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Лабораторная работа № 1 

Аппаратные и программные средства отладки eZDSP F2812 и  

Code Composer Studio 

 

Цель работы: ознакомиться с аппаратной и программной ча-
стью лабораторного оборудования, научиться создавать и отлаживать 

простейшие программы для цифрового сигнального процессора 
TMS320F2812. 

 

Теоретические сведения 

 

Аппаратная часть стенда состоит из платы эмулятора и платы 

расширения, а программная – из среды разработки Code Composer 

Studio.  

На рис. 1.1 представлена плата эмулятора eZDSP320F2812 c 

платой расширения. На плате эмулятора размещен сигнальный про-

цессор TMS320F2812 и схема, обеспечивающая его работу – стабили-

затор напряжения (+3.3В для периферии и +1.9В для ядра), схема 
JTAG-эмулятора, внешнее ОЗУ. Плата эмулятора соединена с платой 

расширения Zwickau Adapterboard, расположенной под ней (рис. 1.1). 

На плате расширения располагаются светодиоды, переключатели, 

кнопки, потенциометры, ЦАП, микросхема FLASH-памяти, датчик 

температуры, микросхемы интерфейсов RS-232 и CAN, звуковой пье-
зоэлектрический преобразователь. Связь эмулятора и ПЭВМ осуще-
ствляется через LPT-порт.  

Code Composer Studio (CCS) – интегрированная среда разработ-
ки для цифровых сигнальных процессоров фирмы Texas Instruments. 
После загрузки программы открывается окно, разделенное на две вер-
тикальные части. В левой части (узкой) отображается окно проекта, в 
правой (широкой) – рабочая область (рис. 1.2). Любой проект 
(Project), кроме файла с выполняемой программой на языке Си или 
Ассемблер, содержит  командные файлы, библиотеки, линкеры. Дан-
ные файлы необходимы для преобразования исходного текста про-
грамм в машинный код, который затем загружается в процессор. 
Файл управления линкером сопоставляет логические сектора (область 
данных, программ) и физическую память сигнального процессора.  
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Рис. 1.1. Плата эмулятора eZDSP и плата расширения Zwickau 

Adapterboard 

 

  
 

Рис. 1.2. Вид рабочего окна Code Composer Studio 
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Процедура линковки объединяет один и более объектные файлы 
(*.obj) в выходной файл (*.out), который содержит машинные коды, 
адреса и отладочную информацию. Проект может содержать более 
одного файла программ и подпрограмм, причем допускается написа-
ние программ и их частей на различных языках (Си, Си++, Макроас-
семблер). Все это позволяет максимально эффективно использовать 
имеющиеся наработки в последующих проектах. Несколько проектов 
могут объединяться в рабочей области, но компилироваться и отла-
живаться будет только один – текущий проект. При выполнении ла-
бораторных работ не рекомендуется открывать сразу несколько про-
ектов. 

 

Ход работы 

 

1. Создание нового проекта. 
Через вкладку меню Project → New создаем новый проект. В по-

ле Project Name записываем название проекта «Lab1». В поле Location 

указывается путь, по которому будет находиться проект – 

E:\DspUser\Lab1. В поле Project Type выбираем Executable (.out), а в 

поле Target – TMS320C28XX. В случае если плата эмулятора про-

граммно не подключена к ПЭВМ, осуществляем подключение через  
вкладку меню Debug → Connect. 

 

2. Создание файла программы.  

Через вкладку меню File → New → Sourse File создаем файл. 

Содержимое файла отображается в рабочей области программы. Да-
лее заносим (копируем) в него тестовую программу, представленную 

на рис. 1.3. Затем необходимо сохранить в папке для проекта, вы-

бранной в п. 1, написанную программу под именем «lab1.c» через 
вкладку меню File → Save as: «lab1.c». 

 
unsigned int k; 
void main (void) 
{ 
unsigned int i; 
while(1) 
{ 
for (i=0;i<100;i++) 
k=i*i; 
} 
} 

Рис. 1.3. Тестовая программа 
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3. Добавление файлов в проект. 
Сохраненный файл еще не является частью проекта и при ком-

пиляции проекта не будет учтен. Его необходимо добавить в проект 
через вкладки меню Project → Add files to Project, где указывается имя 

файла: «lab1.c». После этого имя данного файла появится в разделе 
«Source» окна проекта. Кроме файла программы, через вкладку меню 

Project → Add files to Project необходимо добавить в проект файл 

управления линкером и библиотеки: 

 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 
C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 
 

Рекомендуется здесь и далее в аналогичных случаях для исклю-

чения ошибок полные пути к файлам копировать в диалоговое окно 

«Add files to Project». 

 

4. Компиляция программы. 

Компилируя программу, мы проверяем её на наличие синтакси-

ческих ошибок. Для этого выбираем вкладку меню Project → Compile 

File (горячие клавиши Ctrl+F7) или иконку . В случае удачной 

компиляции в статусной строке будет выдано сообщение об отсутст-
вии ошибок: 

«Compile Complete, 

  0 Errors, 0 Warnings, 0 Remarks.» 

 

5. Добавление библиотек и создание стека. 
Подключаем Си-библиотеки: 

Project → Build Options → Linker → Libraries → Search Path: 

C:\CCStudio_v3.3\C2000\cgtools\lib 

Project → Build Options → Linker → Libraries → Search Path Linker → 

Incl. Libraries: rts2800_ml.lib 
 

 Задаем глубину стека 0х400: 
Project → Build Options → Linker → Basic → Stack Size (-stack): 0x400 
(здесь и далее в формате записи числовых значений префикс «0x» оз-
начает hex-формат). 
 

 6. Компоновка и загрузка выходного файла в отладочный мо-

дуль eZDSP. 
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Для компоновки выбираем Project → Build (горячая клавиша F7) 

или . Открывается окно, в котором указывается наличие или отсут-
ствие ошибок, предупреждений и замечаний. Результатом компонов-

ки будет файл в hex-коде, содержащий коды программ и необходи-

мую отладочную информацию. Далее необходимо загрузить создан-

ный файл в эмулятор-отладчик через вкладку меню: File→Load Pro-

gram→Debug\lab1.out. После этого тестовая программа загрузится в 

память ЦСП, расположенного на плате эмулятора. Функцию загрузки 

готового out-файла в память ЦСП можно настроить автоматически, 

включив опцию Load Program After Build через меню Op-

tion→Customize→Program/Project/CIO. 

Замечания:  

1) Имя выходного файла генерируется по имени проекта, а не 
имени файла программы.  

2) При модификации программы необходимо каждый раз ком-

поновать и загружать программу в память процессора. 
 

 7. Сброс сигнального процессора и запуск программы на выпол-

нение. 
 Для правильного выполнения программы необходимо произве-
сти сброс процессора и его перезапуск. Для этого последовательно 

выполняются директивы Debug → Reset CPU (горячие клавиши 

Ctrl+R) и Debug → Restart (горячие клавиши Ctrl+Shift+F5) . 

Затем с помощью директивы Debug → Go Main (горячая клави-

ша Ctrl+M) устанавливаем программный счетчик на точку «void 

main (void)» основной программы. Директива Go Main позволяет 
выполнить начальную установку процессора, генерируемую компи-

лятором языка Си. Положение программного счетчика отображается 

желтой стрелкой у левого края рабочей области. 

Запуск программы на выполнение может осуществляться в по-

шаговом  и в автоматическом режимах.  

Запуск программы в автоматическом режиме осуществляется 

через вкладку меню Debug → Run (горячая клавиша F5) или с помо-

щью иконки  . При этом в строке статуса внизу рабочей области 

индицируется зелёная лампочка и появляется надпись Running. Оста-
новить выполнение программы можно через вкладку меню Debug → 

Halt (горячие клавиши Shift+F5) или .  
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Пошаговая отладка осуществляется с помощью Debug → Step 

Into или горячей клавиши F11. Нажимая функциональную клавишу 

F11, понаблюдайте за ходом выполнения программы. 

 

8. Просмотр переменных. 

Для просмотра переменных используется вкладка меню View → 

Watch Window или . В колонке Name задается имя переменной, в 

нашем случае там могут быть записаны переменные i и k (для добав-

ления переменной можно, выделив ее, воспользоваться в контекстном 

меню опцией Add to Watch Window). В колонке Value отображаются 

сами переменные, причем после каждой их модификации вручную 

или исполняемой программой они выделяются красным цветом в те-
чение одного такта отладки. В колонке Type отображается тип пере-
менной (целый, вещественный и т.д.), а в колонке Radix – задается 

формат представления чисел (десятичный, двоичный, шестнадцате-
ричный и пр.).  В окне Watch Window также можно просматривать 

также содержимое всех программно доступных регистров ЦСП. Для 

этого необходимо навести мышь на область окна, щелкнуть правой 

кнопкой мыши, из открывшегося списка выбрать «Add Globals to 

Watch», и поставить отметку напротив той группы регистров ЦСП, 

которую следует просматривать в ходе выполнения программы. 

 

9. Использование точки останова (Breakpoint). 

Точки останова (Breakpoint) в Code Composer Studio использу-

ются для удобства отладки программ. Для установки Breakpoint уста-
навливаем курсор на строку, на которой должно остановиться выпол-

нение программы, щелкаем на , строка выделяется красной точ-

кой. Запускаем программу (F5) и видим, что её выполнение останови-

лось на выделенной строке (желтая стрелка). Чтобы снять все Break-

point, необходимо щелкнуть на иконку . При достижении точки 

Breakpoint  в автоматическом режиме (Run) обновление переменных в 

окне Watch происходит дискретно с остановкой программы (далее 
требуется перезапуск). 

Измените исходную программу (рис. 1.3) так, как показано на 
рис. 1.4. 
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unsigned int k; 
void main (void) 
{ 
unsigned int i; 
while(1) 
{ 
for (i=0;i<100;i++) 
{ 
k=2; 
k=i*i; 
} 
} 
} 

Рис. 1.4. Измененная тестовая программа 
 

 

10. Режим Animate. 

Режим Animate используется для отслеживания содержимого 

регистров и переменных. Для его запуска необходимо нажать Debug 

→ Animate (горячие клавиши Shift+F5) или . Скорость анимации 

устанавливается в окне Option → Customize → Debug Properties → 

Animate Speed. Установите скорость анимации, равную 1 сек.  

 

11. Просмотр содержимого регистров. 

Содержимое регистров процессора  можно отследить, выбрав 

вкладку меню View → Registers → CPU Register и View → Registers 

→ Status Register. Чтобы изменить значение регистра, необходимо 

дважды щелкнуть по его содержимому и ввести новое значение. 
 

Задание для самостоятельной работы 

 

1. Установите Breakpoint на строки 7, 9 и 10 измененной тесто-

вой программы, показанной на рис. 1.4. Перезапускайте программу в 

автоматическом режиме (Run) после каждой остановки в выполнении 

программы на точках останова. Проследите изменение переменных  

i и k в окне Watch. Объясните полученные результаты. 

2. Не снимая Breakpoint, запустите программу в режиме 
Animate. Проследите выполнение программы, содержимого окна 
Watch (переменные i и k). Объясните полученные результаты.  

3. Открыв окна CPU Register и Status Register, проследите изме-
нение содержимого регистров при выполнении программы в режиме 
Animate. Объясните полученные результаты.  
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4. Не останавливая выполнение программы, откройте окно ас-
семблированного кода программы, полученного в результате компо-

новки (Window → Disassembly). Объясните полученные результаты. 

Вернитесь в окно исходного кода программы, написанной на языке 
Си (Window → Lab1.c). Остановите выполнение программы. Снимите 
все Breakpoint. 

 

 

Содержание отчета: 

 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, тексты тестовых программ, результаты их 

выполнения, выводы. 

 

 

Контрольные вопросы: 

 

1. Структура платы эмулятора eZDSP320F2812 и платы расшире-
ния Zwickau Adapterboard. 

2. Среда разработки Code Composer Studio. Создание, компиляция, 

компоновка и загрузка проекта. 
3. Среда разработки Code Composer Studio. Режимы запуска про-

грамм. 

4. Среда разработки Code Composer Studio. Просмотр переменных.  

5. Среда разработки Code Composer Studio. Использование точки 

останова (Breakpoint). 

6. Среда разработки Code Composer Studio. Просмотр содержимого 

регистров ЦСП. 

7. Каким образом осуществить отладку исследуемой программы в 

пошаговом режиме: 
- без исследования ассемблерного кода; 
- с исследованием ассемблерного кода; 
- с одновременным исследованием исходного текста на Си и 

соответствующего ему ассемблерного кода. 
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Лабораторная работа № 2 
 Изучение карты памяти, структуры цифровых портов ввода/ 

вывода и системы тактирования ЦСП TMS320F2812 
 

Цель работы: изучить карту памяти, структуру цифровых пор-
тов ввода-вывода и системы тактирования ЦСП, научиться выполнять 
настройку данных модулей, вводить и выводить цифровые сигналы. 

 
Теоретические сведения 

 
Структурная схема ЦСП семейства C28x приведена на рис. 2.1. 

Память и все периферийные модули объединены системой шин по 
модифицированной гарвардской архитектуре. 

 

 

Рис. 2.1. Структурная схема ЦСП семейства C28x 
 
Карта адресного пространства ЦСП C28x показана на рис. 2.2. В 

качестве памяти данных используется исключительно ОЗУ быстрого 
доступа (Single Access RAM – SARAM, доступ возможен в течение 
каждого машинного цикла) общим объёмом 18 Кслов,  состоящее из 
нескольких банков – М0, M1 (2x1К), L0, L1 (2x4К) и Н0 (8К). Каждый 
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банк отображается и на память программ, и на память данных, т.е. эту 
память можно использовать и  в качестве памяти программ, и в каче-
стве памяти данных. В сигнальных процессорах F2812 объём встро-
енной флэш-памяти составляет 128 Кслов (4 сектора по 8К и 6 секто-
ров по 16К). 

В процессоре C28x, помимо центрального процессорного уст-
ройства (CPU) имеется внутренняя периферия (АЦП, таймеры, встро-
енные интерфейсы и пр.), которая также располагается на кристалле. 
ЦСП семейства С28x содержат регистры модуля центрального про-
цессора (регистры CPU), необходимые для арифметиче-
ской/логической обработки данных и три сегмента (фрейма) регист-
ров встроенной периферии, предназначенных для управления режи-
мами и хранения данных внутренних периферийных устройств. Эти 
регистры расположены прямо в адресном пространстве памяти, т.е. 
доступны не только как регистры с именами, но и как ячейки памяти 
с определенными адресами (см. рис. 2.2).  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Рис. 2.2. Карта адресного пространства ЦСП семейства C28x 
 
Peripheral Frame 0 (PF0, объем 2K, адреса 0x00 0800… 

0x00 0FFF) – включает в себя регистры внешнего интерфейса памяти 
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XINTF, модуля расширения прерываний PIE, модуля Flash-памяти, 
модуля таймеров ядра, модуля ключа защиты CSM; 

Peripheral Frame 2 (PF2, объем 4K, адреса 0x00 6000…0x00 6FFF) – 
включает в себя регистры интерфейса eCAN; 

Peripheral Frame 1 (PF1, объем 4K, адреса 0x00 7000… 
0x00 7FFF) – включает в себя регистры модуля управления системой, 
модуля ввода-вывода GPIO, модуля менеджеров событий EVA/EVB, 
модуля последовательного интерфейса McBSP, модуля последова-
тельного интерфейса SCI, модуля последовательного интерфейса SPI, 
модуля АЦП. 

Все программно доступные цифровые выводы сгруппированы в 
порты GPIOA, GPIOB, GPIOD, GPIOE, GPIOF, GPIOG. GPIO (general 
purpose input/output) означает «линии ввода/вывода общего назначе-
ния». 

Периферия имеет выводы, использующиеся для ввода/вывода 
сигналов. Чтобы не загромождать ЦСП дополнительными выводами, 
используют мультиплексирование: на одном выводе могут быть реа-
лизованы две и более различные функции, которые выбираются про-
граммным путем. На рис. 2.3 приведены основные и альтернативные 
функции портов. 

 

 

Рис. 2.3. Основные и альтернативные функции портов ввода-
вывода F2812 
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Все 6 портов управляются своими мультиплексирующими реги-
страми (GPxMUX, здесь и далее в именах регистров, относящихся к 
портам, x – имя порта). Если бит сброшен в 0, то данный вывод рабо-
тает как обычная линия порта; установкой бита в 1 выбирается аль-
тернативная функция, т.е. линия порта (pin) подключается к соответ-
ствующему периферийному устройству (см. рис. 2.4). К регистрам 
данных относятся: 

- регистры GPxDAT (в них непосредственно хранятся данные 
порта, которые могут быть изменены записью в данные регистры); 

- регистры GPxSET (служат для установки соответствующих 
разрядов порта); 

- регистры GPxCLEAR (служат для сброса соответствующих 
разрядов порта); 

- регистры GPxTOGGLE (служат для переключения соответст-
вующих разрядов порта в альтернативное логическое состояние). 

 

 
  

Рис. 2.4. Функциональная схема линии GPIO 
 
Каждый вывод порта может работать на ввод или вывод. На-

правление передачи данных задается битами в регистрах  GPxDIR:  
0 – линия работает на ввод, 1 – на вывод данных. При работе портов 
A, B, D и E на ввод для увеличения помехозащищенности можно на-

 

 

Периферийная 

функция 
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строить функцию задержки ввода (Input Qualification feature) установ-
кой битов 7-0 в соответствующем регистре GPxQUAL. После этого 
импульсы на линиях соответствующих портов, имеющие максималь-
ную длительность от 2 (GPxQUAL=0x01) до 510 (GPxQUAL=0xFF) пе-
риодов частоты тактирования ядра SYSCLKOUT, не будут распозна-
ваться ядром процессора. 

Перед началом работы необходимо настроить модуль тактиро-
вания. Как и многие современные процессоры, ЦСП семейства С28х 
используют внешний резонатор или генератор с частотой более низ-
кой, чем максимальная тактовая. Это позволяет уменьшить влияние 
электромагнитных помех, понизить требования к разводке печатной 
платы и повысить надежность работы схемы. Частота тактового гене-
ратора OSCCLK, расположенного на плате эмулятора, составляет  
30 МГц. Максимальная тактовая частота процессора 150 МГц получа-
ется путем умножения внешней частоты на 5 (OSCCLK*10/2, см. рис. 
2.5). Коэффициент деления задается программно в регистре PLLCR.  
 

 
Рис. 2.5. Тактовый модуль и регистр PLLCR 

 
Помимо формирователя тактовой частоты ядра, тактовый мо-

дуль содержит предделители: низкоскоростной LOSPCP и высокоско-

ростной HISPCP (рис. 2.6), которые используются для тактирования 

периферийных устройств. 
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Известно, что потребляемая мощность микропроцессорных эле-
ментов возрастает пропорционально тактовой частоте. Снижая такто-

вую частоту, можно снизить энергопотребление и определенного моду-

ля, и всего ЦСП в целом. Коэффициенты деления задаются программно 

в регистрах LOSPCP и HISPCP. 

 

Рис. 2.6. Формат регистров HISPCP и LOSPCP 

В ЦСП семейства С28х реализована возможность не только из-
менять, но и полностью запрещать/разрешать тактирование различных 

периферийных модулей при помощи регистра PCLKCR (рис. 2.7). 

 

 
 

EVAENCLK Разрешение HSPCLK в EVA  

EVBENCLK  Разрешение HSPCLK в EVВ  

ADCENCLK  Разрешение HSPCLK в АЦП (ADC)  

SPIAENCLK  Разрешение LSPCLK в SPI  

SCIAENCLK  Разрешение LSPCLK в SCI-A  

SCIBENCLK  Разрешение LSPCLK в SCI-B  

MCBSPENCLK  Разрешение LSPCLK в McBSP  

ECANENCLK  Разрешение тактирования eCAN 

Рис. 2.7. Формат регистра PCLKCR: 1 – разрешить тактирование 
периферийного модуля; 0 – запретить. 
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Сторожевой таймер (Watchdog timer или WDT, рис. 2.8) предна-
значен для предотвращения «зависания» ядра ЦСП и реализован на 
основе суммирующего счетчика WDCNTR, который тактируется че-
рез счетчик-делитель от внешнего генератора и при переполнении 

вырабатывает сигнал прерывания WDINT либо сброса ядра ЦСП 

WDRST (задается программно). WDT работает независимо от ядра 
ЦСП и должен сбрасываться программно для предотвращения сброса 
процессора. 

Сторожевой таймер защищен ключом «101», и, в случае записи в 

биты WDCHK 2–0 регистра WDCR (рис. 2.9) любой иной кодовой 

комбинации, в следующем машинном цикле происходит генерация 

выходного сигнала (такого же, как и при переполнении).  Для предот-
вращения сброса ЦСП необходимо периодически программно сбра-
сывать счетчик WDCNTR при помощи записи последовательности 

кодов «0x55 + 0xAA» в специальный регистр WDKEY. 

 

 
 

Рис. 2.8. Функциональная схема сторожевого таймера 
 

 

Сброс WDT 

WDOVERRIDE 
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Рис. 2.9. Формат регистра управления сторожевого таймера WDCR 

 
Бит WDFLAG используется для того, чтобы указать источник 

сброса:  обычный сброс (WDFLAG=0) или сброс по сторожевому 
таймеру (WDFLAG=1).  Биты WDPS 2–0 позволяют выбрать необхо-
димый коэффициент деления частоты для работы сторожевого тайме-
ра. Бит WDDIS служит для запрета работы (блокировки) WDT. 

Регистр управления и состояния (System Control and Status  
Register – SCSR, рис. 2.10) управляет сбросом сторожевого таймера. 
Бит WDINTS отражает текущее состояние сигнала WDINT. Бит 
WDENINT – выбор режима действия от WDT (сброс или прерыва-
ние). Если WDENINT=0 – разрешен сигнал сброса WDRST, если 
WDENINT=1 – разрешен сигнал прерывания WDINT. 

Если бит WDOVERRIDE установлен в 1, то пользователь может 
изменять состояние сторожевого таймера, т.е. запрещать или разре-
шать его работу с помощью бита WDDIS в регистре управления 
WDCR. Особенностью является то, что пользователь может только 
сбросить бит WDOVERRIDE, записав в него «1», установить бит 
программно нельзя.  

 

 
 

Рис. 2.10. Формат регистра управления и состояния SCSR 
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Ход работы 

 

Часть I 

 
В части I лабораторной работы необходимо разработать про-

грамму «бегущие огни», задавая направление движения: сначала – от 
края к краю (см. рис. 2.11, а), а потом, зажигая по два светодиода, – от 
периферии к центру (см. рис. 2.11, б). Светодиоды подключены  к ли-
ниям порта GPIOB7 – GPIOB0 (1 – горит, 0 – погашен), а линии порта 
GPIOB15 – GPIOB8 соединены с ключами (1 – ключ замкнут, 0 – ра-
зомкнут). 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Рис. 2.11. Направление движения светодиодов: а) – слева напра-

во и наоборот; б) – от периферии к центру и наоборот. 
 

1. Создание нового проекта. 
В Code Composer Studio создаем новый проект Lab2.pjt. В поле 

Project Name записываем название проекта «Lab2». В поле Location 
указывается путь, по которому будет находиться проект – 
E:\DspUser\Lab2. 

а) 

0 1 2 3 4 5 6 7 
GPIOB

0 1 2 3 4 5 6 7 
GPIOB

б) 
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1.1. Для упрощения работы файл под именем «_lab2_.c» с заго-
товкой текста программы имеется на диске в папке 
«E:\DspUser\Templates». Знаками «?» в исходном тексте программы 

отмечены значения, которые необходимо будет заменить на требуе-
мые для правильной работы программы (рис. 2.12). Копируем данный 
файл в папку проекта E:\DspUser\Lab2 и переименовываем в «Lab2.c». 
Добавляем в проект и открываем в окне редактора данный файл:  
Project → Add files to Project.   

1.2. Добавляем в проект управляющий файл линкера, команд-
ные файлы, библиотеки, необходимые внешние программные модули 
(рекомендуется для исключения ошибок пути к файлам, указанные 
ниже, копировать в диалоговое окно «Add files to Project»): 

 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\cmd\DSP281x_Headers_nonBIOS.cmd 
C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\source\DSP281x_GlobalVariableDefs.c 

 
2. Настройка параметров проекта. 
2.1. Включаем в проект заголовочные файлы, для этого выбира-

ем Project →  Build Options, в закладке Compiler выбираем Preproces-
sor и в поле Include Search Path (-i) вводим:  

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include 
2.2. Добавление библиотек и создание стека. 
Подключаем Си-библиотеки: 

Project → Build Options → Linker → Libraries → Search Path: 
C:\CCStudio_v3.3\C2000\cgtools\lib 
Project → Build Options → Linker → Libraries → Search Path Linker → 
Incl. Libraries: rts2800_ml.lib 

Задаем глубину стека 0х400: 
Project → Build Options → Linker → Basic → Stack Size (-stack): 0x400 
 
//################################################################## 
// Имя файла: _Lab2_.c 
// 
// Описание: С помощью 8 светодиодов, подключенных к линиям  
// порта GPIOB0 - GPIOB7, формируются "бегущие огни". 
// Направление движения справа - налево и наоборот 
//################################################################## 
 
#include "DSP281x_Device.h" // Включение заголовочного файла 
 
void delay_loop(long); 
void Gpio_select(void); 
void InitSystem(void); 
 
void main(void) 
{ 
 unsigned int i; 
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 unsigned int LED[8]= {0x0001,0x0002,0x0004,0x0008, 
                       0x0010,0x0020,0x0040,0x0080};  
  
 InitSystem();  // Инициализация регистров ЦСП 
 Gpio_select();  // Инициализация линий ввода/вывода  
  
while(1) 
 {     
       for(i=0;i<14;i++) 
    { 
          if(i<7)  GpioDataRegs.GPBDAT.all = LED[i]; 
          else   GpioDataRegs.GPBDAT.all = LED[14-i];  
          delay_loop(?); 

      } 
     } 
}   
 
//################################################################## 
// Подпрограмма: delay_loop 
// 
// Описание: Формирование временной задержки горения светодиодов 
//################################################################## 
 
void delay_loop(long end) 
{ 
 long i; 
 for (i = 0; i < end; i++); 
 EALLOW; // Сброс сторожевого таймера 
 //SysCtrlRegs.WDKEY = 0x?; 
 //SysCtrlRegs.WDKEY = 0x?; 
 EDIS; 
} 
 
//################################################################## 
// Подпрограмма: Gpio_select 
// 
// Описание: Настройка линий порта GPIO B15-8 на ввод, а линий  
// B7-0 на вывод. Настройка всех линий портов A, D, F, E, G на  
// ввод. Запрещение работы входного ограничителя 
//################################################################## 
 
void Gpio_select(void) 
{ 
 EALLOW; 
    GpioMuxRegs.GPAMUX.all = 0x?; // Настройка линий ввода/вывода на 
    GpioMuxRegs.GPBMUX.all = 0x?; // работу в качестве портов    
    GpioMuxRegs.GPDMUX.all = 0x?; 
    GpioMuxRegs.GPFMUX.all = 0x?;    
    GpioMuxRegs.GPEMUX.all = 0x?;  
    GpioMuxRegs.GPGMUX.all = 0x?;   
    GpioMuxRegs.GPADIR.all = 0x?; // Настройка портов А, D, E, F, G  

  // на ввод 
    GpioMuxRegs.GPBDIR.all = 0x?; // Настройка линий 15-8 на ввод,  
    GpioMuxRegs.GPDDIR.all = 0x?; // а линий 7-0 на вывод 
    GpioMuxRegs.GPEDIR.all = 0x?;  
    GpioMuxRegs.GPFDIR.all = 0x?;  
    GpioMuxRegs.GPGDIR.all = 0x?;  
 
    GpioMuxRegs.GPAQUAL.all = 0x?; // Запрещение входного ограничителя 
    GpioMuxRegs.GPBQUAL.all = 0x?; 
    GpioMuxRegs.GPDQUAL.all = 0x?; 
    GpioMuxRegs.GPEQUAL.all = 0x?; 
    EDIS; 
}      
 
 

7 

5 

6
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//##################################################################### 
// Подпрограмма: InitSystem 
// 
// Описание: Настройка сторожевого таймера на работу, 
//  предделитель = 1. Выработка сброса сторожевым  
//  таймером. Внутренняя частота работы ЦСП 150 МГц. 
//  Запись в предделитель высокоскоростного таймера  
//  коэффициента деления 2, а в предделитель 
//  низкоскоростного таймера - 4. Запрещение работы  
//  периферийных устройств 
//##################################################################### 
 
void InitSystem(void) 
{ 
    EALLOW; 
    SysCtrlRegs.WDCR= 0x?;  // Разрешение работы сторожевого    
      // таймера, предделитель = 64 
      // или запрещение работы  сторо- 
      // жевого таймера, предделитель = 1 
  
    SysCtrlRegs.SCSR = ?;   // Конфигурирование сброса ЦСП от WDT
  

    SysCtrlRegs.PLLCR.bit.DIV = ?;// Настройка блока умножения частоты 
      SysCtrlRegs.HISPCP.all = 0x?;// Задание значений высокоскоростного 

SysCtrlRegs.LOSPCP.all = 0x?; // и низкоскоростного предделителей  
       

 
    SysCtrlRegs.PCLKCR.bit.EVAENCLK=?; // Запрещение работы 
    SysCtrlRegs.PCLKCR.bit.EVBENCLK=?; // периферийных устройств 
    SysCtrlRegs.PCLKCR.bit.SCIAENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SCIBENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.MCBSPENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SPIENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ECANENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ADCENCLK=?; 
    EDIS; 
} 

 
 

Рис. 2.12. Заготовка текста программы «бегущие огни» 
 
3. Инициализация системы. 
Открываем файл Lab2.c и переходим к подпрограмме  

«InitSystem()». 

 3.1. Присваивая необходимое значение регистру WDCR (см. 
рис. 2.9), запрещаем работу сторожевого таймера (WDDIS=0), сбра-
сываем бит WDFLAG, задаем коэффициент деления частоты тактиро-
вания Watchdog-таймера, равный 1 (WDPS0, WDPS1, WDPS2=0). 
Указанные значения нужно  внести в область 1 программы  
(см. рис. 2.12). 
 3.2. Программируем регистр SCSR (см. рис. 2.10) на сброс про-
цессора при переполнении Watchdog-таймера. В бит WDENINT запи-
сываем «0», в бит WDOVERRIDE также записываем «0» для того, 
чтобы оставить его в единичном состоянии (см. область 2 на  
рис. 2.12). 

1

2 

3

4
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 3.3. В регистр PLLCR (см. рис. 2.5) заносим код, необходимый 
для преобразования частоты кварцевого резонатора 30 МГц во внут-
реннюю частоту SYSCLKOUT работы процессора 150 МГц (см. об-
ласть 3 на рис. 2.12). 
 3.4. Заносим в высокоскоростной предделитель HISPCP  
(см. рис. 2.6) коэффициент деления 2, а в низкоскоростной (LOSPCP) 
– 4 (см. область 3 на рис. 2.12). 
 3.5. Установкой-сбросом бит в регистре PCLKCR (см. рис. 2.7) 
запрещаем работу всех периферийных устройств (см. область 4 на 
рис. 2.12). 
 
 4. Настройка портов. 
Переходим к подпрограмме «Gpio_select()». 

 4.1. Установкой-сбросом бит в регистрах GPxMUX настраиваем 
все выводы на работу в качестве портов (см. область 5 на рис. 2.12). 
 4.2. Установкой-сбросом бит в регистрах GPxDIR настраиваем 
все линии портов A, D, E, F, G на ввод (см. область 5 на рис. 2.12).  
В порту GPIOB настраиваем линии порта GPIOB15 – GPIOB8 на ввод, 
а GPIOB7 – GPIOB0 на вывод (см. область 5 на рис. 2.12). 
 4.3. Сбрасываем все биты регистров GPxQUAL портов A, B, D, 
E  в ноль (см. область 5 на рис. 2.12). 
 

5. Расчет и задание временной задержки 
В строке «delay_loop()» (см. область 6 на рис. 2.12) в скоб-

ках указываем число n – параметр задержки. Длительность задержки 
будет пропорциональна данному числу и рассчитывается по формуле 
(в секундах): 
 

610150

6

⋅
⋅

=
n

tзд . 

 
6. Компиляция, компоновка и загрузка выходного файла в отла-

дочный модуль ЦСП. 
6.1. Компилируем программу: Project → Compile File. При нали-

чии ошибок, исправляем их. 
6.2. Компонуем проект: Project → Build. При наличии ошибок, 

исправляем их. 
6.3. Загружаем выходной файл: File → Load Program → Debug\ 

lab2.out (в случае, если данная функция сконфигурирована для вы-
полнения автоматически, выполнять данный пункт не нужно).  
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 7.  Тестирование программы.  
7.1. Сбрасываем ЦСП: Debug → Reset CPU, Debug → Restart. 

 7.2. Устанавливаем программный счетчик на точку «void 
main (void)» основной программы: Debug → Go main. 

7.3. Запускаем программу: Debug → Run. Проверяем правиль-
ность работы, наблюдая за светодиодами. 

Имеется возможность отслеживать правильность выполнения 
логики программы, просматривая в отдельном окне, как изменяется 
содержимое выводов порта GPIOB. Для этого необходимо: 

- остановить выполнение программы; 
- установить точку останова на строку программы, отмеченную 

знаком «●»; 
- выделить мышью в любом месте текста программы  название 

«GpioDataRegs.GPBDAT», нажать правую кнопку мыши и в открыв-
шемся окне выбрать «Add to Watch Window»; 

- щелкнуть по значку «+» напротив имени 
«GpioDataRegs.GPBDAT» в окне Watch Window, далее выбрать «bit», 
после чего в данном окне будут выведены в столбик двоичные со-
стояния разрядов порта GPIOB (рис. 2.13); 

- исключить из программы (закомментировать) задержку, вста-
вив символы «//» в начало строки  delay_loop(?); 

- сохранить проект (Project → Save), выполнить компиляцию и 
линковку измененного проекта; 

- запустив программу в режиме «Animate», наблюдать последо-
вательность изменения логических уровней на линиях порта GPIOB. 

 
8. Работа со сторожевым таймером. 
8.1. Останавливаем выполнение программы. 
8.2. В подпрограмме «InitSystem()» изменением содержи-

мого регистра WDCR разрешаем работу сторожевого таймера (см. об-
ласть 1 на рис. 2.12). В битовом поле WDPS этого регистра задаем ко-
эффициент деления программного предделителя равным 64 (см. рис. 
2.8, 2.9). 

8.3. В подпрограмме временной задержки «delay_loop()» 

удаляем символы «//» перед двумя строками программы, в которых 
должна производиться запись в регистр WDKEY (см. область 7 на 
рис. 2.12), и записываем кодовую комбинацию для сброса Watchdog-
таймера: SysCtrlRegs.WDKEY = 0x55, SysCtrlRegs.WDKEY 
= 0xAA. 

Расчетное время до формирования импульса сброса /WDRST от 
Watchdog-таймера в выбранном режиме составит: 
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Для того чтобы сброс WDT происходил раньше (т.е. сброса 

ЦСП не происходило), нужно обеспечить соотношение tзд ≤ tWDRST. 
8.4. Компилируем, компонуем проект и тестируем программу. 
 

 
 

Рис. 2.13. Просмотр состояния двоичных разрядов порта GPIOB 
в окне Watch Window 

 
9. Работа с двумя светодиодами. 

 9.1. Копируем содержимое файла «Lab2.c» в новый файл, кото-
рый называем «Lab2a.c».  

9.2. Преобразуем программу Lab2a.c так, чтобы одновременно 
зажигались два светодиода в направлении от периферии к центру  
(см. рис. 2.11, б). 

9.3. Добавляем в проект «Lab2a.c» и удаляем «Lab2.c» (щелкаем 
правой клавишей мышки и выбираем Remove from project). 

9.4. Компилируем, компонуем проект и тестируем программу. 
 

Часть II 
  

В части II лабораторной работы необходимо положение ключей 
отражать на светодиодах (ключ замкнут – светодиод горит, разомкнут 
– погашен), а также положением ключей задавать длительность све-
чения светодиодов. 
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1. Отображение состояния ключей на светодиодах. 
1.1. Копируем содержимое файла «Lab2а.c» в новый файл, кото-

рый называем «Lab2b.c».  
1.2. Преобразуем программу Lab2b.c. Состояние (двоичный код), 

установленный ключами, должен индицироваться на светодиодах. С 
учетом того, что для подключения и светодиодов, и ключей использу-
ется один и тот же порт (GPIOB), состояние ключей можно индициро-
вать, введя в основную программу команду циклического сдвига со-
держимого порта GPIOB на 8 бит: 

 
GpioDataRegs.GPBDAT.all = GpioDataRegs.GPBDAT.all >> 8 
 

Удаляем таблицу состояния светодиодов, а подпрограммы  
«InitSystem()» и «Gpio_select()» оставляем без изменений. 

1.3. Добавляем в проект «Lab2b.c» и удаляем «Lab2a.c».  
1.4. Компилируем, компонуем проект и тестируем программу. 
 
2. Формирование длительности свечения светодиодов в зависи-

мости от состояния ключей. 
2.1. Копируем содержимое файла «Lab2.c» в новый файл, кото-

рый называем «Lab2c.c».  
2.2. Преобразуем программу Lab2c.c. Задаем длительность за-

держки при  переключении  светодиодов  согласно рис. 2.11, а,  рав-
ную (0,1*N+0,001) сек, где N – код, заданный переключателями на 
линиях B15–B8. Подпрограммы «InitSystem()» и 

«Gpio_select()» оставляем без изменений. 

2.3. Добавляем в проект «Lab2c.c» и удаляем  «Lab2b.c».  
2.4. Компилируем, компонуем проект и тестируем программу. 

 

 

Содержание отчета: 

 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, тексты исследуемых программ, результаты 

их выполнения, выводы. 

 

 

Контрольные вопросы: 

 

1. Структурная схема ЦСП семейства C28x. 
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2. Карта адресного пространства ЦСП C28x. 

3. Структура портов ввода/вывода, режимы работы, регистры управ-

ления. 
4. Вывод простейших управляющих сигналов через порты 

TMS320F2812. 

5. Система тактирования TMS320F2812. Структура, особенности, 

назначение регистров высокоскоростного и низкоскоростного 

предделителей. 

6. Watchdog timer: назначение, принцип действия, особенности. 

7. Какие изменения необходимо внести в исходный текст, чтобы 

программа «бегущие огни» запускалась по нажатию кнопки, 

присоединенной к линии порта GPIOD1, а останавливалась – по 

нажатию кнопки, присоединенной к линии порта GPIOD6  

(«0» – соответствующая кнопка нажата, «1» – кнопка отжата)?  

В исходном состоянии обе кнопки отжаты. 

8. Модифицируйте исходную программу таким образом, чтобы 

происходило движение одного «погашенного» светодиода среди 

остальных «горящих». 
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Лабораторная работа № 3 

Исследование системы прерываний и таймеров ядра 

ЦСП семейства C28х 

 

Цель работы: изучить систему прерываний процессоров семей-

ства С28х, а также таймеры ядра ЦСП.  Научиться создавать про-

граммы, использующие прерывания.  

 

Теоретические сведения 

 

Система прерываний ядра процессора C28x содержит  
16 линий прерываний (рис. 3.1). Два из них – немаскируемые (RS, 

NMI). Пользователь не может запретить данные прерывания.  Ос-
тальные 14 прерываний – маскируемые, т.е. пользователь может раз-
решить/запретить прерывания от них программно соответственно ус-
тановкой /сбросом соответствующих бит в регистре IER (Interrupt En-

able Register). Регистр IFR (Interrupt Flag Register) – регистр флагов 

прерываний. При обнаружении прерывания соответствующий бит ре-
гистра IFR защелкивается в единичном состоянии, а после обслужи-

вания прерывания – сбрасывается. Так же, когда аппаратное прерыва-
ние обслужено, или когда выполнена инструкция INTR, сбрасывается 

соответствующий бит регистра IER. 

 

 

Рис. 3.1. Линии прерываний ядра C28х 

 

  

ЯЯддрроо  

CC2288xx  

((CCoorree))  
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Общая структура прерываний ядра C28x показана на рис. 3.2, а 
форматы регистров IER и IFR – на рис. 3.3. Следует отметить, что 

программная установка одного из битов в регистре IFR приведет к 

обработке данного прерывания ядра таким же образом, как и в случае 
возникновения соответствующего прерывания. INTM – младший бит 
в статусном регистре ST1, служит для общего разрешения/запрета 
маскируемых прерываний ядра. 

 
 

Рис. 3.2. Общая структура прерываний ядра C28x 

 

 
 

 
Рис. 3.3. Форматы регистров IER и IFR 

 

Все 16 прерываний однозначно связаны в памяти с таблицей 

векторов прерываний ядра BROM vector (см. рис. 2.2), содержащей 

22-битные адреса (на каждое прерывание – 16 бит в ячейке с млад-

IFR   IER        INTM 

 

 

Ядро 

C28x 

Прерывание ожидает разрешения: IFRBit=1 

Прерывание отсутствует: IFRBit=0 

Прерывание разрешено: IERBit=1 

Прерывание запрещено: IERBit=0 
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шим адресом и 6 бит в ячейке со старшим адресом), по которым 

должны располагаться стартовые адреса подпрограмм обработки со-

ответствующих прерываний. Всего данная область памяти содержит 
32 таких вектора, т.к. к 16 прерываниям ядра добавлены прерывания 

DLOGINT, RTOSINT, Illegal (недопустимая инструкция), 12 про-

граммных прерываний USER1…USER12 и один резервный вектор 

(Reserved).  

Подача активного сигнала на вход сброса (на вывод /RS) вызо-

вет его сброс и перезапуск программы с начального адреса. Сброс от-
личается от остальных прерываний тем, что программа затем не воз-
вращается в исходную точку, а регистры сбрасываются в начальное 
состояние. Сброс может происходить как от внешнего источника, так 

и от сторожевого таймера (WDT). Сброс внешних схем при сбросе 
ядра процессора от WDT осуществляется через вывод /RS, который 

является двунаправленным.  

Особенностью ЦСП семейства C28x является возможность за-
пуска программ как из внутренней памяти (микроконтроллерный ре-
жим), так и из внешней (микропроцессорный режим). Режим опреде-
ляется состоянием вывода XMP/MC (см. рис. 2.2). Соответственно, 

после сброса программа переходит либо к начальному адресу  

0x3F FFC0 внутренней памяти (при XMP/MC=0), либо к тому же ад-

ресу внешней памяти (при XMP/MC=1), а режим запоминается с по-

мощью флага XMP/MC в регистре XINTCNF2, который может быть 

впоследствии обработан программно.  

После сброса в режиме микроконтроллера запускается служеб-

ная программа Bootloader, которая анализирует выводы порта GPIOF 

(GPIOF2, GPIOF3, GPIOF4 и GPIOF12) и, исходя из комбинации сиг-
налов на них, выполняет один из переходов, перечисленных в табл. 

3.1 и условно показанных на рис 3.4. 

В отладочном стенде ezDSP2812, используемом в лабораторных 

работах, программа загружается в H0 SARAM (ОЗУ), а прочие воз-
можные режимы загрузки могут быть заданы при помощи переклю-

чателей (джамперов). Следует отметить, что память программ и дан-

ных имеют единое адресное пространство, программа может выпол-

няться как из ОЗУ, так и из FLASH, или ПЗУ (ОТР). 
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Таблица 3.1. Режимы запуска программы Bootloader 

 

Выводы GPIO 

F4 F12 F3 F2
Режим запуска 

1 x x x 
Передать управление FLASH-памяти по адресу 

0x3F 7FF6 

0 0 1 0 
Передать управление H0 SARAM-памяти по адре-
су 0x3F 8000 

0 0 0 1 
Передать управление OTP-памяти по адресу 

0x3D 7800 

0 1 x x 
Загрузить программу из внешнего EEPROM во 

внутреннюю память через SPI-порт 

0 0 1 1 
Загрузить программу во внутреннюю память через 
SСI-А порт 

0 0 0 0 
Загрузить программу во внутреннюю память через 
параллельный порт GPIOВ 

 

 
Рис. 3.4. Режимы запуска программы Bootloader 

 
ЦСП имеет большое количество источников прерываний – 96, но 

только 16 линий прерываний ядра. Для возможности обслуживания 
всех прерываний для линий INT1…INT12 применяется мультиплекси-
рование (рис. 3.5). Т.к. программный поиск конкретного прерывания в 
линии при обработке программно занял бы длительное время, то при-

Стартовый адрес 
определяется 
состоянием  
линий порта 

GPIOF

Загрузочные  
программы 
(SPI, SCI-A, 
параллельная 
загрузка) 
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меняется специальный аппаратный модуль – Peripheral Interrupt Expan-
sion (PIE), или расширитель прерываний периферии. При работе с PIE 
происходит перенос области векторов:  каждому из 96 прерываний со-
ответствует свой 32-битный адрес в адресном пространстве – таблице 
векторов прерываний расширителя (PIE vector, адреса  
0x00 D000…0x00 DFFF, см. рис. 2.2 и 3.9).  Прерывания сгруппирова-
ны по 8 источников на линию (см. рис. 3.8). Для разрешения/запрета 
каждого прерывания используются биты в регистрах PIEIERx (x может 
принимать значения от 1 до 12), для индикации прерываний – биты в 
регистрах PIEIFRx. Соответствующий бит  в регистре подтверждения 
PIEACK  (активный уровень – 0) определяет номер активного преры-
вания для ядра CPU внутри группы. В результате каждая группа муль-
типлексируется в одно из прерываний ядра INT1…INT12  (рис. 3.6).  

Форматы регистров модуля расширителя прерываний PIEIERx  
и PIEIFRx показаны на рис. 3.7, данные регистры содержат по 8 ин-
формационных бит, т.е. по числу прерываний в группе. В регистре 
PIECTRL биты 15-1 (PIEVECT) показывают адрес в пределах табли-
цы векторов PIE vector, из которой был извлечен вектор. Младший 
значащий бит игнорируется и показываются биты адреса от 1 до 15 
(т.е. только четные адреса), что позволяет при чтении из регистра од-
нозначно определить, какое прерывание генерировалось. ENPIE – 
бит  разрешения извлечения векторов из таблицы PIE-контроллера. 
Если ENPIE=1, все вектора извлекаются из таблицы векторов PIE 
vector, а если ENPIE=0, PIE-контролер запрещен, и вектора извлека-
ются из таблицы CPU-векторов (BROM vector, см. рис. 2.2). 

  

 

 

 

 

 

 

 

 

 

 

 

 

Рис. 3.3. Модуль прерываний С28х. 

 

Рис. 3.5. Логика работы регистров PIEIFRx, PIEIERx, PIEACKx 

x=1…12x=1…12

 
От 

периферии 
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Рис. 3.6. Общая структура расширения прерываний ЦСП С28х 

 

 

 
Рис. 3.7. Формат регистров модуля расширителя прерываний 

ЦСП С28х 
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Таблица векторов прерываний приведена на рис. 3.8.  
Примеры векторов прерываний:  
- прерывание от встроенного АЦП (ADCINT) – INT1.6;  
- прерывание от CPU-таймера 0 (TINT0) – INT1.7. 
 

 

Рис. 3.8. Таблица источников прерываний в PIE 
 

 

Рис. 3.9. Таблица векторов прерываний при ENPIE=1: вектор  
0x00 0D00 не активен, первичные вектора прерывания ядра по адресам  
0x00 0D02 по 0x00 0D1C переадресовываются в область  
0x00 0D40…0x00 0DFE с учетом конкретного источника прерывания 
периферии; вектор извлекается за 9 шагов (машинных циклов ЦСП). 

приоритет
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Рис. 3.10. Полная процедура обработки прерываний при 
ENPIE=1: шаг 1 – генерация прерывания от периферии; шаг 2 – уста-
новка флага PIEIFRx.y = 1; шаг 3а – проверка одновременного нали-
чия двух условий: PIEIERx.y = 1 и PIEACKx=0; шаг 3б – установка в 
«1» бита PIEACKx для подтверждения прерывания от группы x;  
шаг 4 – формирование импульса прерывания по линии INTx на ядро 
(PIEACKx продолжает оставаться в единичном состоянии и требует 
программного сброса для возможности  приема прерывания  ядром по 
линии INTx в дальнейшем); шаг 5 – установка флага IFRx = 1;  
шаг 6 – проверка условия IERx = 1; шаг 7 – проверка условия  
INTM = 1, подготовка адреса возврата и данных к сохранению в сте-
ке; шаг 8 – процессор определяет адрес вектора прерывания в области 
PIE Vector Mapping (адреса с 0x00 0D02 по 0x00 0D1C); шаг 9 – про-
цессор определяет первичный адрес вектора прерывания в области 
PIE Vector Mapping с учетом текущего значения регистров PIEIER и 
PIEIFR (адреса с 0x00 0D40 по 0x00 0DFE). 

 
В сигнальных процессорах семейства С28х имеется три  

32-битных таймера ядра (CPU timers) с одинаковой структурой. Схема 
одного таймера приведена на рис. 3.11.  Работа таймера разрешается 
сбросом бита TCR.4. Таймер имеет 16-битный предварительный де-
литель (прескалер) PSCH: PSC, который формирует счетный импульс 
вычитания из основного 32-битного счетчика TIMH: TIM. По дости-
жении счетчиком TIMH: TIM нуля формируется сигнал прерывания 

ядро 
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/TINT, поступающий на ядро. 16-битный регистр TDDRH: TDDR ис-
пользуется для перезагрузки прескалера таймера.  Регистр  
PRDH: PRD содержит значение основного 32-битного счетчика, пере-
загружаемое в него при очередном переопустошении. Данная каскад-
ная структура позволяет получить очень широкий диапазон коэффи-
циентов деления частоты: от 22

 до 2
48

. 
Таймеры 1 и 2, как правило,  используются для операционной 

системы реального времени «DSP/BIOS», в то время как таймер 0 ис-
пользуется для пользовательских приложений. Данные таймеры ин-
тегрированы в ЦСП, не следует их путать с таймерами менеджеров со-
бытий (EvA и EvB). Необходимо отметить, что после сброса разреша-
ется работа всех трех таймеров ядра. 

 

 

 

 

 

 

 

 

 

 

 

Рис. 3.11. Схема таймера ядра ЦСП семейства C28x (жирной ли-

нией показано прохождение тактового сигнала с делением частоты на 
выход) 

 

Полный набор программно доступных регистров, относящихся к 

таймерам ядра, показан на рис. 3.12. 

Счетчик-предделитель TIMERxPSC и регистр-делитель 

TIMERxTDDR программно доступны как один 16-разрядный регистр 

TIMERxTPR (см. рис. 3.13).  

Аналогично, регистры TIMERxPSCH и TIMERxTDDRH, про-

граммно представляют собой единый 16-битный регистр 

TIMERxTPRH. 
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Рис. 3.12. Регистры таймеров ядра ЦСП семейства C28x 

 

 
 

Рис. 3.13. Формат регистров-прескалеров TIMERxTPR (x = 0, 1, 2) 

 

Функции управления каждым из таймеров реализованы в реги-

страх управления TIMERxTCR, формат которых показан на рис. 3.14. 

Сигналы прерываний, формируемые CPU-таймерами, связаны с 
прерываниями ядра, как показано на рис. 3.15. Прерывание таймера 0 

происходит через PIE, а таймеров 1 и 2 – попадают напрямую на ядро 

через соответствующие линии. 
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Рис. 3.14. Формат регистров управления таймерами ядра 
(TIMERxTCR) 

 

 

 

 

 

 

 

 

 

 

 

 

 

Рис. 3.15. Сигналы прерываний от CPU-таймеров 

 

 

Ход работы 

 

Использование таймера позволяет более эффективно использо-

вать ресурсы процессора. Наиболее простые задачи для таймера – вы-

Флаг прерывания от 

таймера 

(очистка – записью «1») 

Разрешение  
прерывания от таймера 

(«1»-да, «0»-нет) 

Разрешение эмуляции 

(записью «1x») 

Бит перезагрузки  

таймера 

(«1» – перезагрузка) 

Статус таймера 

(«0» – старт, «1» – стоп) 
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зывать на выполнение периодические задачи либо инкрементировать 

глобальную переменную. Данная переменная будет пропорциональна 
машинному времени, прошедшему с момента запуска таймера.  

Для выполнения данной работы следует использовать файл с 
программой из предыдущей работы. Но вместо программной задерж-

ки в этот раз будем использовать аппаратную задержку, формируе-
мую таймером 0 ядра ЦСП. Данный таймер использует систему рас-
ширения прерываний (PIE).  

 

1. Создание нового проекта. 
В Code Composer Studio создаем новый проект Lab3.pjt. В поле 

Project Name записываем название проекта «Lab3». В поле Location 

указывается путь, по которому будет находиться проект – 

E:\DspUser\Lab3. 

1.1. Открываем файл с программой формирования бегущих ог-
ней из лабораторной работы №2  Lab2.с и сохраняем его под именем 

Lab3.с. Затем добавляем файл Lab3.с в проект: Project → Add files to 

Project. 

Структура исходного текста программы показана на рис. 3.16. 
1.2. Добавляем в проект управляющий файл линкера, командные 

файлы, библиотеки, необходимые внешние программные модули (ре-
комендуется для исключения ошибок пути к файлам, указанные ниже, 
копировать в диалоговое окно «Add files to Project»): 

 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\cmd\DSP281x_Headers_nonBIOS.cmd 
C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\source\DSP281x_GlobalVariableDefs.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieCtrl.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieVect.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_DefaultIsr.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_CpuTimers.c 

 
2. Настройка параметров проекта. 
2.1. Включаем в проект заголовочные файлы, для этого выбира-

ем Project →  Build Options, в закладке Compiler выбираем Preproces-
sor и в поле Include Search Path (-i) вводим:  

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include 

2.2. Добавление библиотек и создание стека. 
Подключаем Си-библиотеки: 
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Project → Build Options → Linker → Libraries → Search Path: 

C:\CCStudio_v3.3\C2000\cgtools\lib 

Project → Build Options → Linker → Libraries → Search Path Linker → 

Incl. Libraries: rts2800_ml.lib 

Задаем глубину стека 0х400: 

Project → Build Options → Linker → Basic → Stack Size (-stack): 0x400 

 
//################################################################## 
// Имя файла: Lab3.c 
// 
// Описание: С помощью 8 светодиодов, подключенных к линиям  
//  порта GPIOB0 - GPIOB7, формируются "бегущие огни". 
//  Направление движения справа - налево и наоборот 
//##################################################################### 
 
#include "DSP281x_Device.h" // Включение заголовочного файла 
 
void delay_loop(long); 
void Gpio_select(void); 
void InitSystem(void); 
 
void main(void) 
{ 
 unsigned int i; 
 unsigned int LED[8]= {0x0001,0x0002,0x0004,0x0008, 
                       0x0010,0x0020,0x0040,0x0080};  
  
 InitSystem();  // Инициализация регистров ЦСП 
 Gpio_select();  // Инициализация линий ввода/вывода  
  
while(1) 
 {     
       for(i=0;i<14;i++) 
    { 
          if(i<7)  GpioDataRegs.GPBDAT.all = LED[i]; 
          else   GpioDataRegs.GPBDAT.all = LED[14-i];  
          delay_loop(?); 
      } 
     } 
}   
 
 
 
//##################################################################### 
// Подпрограмма: delay_loop 
// 
// Описание: Формирование временной задержки горения светодиодов 
//##################################################################### 
 
void delay_loop(long end) 
{ 
 long i; 
 for (i = 0; i < end; i++); 
 EALLOW; // Сброс сторожевого таймера 
 SysCtrlRegs.WDKEY = 0x?; 
 SysCtrlRegs.WDKEY = 0x?; 
 EDIS; 
} 
 
 
 
 

1

2

4

3

5 

7
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//##################################################################### 
// Подпрограмма: Gpio_select 
// 
// Описание: Настройка линий порта GPIO B15-8 на ввод, а линий B7-0  
//  на вывод. Настройка всех линий портов A, D, F, E, G на  
//  ввод. Запрещение работы входного ограничителя 
//##################################################################### 
 

void Gpio_select(void) 
{ 
 EALLOW; 
    GpioMuxRegs.GPAMUX.all = 0x?; // Настройка линий ввода/вывода на                    
    GpioMuxRegs.GPBMUX.all = 0x?; // работу в качестве портов    
    GpioMuxRegs.GPDMUX.all = 0x?; 
    GpioMuxRegs.GPFMUX.all = 0x?;    
    GpioMuxRegs.GPEMUX.all = 0x?;  

    GpioMuxRegs.GPGMUX.all = 0x?;    
           
    GpioMuxRegs.GPADIR.all = 0x?; // Настройка портов А, D, E, F, G на ввод 
    GpioMuxRegs.GPBDIR.all = 0x?; // Настройка линий 15-8 на ввод,  
    GpioMuxRegs.GPDDIR.all = 0x?; // а линий 7-0 на вывод 
    GpioMuxRegs.GPEDIR.all = 0x?;  
    GpioMuxRegs.GPFDIR.all = 0x?;  
    GpioMuxRegs.GPGDIR.all = 0x?;  
 

    GpioMuxRegs.GPAQUAL.all = 0x?; // Запрещение входного ограничителя 
    GpioMuxRegs.GPBQUAL.all = 0x?; 
    GpioMuxRegs.GPDQUAL.all = 0x?; 
    GpioMuxRegs.GPEQUAL.all = 0x?; 

    EDIS; 
}      
 
//##################################################################### 

// Подпрограмма: InitSystem 
// 
// Описание: Настройка сторожевого таймера на работу, 
//  предделитель = 1. Выработка сброса сторожевым  
//  таймером. Внутренняя частота работы ЦСП 150 МГц. 
//  Запись в предделитель высокоскоростного таймера  
//  коэффициента деления 2, а в предделитель 
//  низкоскоростного таймера - 4. Запрещение работы  
//  периферийных устройств 
//##################################################################### 
 
void InitSystem(void) 

{ 
    EALLOW; 
    SysCtrlRegs.WDCR= 0x?;  // Разрешение работы сторожевого    
      // таймера, предделитель = 64 
      // или запрещение работы  сторо- 
      // жевого таймера, предделитель = 1 
  
    SysCtrlRegs.SCSR = ?;   // Конфигурирование сброса ЦСП от WDT

  

    SysCtrlRegs.PLLCR.bit.DIV = ?;// Настройка блока умножения частоты 
      SysCtrlRegs.HISPCP.all = 0x?; // Задание значений высокоскоростного   
 SysCtrlRegs.LOSPCP.all = 0x?; // и низкоскоростного предделителей  

6
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    SysCtrlRegs.PCLKCR.bit.EVAENCLK=?; // Запрещение работы 
    SysCtrlRegs.PCLKCR.bit.EVBENCLK=?; // периферийных устройств 
    SysCtrlRegs.PCLKCR.bit.SCIAENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SCIBENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.MCBSPENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SPIENCLK=?; 

    SysCtrlRegs.PCLKCR.bit.ECANENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ADCENCLK=?; 
    EDIS; 
} 

 
 

Рис. 3.16. Структура исходного текста программы 

 

3. Редактирование программы. 

 

3.1. В программе Lab3.c объявляем подпрограмму обработки 

прерываний от  CPU-таймера 0: 
 
interrupt void cpu_timer0_isr(void); 

 

Место вставки – область 1 на рис. 3.16. 

Далее в основной программе добавляем вызов подпрограммы: 
 
InitPieCtrl(); 

 

Место вставки – область 2 на рис. 3.16. 

Данная подпрограмма описана в файле DSP281x_PieCtrl.c, до-

бавленном в проект. Она позволяет очистить флаги и запретить все 
прерывания, что удобно при написании программ. Просмотреть и 

проанализировать содержимое данного файла можно, открыв его в 

другом окне редактора CCS. Аналогичным образом рекомендуется 

далее ознакомиться и с программами, хранящимися в прочих про-

граммных модулях, подключенных к проекту (файлы *.c). 

 

3.2. Непосредственно после вызова подпрограммы  

«InitPieCtrl();» добавляем еще один вызов подпрограммы: 

 
InitPieVectTable(); 
 



 43

Данная подпрограмма инициализирует область векторов PIE в 

начальное состояние. Она использует предварительно заданную таб-

лицу прерываний «PieVectTableInit()», которая определена в файле 
DSP281x_PieVect.c, и копирует эту таблицу в глобальную перемен-

ную «PieVectTable», которая связана с областью памяти процессора 
PIE area.  Также, для использования подпрограммы  

InitPieVectTable, в проект добавлен файл  DSP281x_DefaultIsr.c, 

который добавляет в проект подпрограммы обработки прерываний. 

 

3.3. Необходимо переопределить имя подпрограммы обработки 

прерываний от CPU-таймера 0 на нашу подпрограмму. Для этого в 

основную программу сразу после вызова подпрограммы  

«InitPieVectTable();» добавляем вызов следующих подпро-

грамм: 

 
EALLOW; 
PieVectTable.TINT0 = &cpu_timer0_isr; 
EDIS; 

 

Здесь EALLOW и EDIS – подпрограммы, используемые соот-
ветственно для разрешения и запрета доступа к системным регистрам 

процессора, а  «cpu_timer0_isr» – имя  подпрограммы обработки 

прерываний, описанной в программе ранее. 
 

3.4. Инициализируем CPU-таймер 0. В основную программу не-
обходимо добавить вызов подпрограммы (место вставки – сразу после 
команд, указанных в п. 3.3): 

 
InitCpuTimers(); 
 

Для возможности работы этой подпрограммы в проект добавлен 

файл DSP281x_CpuTimers.c. После этого таймер будет инициализи-

рован и остановлен. 

 

3.5. Необходимо настроить CPU Timer0 для генерации времен-

ных интервалов в 50 мс при тактовой частоте 150 МГц. Для этого сра-
зу после вызова  подпрограммы «InitCpuTimers();» добавляем 

вызов подпрограммы: 
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ConfigCpuTimer(&CpuTimer0, 150, 50000); 

 

Выполнение данной подпрограммы реализует файл 

DSP281x_CpuTimers.c. 

 

3.6. Настраиваем прерывания от CPU-таймера 0. Необходимо 

настроить три уровня прерывания. 

Первый уровень – модуль PIE, группа PIEIER1 (т.к. прерывания 

от CPU-таймера 0 относятся именно к данной группе, см. рис. 3.8): 

 
PieCtrlRegs.PIEIER1.bit.INTx7 = 1; 
 

 Второй уровень – разрешение прерываний линии 1 ядра ЦПУ.  

Для этого необходимо настроить регистр IER (см. рис. 3.2 и 3.3). 
 
IER = 1; 

 

Третий уровень – разрешить глобальные прерывания. Следует 
разрешить глобальные прерывания, добавив в программу команды:  

 
EINT;  
ERTM; 

 

Вызов данных подпрограммы следует произвести сразу вслед за 
конфигурацией таймера, произведенной в п. 3.6. 

 

3.7. Затем необходимо добавить команду запуска CPU Timer0: 

 
CpuTimer0Regs.TCR.bit.TSS = 0; 

 

3.8. Сразу после основной программы  (область 3 на рис. 3.16) 

необходимо добавить подпрограмму обработки прерываний от CPU-

таймера 0 «cpu_timer0_isr». Подпрограмму и обращение к ней 

мы уже внесли в программу. Теперь необходимо написать саму под-

программу. Подпрограмма  будет иметь общий вид: 

 
interrupt void cpu_timer0_isr(void) 
{ 
… 
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(текст подпрограммы) 
… 
} 

 

Подпрограмма должна выполнять следующие действия:  

- инкрементировать глобальную переменную 

«CpuTimer0.InterruptCount», описываемую (начальное значение = 0) в 

подключаемом файле DSP281x_CpuTimers.c. Данная переменная будет 
показывать истечение интервала времени 50 мс с момента запуска тай-

мера;  
- сбросить  в «0» бит 1 регистра PIEACK, что необходимо для 

разрешения последующих прерываний. Это действие выполняет ко-

манда: 
 
PieCtrlRegs.PIEACK.all = PIEACK_GROUP1; 

 

3.9. После настройки таймера и прерываний корректируем ос-
новную программу. Для этого удаляем (либо добавляем в начале 
строки признак комментария «//»)  вызов подпрограммы   

«delay_loop(?);» (см. область 4 на рис. 3.16). Также удаляем 

объявление этой подпрограммы (см. область 5 на рис. 3.16), и заклю-

чаем в скобки комментария саму подпрограмму   

«void delay_loop(long end)». Скобки комментария открыва-
ются парой символов «/*» и закрываются парой символов «*/». 

Затем необходимо программно реализовать цикл ожидания для 

формирования задержки длительностью 150 мс, с учетом того, что 

переменная «CpuTimer0.InterruptCount» однократно инкрементируется 

в подпрограмме «interrupt void cpu_timer0_isr(void)» 

каждые 50 мс. Место вставки цикла ожидания – область 4  

на рис. 3.16. После цикла ожидания необходимо сбросить перемен-

ную «CpuTimer0.InterruptCount» в 0. 

 

3.10. Разрешаем работу Watchdog timer (WDT). См. область 6 на 
рис. 3.16. 

 

3.11. Добавляем обслуживание WDT. Для этого необходимо по-

следовательно записать в регистр WDKEY коды «0x55» и «0xAA», 

аналогично тому, как это выполнялось в программе к лабораторной 

работе № 2 (см. область 7 на рис. 3.16). Отличием является то, что 
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данную процедуру вместе с макросами EALLOW и EDIS необходимо 

перенести внутрь подпрограммы обработки прерывания от CPU-

таймера 0 «interrupt void cpu_timer0_isr(void)». По-

скольку прерывание от таймера происходит циклично с периодом   

50 мс, сброс ЦСП от WDT не происходит. 
 
4. Компиляция, компоновка и загрузка выходного файла в отла-

дочный модуль ЦСП. 
4.1. Компилируем программу: Project → Compile File. При нали-

чии ошибок, исправляем их. 
4.2. Компонуем проект: Project → Build. При наличии ошибок, 

исправляем их. 
4.3. Загружаем выходной файл: File → Load Program → Debug\ 

lab3.out (в случае, если данная функция сконфигурирована для вы-
полнения автоматически, выполнять данный пункт не нужно). 

 

 

Содержание отчета: 
 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, тексты исследуемых программ, результаты 

их выполнения, выводы. 

 

Контрольные вопросы: 

 

1. Маскируемые и немаскируемые прерывания.  

2. Сброс ЦСП. 

3. Обработка прерываний ядра ЦСП семейства C28x. 

4. Назначение и структура модуля расширения прерываний (PIE) 

ЦСП семейства C28x. 

5. Расположение векторов прерываний ЦСП семейства C28x в 

режимах ENPIE=0 и ENPIE=1. 

6. Процедура обработки прерываний при ENPIE=1. 

7. Назначение и структура CPU-таймеров ЦСП семейства C28x. 

8. Регистры CPU-таймеров ЦСП семейства C28x. 

9. Какие изменения необходимо внести в исходный текст, чтобы 

программа «бегущие огни» выполнялась с движением «горя-

щих» светодиодов: 

- в 1,7 раз быстрее?  

- в 2,45 раз медленнее? 
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10. Какие изменения необходимо внести в исходный текст, чтобы 

программа «бегущие огни» выполнялась: 

- с замедлением движения «горящих» светодиодов в 2 раза на 
каждом шаге движения? 

- с ускорением движения «горящих» светодиодов в 3 раза на 
каждом шаге движения? 
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