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ВВЕДЕНИЕ 

На сегодняшний день представлено большое количество литера-
туры, в которой рассмотрены современные инструментальные сред-

ства обработки сигналов (ИСОС) и изложены известные базовые ал-
горитмы цифровой обработки сигналов (ЦОС), однако реализация 
даже простейших алгоритмов на базе микропроцессоров и элементов 
с параллельной логикой может вызвать трудности у разработчиков 
начального уровня квалификации. Это объясняется тем, что реализа-
ция алгоритма ЦОС тесно связана с устройством обработки сигналов, 
т. е. для реализации этого алгоритма необходимо знание архитектуры 

устройства обработки сигналов (микропроцессора, программируемой 

логической интегральной схемы и т. п.).  

Наиболее распространенными инструментальными средствами 

цифровой обработки аналоговых сигналов в реальном масштабе вре-
мени являются отладочные платы (Evaluation board) на основе цифро-
вых сигнальных процессоров, программируемых интегральных схем 

ПЛИС (CPLD, Complex programmable logic device и FPGA, Field-

programmable gate array), ARM-процессоров (Advanced RISC 

Machine). Изучение приемов работы с такими ИСОС является важ-

ным этапом подготовки инженеров по информационным технологиям 

и управлению. 
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Лабораторная работа № 1 

Изучение отладочного модуля для цифрового  
сигнального процессора семейства C28х 

Цель работы 

Изучить отладочное оборудование для цифрового сигнального 
процессора семейства C28х фирмы Texas Instruments – отладочную 

плату eZDSP320F2812 c платой расширения Zwickau Adapterboard. 

Освоить интегрированную среду разработки Code Composer Studio, 

научиться создавать и отлаживать простейшие программы для циф-

рового сигнального процессора TMS320F2812. 

Основные теоретические сведения 

Аппаратная часть стенда состоит из платы эмулятора и платы  

расширения, а программная – из среды разработки Code Composer Studio. 

На рис. 1.1 представлена отладочная плата (Evaluation board) 

eZDSP320F2812 c платой расширения. На плате эмулятора размещен 

сигнальный процессор TMS320F2812 и схема, обеспечивающая его 
работу – стабилизатор напряжения (+3,3 В для периферии и +1,9 В 

для ядра), схема JTAG-эмулятора, внешнее ОЗУ. Плата эмулятора со-
единена с платой расширения Zwickau Adapterboard, расположенной 

под ней (рис. 1.1). На плате расширения располагаются светодиоды, 

переключатели, кнопки, потенциометры, ЦАП, микросхема FLASH-

памяти, датчик температуры, микросхемы интерфейсов RS-232  

и CAN, звуковой пьезоэлектрический преобразователь. Связь эмуля-
тора и ПЭВМ осуществляется через LPT-порт.  

Code Composer Studio (CCS) – интегрированная среда разработ-
ки для цифровых сигнальных процессоров фирмы Texas Instruments. 

После загрузки программы открывается окно, разделенное на две вер-
тикальные части. В левой части (узкой) отображается окно проекта,  
в правой (широкой) – рабочая область (рис. 1.2).  

Любой проект (Project), кроме файла с выполняемой програм-

мой на языке Си или Ассемблер, содержит командные файлы, биб-

лиотеки, линкеры. Данные файлы необходимы для преобразования 
исходного текста программ в машинный код, который затем загружа-
ется в процессор. Файл управления линкером сопоставляет логиче-
ские сектора (область данных, программ) и физическую память сиг-
нального процессора.  
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Рис. 1.1. Плата эмулятора eZDSP и плата  
расширения Zwickau Adapterboard 
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Процедура линковки объединяет один и более объектные файлы 

(*.obj) в выходной файл (*.out), который содержит машинные коды,  

адреса и отладочную информацию. Проект может включать более одно-
го файла программ и подпрограмм, причем допускается написание про-
грамм и их частей на различных языках (Си, Си++, Макроассемблер). 
Все это позволяет максимально эффективно использовать имеющиеся 
наработки в последующих проектах. Несколько проектов могут объе-
диняться в рабочей области, но компилироваться и отлаживаться будет 
только один – текущий проект. При выполнении лабораторных работ не 
рекомендуется открывать сразу несколько проектов. 

Порядок выполнения работы 

1. Создание нового проекта. 
Через вкладку меню Project → New создаем новый проект. В по-

ле Project Name записываем название проекта «Lab1». В поле Location 

указывается путь, по которому будет находиться проект – 

E:\DspUser\Lab1. В поле Project Type выбираем Executable (.out),  

а в поле Target – TMS320C28XX. В случае, если плата эмулятора про-
граммно не подключена к ПЭВМ, осуществляем подключение через  
вкладку меню Debug → Connect. 

2. Создание файла программы.  

Через вкладку меню File → New → Sourse File создаем файл. 
Содержимое файла отображается в рабочей области программы. Да-
лее заносим (копируем) в него тестовую программу, представленную 

на рис. 1.3. Затем необходимо сохранить в папке для проекта, вы-

бранной в п. 1, написанную программу под именем «lab1.c» через 
вкладку меню File → Save as: «lab1.c». 

 
unsigned int k; 
void main (void) 
{ 
unsigned int i; 
while(1) 
{ 
for (i=0;i<100;i++) 
k=i*i; 
} 
} 

Рис. 1.3. Тестовая программа 



 7

3. Добавление файлов в проект. 
Сохраненный файл еще не является частью проекта и при ком-

пиляции проекта не будет учтен. Его необходимо добавить в проект 
через вкладки меню Project → Add files to Project, где указывается имя 
файла: «lab1.c». После этого имя данного файла появится в разделе 
«Source» окна проекта. Кроме файла программы, через вкладку меню 

Project → Add files to Project нужно добавить в проект файл управле-
ния линкером и библиотеки: 

 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_

RAM_lnk.cmd 

C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 
 

Рекомендуется здесь и далее в аналогичных случаях для исклю-

чения ошибок полные пути к файлам копировать в диалоговое окно 
«Add files to Project». 

4. Компиляция программы. 

Компилируя программу, мы проверяем ее на наличие синтакси-

ческих ошибок. Для этого выбираем вкладку меню Project → Compile 

File (горячие клавиши Ctrl+F7) или иконку . В случае удачной 

компиляции в статусной строке будет выдано сообщение об отсутст-
вии ошибок: 

 

«Compile Complete, 

  0 Errors, 0 Warnings, 0 Remarks.» 
 

5. Добавление библиотек и создание стека. 
Подключаем Си-библиотеки: 
 

Project → Build Options → Linker → Libraries → Search Path: 

C:\CCStudio_v3.3\C2000\cgtools\lib 

Project → Build Options → Linker → Libraries → Search Path 

Linker → Incl. Libraries: rts2800_ml.lib 
 

Задаем глубину стека 0х400: 
 

Project → Build Options → Linker → Basic → Stack Size  

(-stack): 0x400 (здесь и далее в формате записи числовых значений 

префикс «0x» означает hex-формат). 
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6. Компоновка и загрузка выходного файла в отладочный 

модуль eZDSP. 

Для компоновки выбираем Project → Build (горячая клавиша F7) 

или . Открывается окно, в котором указывается наличие или  

отсутствие ошибок, предупреждений и замечаний. Результатом компо-
новки будет файл в hex-коде, содержащий коды программ и необходи-

мую отладочную информацию. Далее необходимо загрузить создан-

ный файл в эмулятор-отладчик через вкладку меню: File → Load 

Program → Debug\lab1.out. После этого тестовая программа загрузится 
в память ЦСП, расположенного на плате эмулятора. Функцию загрузки 

готового out-файла в память ЦСП можно настроить автоматически, 

включив опцию Load Program After Build через меню Op-

tion → Customize → Program/Project/CIO. 

Примечания:  
1. Имя выходного файла генерируется по имени проекта, а не имени файла 

программы. 

2. При модификации программы необходимо каждый раз компоновать  
и загружать программу в память процессора. 

7. Сброс сигнального процессора и запуск программы на 
выполнение. 

Для правильного выполнения программы следует произвести 

сброс процессора и его перезапуск. Для этого последовательно вы-

полняются директивы Debug → Reset CPU (горячие клавиши Ctrl+R) 

и Debug → Restart (горячие клавиши Ctrl+Shift+F5) . 

Затем с помощью директивы Debug → Go Main (горячая клави-

ша Ctrl+M) устанавливаем программный счетчик на точку «void 

main (void)» основной программы. Директива Go Main позволяет 
выполнить начальную установку процессора, генерируемую компи-

лятором языка Си. Положение программного счетчика отображается 
желтой стрелкой у левого края рабочей области. 

Запуск программы на выполнение может осуществляться в по-
шаговом и в автоматическом режимах.  

Запуск программы в автоматическом режиме выполняется через 
вкладку меню Debug → Run (горячая клавиша F5) или с помощью 

иконки . При этом в строке статуса внизу рабочей области инди-

цируется зеленая лампочка и появляется надпись Running. Остано-
вить выполнение программы можно через вкладку меню Debug → 

Halt (горячие клавиши Shift+F5) или .  
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Пошаговая отладка осуществляется с помощью Debug → Step 

Into или горячей клавиши F11. Нажимая функциональную клавишу 
F11, понаблюдайте за ходом выполнения программы. 

8. Просмотр переменных. 
Для просмотра переменных используется вкладка меню View → 

Watch Window или . В колонке Name задается имя переменной,  

в нашем случае там могут быть записаны переменные i и k (для до-
бавления переменной можно, выделив ее, воспользоваться в контек-
стном меню опцией Add to Watch Window). В колонке Value отобра-
жаются сами переменные, причем после каждой их модификации 

вручную или исполняемой программой они выделяются красным цве-
том в течение одного такта отладки. В колонке Type отображается тип 

переменной (целый, вещественный и т. д.), а в колонке Radix – зада-
ется формат представления чисел (десятичный, двоичный, шестна-
дцатеричный и пр.). В окне Watch Window также можно просматри-

вать также содержимое всех программно доступных регистров 
цифрового сигнального процессора (ЦСП). Для этого необходимо на-
вести мышь на область окна, щелкнуть правой кнопкой мыши, из от-
крывшегося списка выбрать «Add Globals to Watch», и поставить от-
метку напротив той группы регистров ЦСП, которую следует 
просматривать в ходе выполнения программы. 

9. Использование точки останова (Breakpoint). 

Точки останова (Breakpoint) в Code Composer Studio использу-
ются для удобства отладки программ. Для установки Breakpoint уста-
навливаем курсор на строку, на которой должно остановиться выпол-

нение программы, щелкаем на , строка выделяется красной 

точкой. Запускаем программу (F5) и видим, что ее выполнение оста-
новилось на выделенной строке (желтая стрелка). Чтобы снять все 

Breakpoint, необходимо щелкнуть на иконку . При достижении 

точки Breakpoint в автоматическом режиме (Run) обновление пере-
менных в окне Watch происходит дискретно с остановкой программы 

(далее требуется перезапуск). 
Измените исходную программу (рис. 1.3) так, как показано на 

рис. 1.4. 

 

 

 



 10

unsigned int k; 
void main (void) 
{ 
unsigned int i; 
while(1) 
{ 
for (i=0;i<100;i++) 
{ 
k=2; 
k=i*i; 
} 
} 
} 

Рис. 1.4. Измененная тестовая программа 

10. Режим Animate. 

Режим Animate используется для отслеживания содержимого ре-
гистров и переменных. Для его запуска необходимо нажать Debug → 

Animate (горячие клавиши Shift+F5) или . Скорость анимации уста-
навливается в окне Option → Customize → Debug Properties → Animate 

Speed. Установите скорость анимации, равную 1 с.  
11. Просмотр содержимого регистров. 

Содержимое регистров процессора  можно отследить, выбрав 
вкладку меню View → Registers → CPU Register и View → Registers → 

Status Register. Чтобы изменить значение регистра, следует дважды 

щелкнуть по его содержимому и ввести новое значение. 

Задание для самостоятельной работы 

В ходе выполнения задания для самостоятельной работы требуется: 
1) установить Breakpoint на строки 7, 9 и 10 измененной тесто-

вой программы, показанной на рис. 1.4. Перезапустить программу  
в автоматическом режиме (Run) после каждой остановки в выполне-
нии программы на точках останова. Проследить изменение перемен-

ных i и k в окне Watch. Объяснить полученные результаты; 

2) не снимая Breakpoint, запустить программу в режиме Animate. 

Следить за выполнением программы и содержимым окна Watch (пере-
менные i и k). Объяснить полученные результаты;  

3) открыв окна CPU Register и Status Register, проследить изме-
нение содержимого регистров при выполнении программы в режиме 
Animate. Объяснить полученные результаты; 
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4) не останавливая выполнение программы, открыть окно ас-
семблированного кода программы, полученного в результате компо-
новки (Window → Disassembly). Объяснить полученные результаты. 

Вернуться в окно исходного кода программы, написанной на языке Си 

(Window → Lab1.c). Остановить выполнение программы. Снять все 
Breakpoint. 

Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, тексты тестовых программ, результаты их 
выполнения, выводы. 

Контрольные вопросы 

1. Структура платы эмулятора eZDSP320F2812 и платы расши-

рения Zwickau Adapterboard. 

2. Среда разработки Code Composer Studio. Создание, компиля-
ция, компоновка и загрузка проекта. 

3. Среда разработки Code Composer Studio. Режимы запуска про-
грамм. 

4. Среда разработки Code Composer Studio. Просмотр переменных.  
5. Среда разработки Code Composer Studio. Использование точки 

останова (Breakpoint). 

6. Среда разработки Code Composer Studio. Просмотр содержи-

мого регистров ЦСП. 

7. Укажите, каким образом осуществить отладку исследуемой 

программы в пошаговом режиме: 
– без исследования ассемблерного кода; 
– с исследованием ассемблерного кода; 
– с одновременным исследованием исходного текста на Си и со-

ответствующего ему ассемблерного кода. 
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Лабораторная работа № 2 

Исследование систем управления  
и ввода/вывода цифрового сигнального  

процессора семейства C28х 

Цель работы 

Ознакомиться с системой управления и синхронизации (Control 

System) ЦСП семейства C28х, изучить аппаратную организацию  

и приемы работы с цифровыми портами ввода/вывода. 

Основные теоретические сведения 

Структурная схема ЦСП семейства C28x приведена на рис. 2.1. 
Память и все периферийные модули объединены системой шин по 
модифицированной гарвардской архитектуре. 

Сектори-
зованная 

Flash-
память 

 
ОЗУ 

 

Менеджер 
событий А 

Менеджер 
событий B 

АЦП (12 бит) 

Интерфейсы 

Порты ввода-
вывода 

Блок  
регистров 
(32 бит) 

 

Умно-
житель 

(32x32 
б )

АЛУ 
атомар-
ных 

функций 

PIE
менеджер 
преры-
ваний 

CPU- 
таймеры 

 

Шина данных (Data Bus)

Шина регистров (Register Bus)

Ядро (CPU)

JTAG 
реального 
времени 

ПЗУ 

Шина программ (Program Bus)

 

Рис. 2.1. Структурная схема ЦСП семейства C28x 

Карта адресного пространства ЦСП C28x показана на рис. 2.2.  

В качестве памяти данных используется исключительно оперативно-
запоминающее устройство (ОЗУ) быстрого доступа (Single Access 

RAM – SARAM, доступ возможен в течение каждого машинного цик-
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ла) общим объемом 18 Кслов, состоящее из нескольких банков –  

М0, M1 (2x1К), L0, L1 (2x4К) и Н0 (8К). Каждый банк отображается  
и на память программ, и на память данных, т. е. эту память можно ис-
пользовать и в качестве памяти программ, и в качестве памяти данных. 
В сигнальных процессорах F2812 объем встроенной флэш-памяти со-
ставляет 128 Кслов (4 сектора – по 8К и 6 секторов – по 16К). 

  

Рис. 2.2. Карта адресного пространства ЦСП 

семейства C28x 

В процессоре C28x помимо центрального процессорного устрой-

ства (CPU) имеется внутренняя периферия (АЦП, таймеры, встроен-

ные интерфейсы и пр.), которая также располагается на кристалле. 
ЦСП семейства С28x содержат регистры модуля центрального процес-
сора (регистры CPU), необходимые для арифметической/логической 

обработки данных и три сегмента (фрейма) регистров встроенной пе-
риферии, предназначенных для управления режимами и хранения дан-

ных внутренних периферийных устройств. Эти регистры расположены 

прямо в адресном пространстве памяти, т. е. доступны не только как 
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регистры с именами, но и как ячейки памяти с определенными адреса-
ми (рис. 2.2): 

 Peripheral Frame 0 (PF0, объем 2K, адреса 0x00 0800 … 

0x00 0FFF) – включает в себя регистры внешнего интерфейса памяти 

XINTF, модуля расширения прерываний PIE, модуля Flash-памяти, 

модуля таймеров ядра, модуля ключа защиты CSM. 

 Peripheral Frame 2 (PF2, объем 4K, адреса 0x00 6000 … 0x00 6FFF) – 

включает в себя регистры интерфейса eCAN. 

 Peripheral Frame 1 (PF1, объем 4K, адреса 0x00 7000 … 

0x00 7FFF) – включает в себя регистры модуля управления системой, 

модуля ввода/вывода GPIO, модуля менеджеров событий EVA/EVB, 

модуля последовательного интерфейса McBSP, модуля последова-
тельного интерфейса SCI, модуля последовательного интерфейса SPI, 

модуля АЦП. 

Все программно доступные цифровые выводы сгруппированы  

в порты GPIOA, GPIOB, GPIOD, GPIOE, GPIOF, GPIOG. GPIO (general 

purpose input/output) означает «линии ввода/вывода общего назначения». 

Периферия имеет выводы, использующиеся для ввода/вывода 
сигналов. Чтобы не загромождать ЦСП дополнительными выводами, 

используют мультиплексирование: на одном выводе могут быть реа-
лизованы две и более различные функции, которые выбираются про-
граммным путем. На рис. 2.3 приведены основные и альтернативные 
функции портов. 

Все 6 портов управляются своими мультиплексирующими реги-

страми (GPxMUX, здесь и далее в именах регистров, относящихся  
к портам, x – имя порта). Если бит сброшен в 0, то данный вывод ра-
ботает как обычная линия порта; установкой бита в 1 выбирается аль-
тернативная функция, т. е. линия порта (pin) подключается к соответ-
ствующему периферийному устройству (рис. 2.4). К регистрам 

данных относятся: 
– регистры GPxDAT (в них непосредственно хранятся данные 

порта, которые могут быть изменены записью в данные регистры); 

– регистры GPxSET (служат для установки соответствующих 
разрядов порта); 

– регистры GPxCLEAR (служат для сброса соответствующих 
разрядов порта); 

– регистры GPxTOGGLE (служат для переключения соответст-
вующих разрядов порта в альтернативное логическое состояние). 
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Рис. 2.3. Основные и альтернативные функции  

портов ввода/вывода F2812 

  

 

Периферийная 

функция 

 

Рис. 2.4. Функциональная схема линии GPIO 
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Каждый вывод порта может работать на ввод или вывод. На-
правление передачи данных задается битами в регистрах  GPxDIR:  

0 – линия работает на ввод: 1 – на вывод данных. При работе портов 
A, B, D и E на ввод для увеличения помехозащищенности можно на-
строить функцию задержки ввода (Input Qualification feature) установ-
кой битов 7–0 в соответствующем регистре GPxQUAL. После этого 
импульсы на линиях соответствующих портов, имеющие максималь-
ную длительность от 2 (GPxQUAL=0x01) до 510 (GPxQUAL=0xFF)  

периодов частоты тактирования ядра SYSCLKOUT, не будут распо-
знаваться ядром процессора. 

Перед началом работы необходимо настроить модуль тактирова-
ния. Как и многие современные процессоры, ЦСП семейства С28х ис-
пользуют внешний резонатор или генератор с частотой более низкой, 

чем максимальная тактовая. Это позволяет уменьшить влияние элек-
тромагнитных помех, понизить требования к разводке печатной платы 

и повысить надежность работы схемы. Частота тактового генератора 
OSCCLK, расположенного на плате эмулятора, составляет 30 МГц. 

Максимальная тактовая частота процессора 150 МГц получается путем 

умножения внешней частоты на 5 (OSCCLK*10/2, рис. 2.5). Коэффи-

циент деления задается программно в регистре PLLCR. 

 

Рис. 2.5. Тактовый модуль и регистр PLLCR 
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Помимо формирователя тактовой частоты ядра тактовый модуль 
содержит предделители: низкоскоростной LOSPCP и высокоскорост-
ной HISPCP (рис. 2.6), которые используются для тактирования пе-
риферийных устройств. 

Известно, что потребляемая мощность микропроцессорных эле-
ментов возрастает пропорционально тактовой частоте. Снижая такто-
вую частоту, можно снизить энергопотребление и определенного моду-
ля, и всего ЦСП в целом. Коэффициенты деления задаются программно 
в регистрах LOSPCP и HISPCP. 

 

Рис. 2.6. Формат регистров HISPCP и LOSPCP 

В ЦСП семейства С28х реализована возможность не только изме-
нять, но и полностью запрещать/разрешать тактирование различных пе-
риферийных модулей при помощи регистра PCLKCR (рис. 2.7). 

Сторожевой таймер (Watchdog timer или WDT, рис. 2.8) предна-
значен для предотвращения «зависания» ядра ЦСП и реализован на 
основе суммирующего счетчика WDCNTR, который тактируется че-
рез счетчик-делитель от внешнего генератора и при переполнении 

вырабатывает сигнал прерывания WDINT либо сброса ядра ЦСП 

WDRST (задается программно). WDT работает независимо от ядра 
ЦСП и должен сбрасываться программно для предотвращения сброса 
процессора. 

 



 18

 

EVAENCLK Разрешение HSPCLK в EVA  

EVBENCLK  Разрешение HSPCLK в EVВ  

ADCENCLK  Разрешение HSPCLK в АЦП (ADC)  

SPIAENCLK  Разрешение LSPCLK в SPI  

SCIAENCLK  Разрешение LSPCLK в SCI-A  

SCIBENCLK  Разрешение LSPCLK в SCI-B  

MCBSPENCLK  Разрешение LSPCLK в McBSP  

ECANENCLK  Разрешение тактирования eCAN 

Рис. 2.7. Формат регистра PCLKCR:  

1 – разрешить тактирование периферийного модуля; 0 – запретить 

 

Рис. 2.8. Формат регистра управления сторожевого таймера WDCR 

Сторожевой таймер защищен ключом «101» и в случае записи  

в биты WDCHK 2–0 регистра WDCR (рис. 2.9) любой иной кодовой 

комбинации в следующем машинном цикле происходит генерация 
выходного сигнала (такого же, как и при переполнении).   

Бит WDFLAG используется для того, чтобы указать источник 
сброса: обычный сброс (WDFLAG=0) или сброс по сторожевому тай-

меру (WDFLAG=1). Биты WDPS 2–0 позволяют выбрать необходи-

мый коэффициент деления частоты для работы сторожевого таймера. 
Бит WDDIS служит для запрета работы (блокировки) WDT. 
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WDOVERRIDE

Сброс WDT 

 

Рис. 2.9. Функциональная схема сторожевого таймера 

Регистр управления и состояния (System Control and Status  

Register – SCSR, рис. 2.10) управляет сбросом сторожевого таймера. 
Бит WDINTS отражает текущее состояние сигнала WDINT. Бит 
WDENINT – выбор режима действия от WDT (сброс или прерыва-
ние). Если WDENINT=0 – разрешен сигнал сброса WDRST, если 

WDENINT=1 – разрешен сигнал прерывания WDINT. 

 

Рис. 2.10. Формат регистра управления и состояния SCSR 

Если бит WDOVERRIDE установлен в «1», то пользователь мо-
жет изменять состояние сторожевого таймера, т. е. запрещать или 

разрешать его работу с помощью бита WDDIS в регистре управления 
WDCR. Особенностью является то, что пользователь может только 
сбросить бит WDOVERRIDE, записав в него «1», установить бит про-
граммно нельзя.  
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Порядок выполнения работы 

Часть I 

В части I лабораторной работы необходимо разработать про-
грамму «бегущие огни», задавая направление движения: сначала –  

от края к краю (рис. 2.11, а), а потом, зажигая по два светодиода, –  

от периферии к центру (рис. 2.11, б). Светодиоды подключены  к ли-

ниям порта GPIOB7 – GPIOB0 (1 – горит, 0 – погашен), а линии порта 
GPIOB15 – GPIOB8 соединены с ключами (1 – ключ замкнут, 0 –  

разомкнут). 
1. Создание нового проекта. 
В Code Composer Studio создаем новый проект Lab2.pjt. В поле 

Project Name записываем название проекта «Lab2». В поле Location 

указывается путь, по которому будет находиться проект – 

E:\DspUser\Lab2. 

1.1. Для упрощения работы файл под именем «_lab2_.c» с заго-
товкой текста программы имеется на диске в папке 
«E:\DspUser\Templates». Знаками «?» в исходном тексте программы 

отмечены значения, которые необходимо будет заменить на требуе-
мые для правильной работы программы (рис. 2.12). Копируем данный 

файл в папку проекта E:\DspUser\Lab2 и переименовываем в «Lab2.c». 

Добавляем в проект и открываем в окне редактора данный файл: Pro-

ject → Add files to Project.   

1.2. Добавляем в проект управляющий файл линкера, командные 
файлы, библиотеки, необходимые внешние программные модули (ре-
комендуется для исключения ошибок пути к файлам, указанные ниже, 
копировать в диалоговое окно «Add files to Project»): 

 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\cmd\DSP281x_Headers_nonBIOS.cmd 
C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\source\DSP281x_Glo-
balVariableDefs.c 

 

Сторожевой таймер защищен ключом «101», и, в случае записи 

в биты WDCHK 2–0 регистра WDCR (рис. 2.9) любой иной кодовой 

комбинации, в следующем машинном цикле происходит генерация 
выходного сигнала (такого же, как и при переполнении).   
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GPIOB 

 

 

а) б) 
Рис. 2.11. Направление движения светодиодов:  

а – слева направо и наоборот; б – от периферии к центру  

и наоборот 

2. Настройка параметров проекта. 
2.1. Включаем в проект заголовочные файлы, для этого выбира-

ем Project → Build Options, в закладке Compiler выбираем Preprocessor 

и в поле Include Search Path (-i) вводим:  
 

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include 
 

2.2. Добавление библиотек и создание стека. 
Подключаем Си-библиотеки: 
 

Project → Build Options → Linker → Libraries → Search Path: 

C:\CCStudio_v3.3\C2000\cgtools\lib 

Project → Build Options → Linker → Libraries → Search Path Linker → Incl. Librar-

ies: rts2800_ml.lib 

Задаем глубину стека 0х400: 

Project → Build Options → Linker → Basic → Stack Size (-stack): 0x400 
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//################################################################## 
// Имя файла: _Lab2_.c 
// 
// Описание: С помощью 8 светодиодов, подключенных к линиям  
// порта GPIOB0 - GPIOB7, формируются "бегущие огни". 
// Направление движения справа - налево и наоборот 
//################################################################## 
 
#include "DSP281x_Device.h" // Включение заголовочного файла 
 
void delay_loop(long); 
void Gpio_select(void); 
void InitSystem(void); 
 
void main(void) 
{ 
 unsigned int i; 
 unsigned int LED[8]= {0x0001,0x0002,0x0004,0x0008, 
                       0x0010,0x0020,0x0040,0x0080};  
  
 InitSystem();  // Инициализация регистров ЦСП 
 Gpio_select();  // Инициализация линий ввода/вывода  
  
while(1) 
 {     
       for(i=0;i<14;i++) 
    { 
          if(i<7)  GpioDataRegs.GPBDAT.all = LED[i]; 
          else   GpioDataRegs.GPBDAT.all = LED[14-i];  
          delay_loop(?); 

      } 
     } 
}   
 
//################################################################## 
// Подпрограмма: delay_loop 
// 
// Описание: Формирование временной задержки горения светодиодов 
//################################################################## 
 
void delay_loop(long end) 

{ 

 long i; 

 for (i = 0; i < end; i++); 

 EALLOW; // Сброс сторожевого таймера 
 //SysCtrlRegs.WDKEY = 0x?; 

 //SysCtrlRegs.WDKEY = 0x?; 

 EDIS; 

} 

 

//################################################################## 

// Подпрограмма: Gpio_select 

// 

// Описание: Настройка линий порта GPIO B15-8 на ввод, а линий  

// B7-0 на вывод. Настройка всех линий портов A, D, F, E, G на  
// ввод. Запрещение работы входного ограничителя 
//################################################################## 

Рис. 2.12. Заготовка текста программы «бегущие огни» 

(продолжение и окончание см. на с. 23 и 24) 

7 

6
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void Gpio_select(void) 
{ 
 EALLOW; 

    GpioMuxRegs.GPAMUX.all = 0x?; // Настройка линий ввода/вывода на 
    GpioMuxRegs.GPBMUX.all = 0x?; // работу в качестве портов 
    GpioMuxRegs.GPDMUX.all = 0x?; 
    GpioMuxRegs.GPFMUX.all = 0x?;    
    GpioMuxRegs.GPEMUX.all = 0x?;  
    GpioMuxRegs.GPGMUX.all = 0x?;   
    GpioMuxRegs.GPADIR.all = 0x?; // Настройка портов А, D, E, F, G  
  // на ввод 
    GpioMuxRegs.GPBDIR.all = 0x?; // Настройка линий 15-8 на ввод,  
    GpioMuxRegs.GPDDIR.all = 0x?; // а линий 7-0 на вывод 
    GpioMuxRegs.GPEDIR.all = 0x?;  
    GpioMuxRegs.GPFDIR.all = 0x?;  
    GpioMuxRegs.GPGDIR.all = 0x?;  
 
    GpioMuxRegs.GPAQUAL.all = 0x?; // Запрещение входного ограничителя 
    GpioMuxRegs.GPBQUAL.all = 0x?; 
    GpioMuxRegs.GPDQUAL.all = 0x?; 
    GpioMuxRegs.GPEQUAL.all = 0x?; 
    EDIS; 
}      

 
 

//##################################################################### 
// Подпрограмма: InitSystem 
// 
// Описание: Настройка сторожевого таймера на работу, 
//  предделитель = 1. Выработка сброса сторожевым  
//  таймером. Внутренняя частота работы ЦСП 150 МГц. 
//  Запись в предделитель высокоскоростного таймера  
//  коэффициента деления 2, а в предделитель 
//  низкоскоростного таймера - 4. Запрещение работы  
//  периферийных устройств 
//##################################################################### 

 
void InitSystem(void) 
{ 
   EALLOW; 
   SysCtrlRegs.WDCR= 0x?;  // Разрешение работы сторожевого    
      // таймера, предделитель = 64 
      // или запрещение работы  сторо- 
      // жевого таймера, предделитель = 1 
  
 
   SysCtrlRegs.SCSR = ?;   // Конфигурирование сброса ЦСП от WDT
  
 
 

 
   SysCtrlRegs.PLLCR.bit.DIV = ?;// Настройка блока умножения частоты 
   SysCtrlRegs.HISPCP.all = 0x?;// Задание значений высокоскоростного 
   SysCtrlRegs.LOSPCP.all = 0x?; // и низкоскоростного предделителей  

       

Рис. 2.12. Продолжение (начало см. на с. 22, окончание – на с. 24) 
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    SysCtrlRegs.PCLKCR.bit.EVAENCLK=?; // Запрещение работы 
    SysCtrlRegs.PCLKCR.bit.EVBENCLK=?; // периферийных устройств 
    SysCtrlRegs.PCLKCR.bit.SCIAENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SCIBENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.MCBSPENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SPIENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ECANENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ADCENCLK=?; 
    EDIS; 
} 

 

Рис. 2.12. Окончание (начало см. на с. 22 и 23) 

3. Инициализация системы. 

Открываем файл Lab2.c и переходим к подпрограмме  
«InitSystem()». 

3.1. Присваивая необходимое значение регистру WDCR (рис. 2.9), 

запрещаем работу сторожевого таймера (WDDIS=0), сбрасываем бит 
WDFLAG, задаем коэффициент деления частоты тактирования Watch-

dog-таймера, равный 1 (WDPS0, WDPS1, WDPS2=0). Указанные значе-
ния нужно внести в область 1 программы (рис. 2.12). 

3.2. Программируем регистр SCSR (см. рис. 2.10) на сброс про-
цессора при переполнении Watchdog-таймера. В бит WDENINT запи-

сываем «0», в бит WDOVERRIDE также записываем «0» для того, 
чтобы оставить его в единичном состоянии (область 2 на рис. 2.12). 

3.3. В регистр PLLCR (рис. 2.5) заносим код, необходимый для 
преобразования частоты кварцевого резонатора 30 МГц во внутрен-

нюю частоту SYSCLKOUT работы процессора 150 МГц (область 3  

на рис. 2.12). 

3.4. Заносим в высокоскоростной предделитель HISPCP (рис. 2.6) 

коэффициент деления 2, а в низкоскоростной (LOSPCP) – 4 (область 3 

на рис. 2.12). 

3.5. Установкой-сбросом бит в регистре PCLKCR (рис. 2.7) за-
прещаем работу всех периферийных устройств (область 4 на рис. 2.12). 

4. Настройка портов. 

Переходим к подпрограмме «Gpio_select()». 

4.1. Установкой-сбросом бит в регистрах GPxMUX настраиваем 

все выводы на работу в качестве портов (область 5 на рис. 2.12). 

4.2 становкой-сбросом бит в регистрах GPxDIR настраиваем все 
линии портов A, D, E, F, G на ввод (область 5 на рис. 2.12).  

В порту GPIOB настраиваем линии порта GPIOB15 – GPIOB8 на ввод, 

а GPIOB7 – GPIOB0 на вывод (область 5 на рис. 2.12). 

4
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4.4. Сбрасываем все биты регистров GPxQUAL портов A, B, D, E  

в ноль (область 5 на рис. 2.12). 

5. Расчет и задание временной задержки. 

В строке «delay_loop()» (область 6 на рис. 2.12) в скобках 
указываем число n – параметр задержки. Длительность задержки здt   

будет пропорциональна данному числу и рассчитывается по формуле, с: 

 .
10150

6
6зд 


n

t  

6. Компиляция, компоновка и загрузка выходного файла в 

отладочный модуль ЦСП. 

6.1. Компилируем программу: Project → Compile File. При нали-

чии ошибок, исправляем их. 
6.2. Компонуем проект: Project → Build. При наличии ошибок, 

исправляем их. 
6.3. Загружаем выходной файл: File → Load Program → Debug\ 

lab2.out (в случае, если данная функция сконфигурирована для вы-

полнения автоматически, выполнять данный пункт не нужно).  
7. Тестирование программы.  

7.1. Сбрасываем ЦСП: Debug → Reset CPU, Debug → Restart. 

7.2. Устанавливаем программный счетчик на точку «void 

main (void)» основной программы: Debug → Go main. 

7.3. Запускаем программу: Debug → Run. Проверяем правиль-
ность работы, наблюдая за светодиодами. 

Имеется возможность отслеживать правильность выполнения 
логики программы, просматривая в отдельном окне, как изменяется 
содержимое выводов порта GPIOB. Для этого необходимо: 

– остановить выполнение программы; 

– установить точку останова на строку программы, отмеченную 

знаком «●»; 

– выделить мышью в любом месте текста программы  название 
«GpioDataRegs.GPBDAT», нажать правую кнопку мыши и в открыв-
шемся окне выбрать «Add to Watch Window»; 

– щелкнуть по значку «+» напротив имени 

«GpioDataRegs.GPBDAT» в окне Watch Window, далее выбрать «bit», 

после чего в данном окне будут выведены в столбик двоичные со-
стояния разрядов порта GPIOB (рис. 2.13); 

– исключить из программы (закомментировать) задержку, вста-
вив символы «//» в начало строки  delay_loop(?); 
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– сохранить проект (Project → Save), выполнить компиляцию  

и линковку измененного проекта; 
– запустив программу в режиме «Animate», наблюдать последо-

вательность изменения логических уровней на линиях порта GPIOB. 

 

Рис. 2.13. Просмотр состояния двоичных разрядов порта GPIOB  

в окне Watch Window 

8. Работа со сторожевым таймером. 

8.1. Останавливаем выполнение программы. 

8.2. В подпрограмме «InitSystem()» изменением содержимо-
го регистра WDCR разрешаем работу сторожевого таймера (область 1 

на рис. 2.12). В битовом поле WDPS этого регистра задаем коэффици-

ент деления программного предделителя равным 64 (рис. 2.8, 2.9). 

8.3. В подпрограмме временной задержки «delay_loop()» уда-
ляем символы «//» перед двумя строками программы, в которых должна 
производиться запись в регистр WDKEY (область 7 на рис. 2.12), и за-
писываем кодовую комбинацию для сброса Watchdog-таймера: 
SysCtrlRegs.WDKEY = 0x55, SysCtrlRegs.WDKEY = 0xAA. 

Расчетное время до формирования импульса сброса /WDRST  

от Watchdog-таймера в выбранном режиме составит: 

 28,0
1030

25664512
6WDRST 




t  с. 
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Для того чтобы сброс WDT происходил раньше (т. е. сброса 
ЦСП не происходило), нужно обеспечить соотношение .WDRSTзд tt   

8.4. Компилируем, компонуем проект и тестируем программу. 
9. Работа с двумя светодиодами. 

9.1. Копируем содержимое файла «Lab2.c» в новый файл, кото-
рый называем «Lab2a.c».  

9.2 Преобразуем программу Lab2a.c так, чтобы одновременно 
зажигались два светодиода в направлении от периферии к центру  
(рис. 2.11, б). 

9.3. Добавляем в проект «Lab2a.c» и удаляем «Lab2.c» (щелкаем 

правой клавишей мышки и выбираем Remove from project). 

9.4. Компилируем, компонуем проект и тестируем программу. 

Часть II 

В части II лабораторной работы необходимо положение ключей 

отражать на светодиодах (ключ замкнут – светодиод горит, разомкнут – 

погашен), а также положением ключей задавать длительность свечения 
светодиодов. 

1. Отображение состояния ключей на светодиодах. 
1.1. Копируем содержимое файла «Lab2а.c» в новый файл, кото-

рый называем «Lab2b.c».  

1.2. Преобразуем программу Lab2b.c. Состояние (двоичный код), 
установленный ключами, должен индицироваться на светодиодах.  
С учетом того, что для подключения и светодиодов, и ключей исполь-
зуется один и тот же порт (GPIOB), состояние ключей можно индици-

ровать, введя в основную программу команду циклического сдвига со-
держимого порта GPIOB на 8 бит: 

 

GpioDataRegs.GPBDAT.all = GpioDataRegs.GPBDAT.all >> 8 
 

Удаляем таблицу состояния светодиодов, а подпрограммы  

«InitSystem()» и «Gpio_select()» оставляем без изменений. 

1.3. Добавляем в проект «Lab2b.c» и удаляем «Lab2a.c».  

1.4. Компилируем, компонуем проект и тестируем программу. 
2. Формирование длительности свечения светодиодов в за-

висимости от состояния ключей. 

2.1. Копируем содержимое файла «Lab2.c» в новый файл, кото-
рый называем «Lab2c.c».  

2.2. Преобразуем программу Lab2c.c. Задаем длительность за-
держки при  переключении  светодиодов согласно рис. 2.11, а, равную 
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(0,1*N+0,001) с, где N – код, заданный переключателями на линиях 
B15–B8. Подпрограммы «InitSystem()» и «Gpio_select()» 

оставляем без изменений. 

2.3. Добавляем в проект «Lab2c.c» и удаляем  «Lab2b.c». 

2.4. Компилируем, компонуем проект и тестируем программу. 

Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, тексты исследуемых программ, результаты 

их выполнения, выводы. 

Контрольные вопросы 

1. Структурная схема ЦСП семейства C28x. 

2. Карта адресного пространства ЦСП C28x. 

3. Структура портов ввода/вывода, режимы работы, регистры 

управления. 
4. Вывод простейших управляющих сигналов через порты 

TMS320F2812. 

5. Система тактирования TMS320F2812. Структура, особенно-
сти, назначение регистров высокоскоростного и низкоскоростного 
предделителей. 

6. Watchdog timer: назначение, принцип действия, особенности. 

7. Укажите, какие изменения необходимо внести в исходный 

текст, чтобы программа «бегущие огни» запускалась по нажатию 

кнопки, присоединенной к линии порта GPIOD1, а останавливалась – 

по нажатию кнопки, присоединенной к линии порта GPIOD6 («0» – 

соответствующая кнопка нажата, «1» – кнопка отжата). В исходном 

состоянии обе кнопки отжаты. 

8. Модифицируйте исходную программу таким образом, чтобы 

происходило движение одного «погашенного» светодиода среди ос-
тальных «горящих». 
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Лабораторная работа № 3 

Формирование функций времени на основе 
сигнального процессора семейства C28х.  

Модуль расширения прерываний 

Цель работы 

Изучить методы формирования функций времени ЦСП 

TMS320F2812 с помощью таймеров, а также систему прерываний 

ЦСП. Освоить программирование типовых процедур, использующих 
прерывания и временные задержки. 

Основные теоретические сведения 

Система прерываний ядра процессора C28x содержит 16 линий 

прерываний (рис. 3.1). Два из них – немаскируемые (RS, NMI). Пользо-
ватель не может запретить данные прерывания. Остальные 14 прерыва-
ний – маскируемые, т. е. пользователь может разрешить/запретить пре-
рывания от них программно соответственно установкой/сбросом 

соответствующих бит в регистре IER (Interrupt Enable Register). Регистр 
IFR (Interrupt Flag Register) – регистр флагов прерываний. При обнару-
жении прерывания соответствующий бит регистра IFR защелкивается  
в единичном состоянии, а после обслуживания прерывания – сбрасыва-
ется. Так же, когда аппаратное прерывание обслужено, или когда вы-

полнена инструкция INTR, сбрасывается соответствующий бит регист-
ра IER. 

Общая структура прерываний ядра C28x показана на рис. 3.2,  

а форматы регистров IER и IFR – на рис. 3.3. Следует отметить, что 
программная установка одного из битов в регистре IFR приведет  
к обработке данного прерывания ядра таким же образом, как и в слу-
чае возникновения соответствующего прерывания. INTM – младший 

бит в статусном регистре ST1, служит для общего разрешения/запрета 
маскируемых прерываний ядра. 

Все 16 прерываний однозначно связаны в памяти с таблицей век-
торов прерываний ядра BROM vector (рис. 2.2), содержащей 22-битные 
адреса (на каждое прерывание – 16 бит в ячейке с младшим адресом  

и 6 бит – в ячейке со старшим адресом), по которым должны распола-
гаться стартовые адреса подпрограмм обработки соответствующих пре-
рываний. Всего данная область памяти содержит 32 таких вектора, так 
как к 16 прерываниям ядра добавлены прерывания DLOGINT, 
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RTOSINT, Illegal (недопустимая инструкция), 12 программных преры-

ваний USER1–USER12 и один резервный вектор (Reserved). 

Подача активного сигнала на вход сброса (на вывод /RS) вызо-
вет его сброс и перезапуск программы с начального адреса. Сброс от-
личается от остальных прерываний тем, что программа затем не воз-
вращается в исходную точку, а регистры сбрасываются в начальное 
состояние. Сброс может происходить как от внешнего источника, так 
и от сторожевого таймера (WDT). Сброс внешних схем при сбросе 
ядра процессора от WDT осуществляется через вывод /RS, который 

является двунаправленным.  

 

 

Ядро 
C28x 

((CCoorree))  

 

Рис. 3.1. Линии прерываний ядра C28х 

 

IFR   IER        INTM 

 
 

Ядро 
C28x 

 

Рис. 3.2. Общая структура прерываний ядра C28x 
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Прерывание разрешено: IERBit=1 

Прерывание запрещено: IERBit=0 
 

 

Прерывание ожидает разрешения: IFRBit=1 

Прерывание отсутствует: IFRBit=0 
 

Рис. 3.3. Форматы регистров IER и IFR 

Особенностью ЦСП семейства C28x является возможность за-
пуска программ как из внутренней памяти (микроконтроллерный ре-
жим), так и из внешней (микропроцессорный режим). Режим опреде-
ляется состоянием вывода XMP/MC (рис. 2.2). Соответственно, после 
сброса программа переходит либо к начальному адресу 0x3F FFC0 

внутренней памяти (при XMP/MC=0), либо к тому же адресу внешней 

памяти (при XMP/MC=1), а режим запоминается с помощью флага 
XMP/MC в регистре XINTCNF2, который может быть впоследствии 

обработан программно. 
После сброса в режиме микроконтроллера запускается служебная 

программа Bootloader, которая анализирует выводы порта GPIOF 

(GPIOF2, GPIOF3, GPIOF4 и GPIOF12) и, исходя из комбинации сигна-
лов на них, выполняет один из переходов, перечисленных в табл. 3.1  

и условно показанных на рис. 3.4. 

В отладочном стенде ezDSP2812, используемом в лабораторных 
работах, программа загружается в H0 SARAM (ОЗУ), а прочие воз-
можные режимы загрузки могут быть заданы при помощи переклю-

чателей (джамперов). Следует отметить, что память программ и дан-

ных имеют единое адресное пространство, программа может 
выполняться как из ОЗУ, так и из FLASH, или ПЗУ (ОТР). 
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Таблица 3.1 

Режимы запуска программы Bootloader 

Выводы GPIO 

F4 F12 F3 F2 
Режим запуска 

1 x x x Передать управление FLASH-памяти по адресу  

0x3F 7FF6 

0 0 1 0 Передать управление H0 SARAM-памяти по адресу 

0x3F 8000 

0 0 0 1 Передать управление OTP-памяти по адресу  

0x3D 7800 

0 1 x x Загрузить программу из внешнего EEPROM во внутрен-

нюю память через SPI-порт 
0 0 1 1 Загрузить программу во внутреннюю память через  

SСI-А порт 
0 0 0 0 Загрузить программу во внутреннюю память через  

параллельный порт GPIOВ 

 

Стартовый адрес  
определяется  
состоянием  

линий порта  GPIOF 

Загрузочные   
программы  
(SPI, SCI-A,  
параллельная  
загрузка)  

Рис. 3.4. Режимы запуска программы Bootloader 

Цифровой сигнальный процессор имеет большое количество ис-
точников прерываний – 96, но только 16 линий прерываний ядра. Для 
возможности обслуживания всех прерываний для линий INT1–INT12 
применяется мультиплексирование (рис. 3.5). Так как программный 
поиск конкретного прерывания в линии при обработке программно за-
нял бы длительное время, то применяется специальный аппаратный 
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модуль – Peripheral Interrupt Expansion (PIE), или расширитель преры-
ваний периферии. При работе с PIE происходит перенос области век-
торов:  каждому из 96 прерываний соответствует свой 32-битный адрес 
в адресном пространстве – таблице векторов прерываний расширителя 
(PIE vector, адреса 0x00 D000…0x00 DFFF, рис. 2.2 и 3.9).   

 

x=1…12x=1…12

 

 

 

От периферии 

и внешних 
прерываний 

Ядро 

 

Рис. 3.5. Логика работы регистров PIEIFRx, PIEIERx, PIEACKx 

Форматы регистров модуля расширителя прерываний PIEIERx  
и PIEIFRx показаны на рис. 3.7, данные регистры содержат по 8 ин-
формационных бит, т. е. по числу прерываний в группе. В регистре 
PIECTRL биты 15–1 (PIEVECT) показывают адрес в пределах табли-
цы векторов PIE vector, из которой был извлечен вектор. Младший 
значащий бит игнорируется и показываются биты адреса от 1 до 15 
(т. е. только четные адреса), что позволяет при чтении из регистра од-
нозначно определить, какое прерывание генерировалось. 

ENPIE – бит разрешения извлечения векторов из таблицы  
PIE-контроллера. Если ENPIE=1, все векторы извлекаются из таблицы 
векторов PIE vector, а если ENPIE=0, PIE-контролер запрещен, и век-
торы извлекаются из таблицы CPU-векторов (BROM vector, рис. 2.2). 

Прерывания сгруппированы по 8 источников на линию (рис. 3.8). 
Для разрешения/запрета каждого прерывания используются биты в ре-
гистрах PIEIERx (x может принимать значения от 1 до 12), для инди-
кации прерываний – биты в регистрах PIEIFRx. Соответствующий бит  
в регистре подтверждения PIEACK (активный уровень – 0) определяет 
номер активного прерывания для ядра CPU внутри группы.  
В результате каждая группа мультиплексируется в одно из прерываний 
ядра INT1–INT12 (рис. 3.6).  
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Рис. 3.6. Общая структура расширения прерываний ЦСП С28х 

 

Рис. 3.7. Формат регистров модуля расширителя прерываний ЦСП С28х 

Таблица векторов прерываний приведена на рис. 3.8.  

Примеры векторов прерываний:  

– прерывание от встроенного АЦП (ADCINT) – INT1.6;  

– прерывание от CPU-таймера 0 (TINT0) – INT1.7. 
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 приоритет 

 

Рис. 3.8. Таблица источников прерываний в PIE 

 

Рис. 3.9. Таблица векторов прерываний при ENPIE=1:  

вектор 0x00 0D00 не активен, первичные вектора прерывания  
ядра по адресам 0x00 0D02 по 0x00 0D1C переадресовываются 

 в область 0x00 0D40 … 0x00 0DFE с учетом конкретного  
источника прерывания периферии; вектор извлекается  

за 9 шагов (машинных циклов ЦСП) 

Полная процедура обработки прерываний при ENPIE=1 показа-
на на рис. 3.10. 
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ядро 

 

Рис. 3.10. Полная процедура обработки прерываний при ENPIE=1: 

шаг 1 – генерация прерывания от периферии; шаг 2 – установка флага 
PIEIFRx.y=1; шаг 3а – проверка одновременного наличия двух  
условий: PIEIERx.y = 1 и PIEACKx=0; шаг 3б – установка в «1»  

бита PIEACKx для подтверждения прерывания от группы x;  

шаг 4 – формирование импульса прерывания по линии INTx на ядро 
(PIEACKx продолжает оставаться в единичном состоянии и требует 
программного сброса для возможности приема прерывания ядром  

по линии INTx в дальнейшем); шаг 5 – установка флага IFRx=1;  

шаг 6 – проверка условия IERx=1; шаг 7 – проверка условия  
INTM=1, подготовка адреса возврата и данных к сохранению  

в стеке; шаг 8 – процессор определяет адрес вектора прерывания  
в области PIE Vector Mapping (адреса с 0x00 0D02 по 0x00 0D1C); 

шаг 9 – процессор определяет первичный адрес вектора прерывания  
в области PIE Vector Mapping с учетом текущего значения регистров 

PIEIER и PIEIFR  (адреса с 0x00 0D40 по 0x00 0DFE) 

В сигнальных процессорах семейства С28х имеются три 32-битных 
таймера ядра (CPU timers) с одинаковой структурой. Схема одного тай-

мера приведена на рис. 3.11. Работа таймера разрешается сбросом бита 
TCR.4. Таймер имеет 16-битный предварительный делитель (прескалер) 
PSCH: PSC, который формирует счетный импульс вычитания из основ-
ного 32-битного счетчика TIMH: TIM. По достижении счетчиком TIMH: 

TIM нуля формируется сигнал прерывания /TINT, поступающий на ядро. 
16-битный регистр TDDRH: TDDR используется для перезагрузки  

прескалера таймера. Регистр PRDH: PRD содержит значение основного 
32-битного счетчика, перезагружаемое в него при очередном переопус-
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тошении. Данная каскадная структура позволяет получить очень широ-
кий диапазон коэффициентов деления частоты: от 22

 до 248
. 

Таймеры 1 и 2, как правило, используются для операционной 

системы реального времени «DSP/BIOS», в то время как таймер 0 

применяется для пользовательских приложений. Данные таймеры ин-

тегрированы в ЦСП, не следует их путать с таймерами менеджеров со-
бытий (EvA и EvB). Необходимо отметить, что после сброса разреша-
ется работа всех трех таймеров ядра. 

 

32-битный
регистр периода

PRDH:PRD

16-битный
регистр делитель

TDDRH:TDDR

16-битный
счетчик-предделитель

PSCH:PSC

заём

32-битный
счетчик

TIMH:TIM

Перезагрузка
таймера

RESET

заём

SYSCLKOUT

TCR.4
(Timer stop status)

TINT

32-битный
регистр периода

PRDH:PRD

16-битный
регистр делитель

TDDRH:TDDR

16-битный
счетчик-предделитель

PSCH:PSC

заём

32-битный
счетчик

TIMH:TIM

Перезагрузка
таймера

RESET

заём

SYSCLKOUT

TCR.4
(Timer stop status)

TINTTINT  

Рис. 3.11. Схема таймера ядра ЦСП семейства C28x  
(жирной линией показано прохождение тактового сигнала  

с делением частоты на выход) 

Полный набор программно доступных регистров, относящихся  
к таймерам ядра, показан на рис. 3.12. 

 

Рис. 3.12. Регистры таймеров ядра ЦСП семейства C28x 
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Счетчик-предделитель TIMERxPSC и регистр-делитель 
TIMERxTDDR программно доступны как один 16-разрядный регистр 
TIMERxTPR (рис. 3.13). 

Аналогично, регистры TIMERxPSCH и TIMERxTDDRH, про-
граммно представляют собой единый 16-битный регистр TIMERxTPRH. 

 

Рис. 3.13. Формат регистров-прескалеров TIMERxTPR (x=0,1, 2) 

Функции управления каждым из таймеров реализованы в реги-

страх управления TIMERxTCR, формат которых показан на рис. 3.14. 

  Флаг прерывания  
от таймера (очистка – 

записью «1» 

Разрешение эмуляции
(записью «1 x»)   

Статус таймера
(«0» – старт, «1» – стоп)

Бит перезагрузки 

таймера 
(«1» – перезагрузка)  

Разрешение 
прерывания от таймера 
(«1» – да, «0» – нет 

 

Рис. 3.14. Формат регистров управления таймерами ядра 
(TIMERxTCR) 

Сигналы прерываний, формируемые CPU-таймерами, связаны  

с прерываниями ядра, как показано на рис. 3.15. Прерывание таймера 0 

происходит через PIE, а таймеров 1 и 2 – напрямую на ядро через соот-
ветствующие линии. 
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Рис. 3.15. Сигналы прерываний от CPU-таймеров 

Порядок выполнения работы 

Использование таймера позволяет более эффективно использо-
вать ресурсы процессора. Наиболее простые задачи для таймера –  

вызывать на выполнение периодические задачи либо инкрементиро-
вать глобальную переменную. Данная переменная будет пропорцио-
нальна машинному времени, прошедшему с момента запуска таймера. 

Для выполнения данной работы следует использовать файл  
с программой из предыдущей работы. Но вместо программной за-
держки в этот раз будем использовать аппаратную задержку, форми-

руемую таймером 0 ядра ЦСП. Данный таймер использует систему 
расширения прерываний (PIE).  

1. Создание нового проекта. 
В Code Composer Studio создаем новый проект Lab3.pjt. В поле 

Project Name записываем название проекта «Lab3». В поле Location 

указывается путь, по которому будет находиться проект – 

E:\DspUser\Lab3. 

1.1. Открываем файл с программой формирования бегущих ог-
ней из лабораторной работы № 2 Lab2.с и сохраняем его под именем 

Lab3.с. Затем добавляем файл Lab3.с в проект: Project → Add files  

to Project. 

Структура исходного текста программы показана на рис. 3.16. 

1.2. Добавляем в проект управляющий файл линкера, командные 
файлы, библиотеки, необходимые внешние программные модули (ре-
комендуется для исключения ошибок пути к файлам, указанные ниже, 
копировать в диалоговое окно «Add files to Project»): 
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C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\cmd\DSP281x_Headers_nonBIOS.cmd 
C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 
C:\tidcs\c28\dsp281x\v100\DSP281x_headers\source\DSP281x_GlobalVariableDefs.c 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieCtrl.c 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieVect.c 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_DefaultIsr.c 
C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_CpuTimers.c 

 

2. Настройка параметров проекта. 
2.1. Включаем в проект заголовочные файлы, для этого выбира-

ем Project →  Build Options, в закладке Compiler выбираем Preproces-
sor и в поле Include Search Path (-i) вводим:  

 

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include 
 

2.2. Добавление библиотек и создание стека. 
Подключаем Си-библиотеки: 
 

Project → Build Options → Linker → Libraries → Search Path: 
C:\CCStudio_v3.3\C2000\cgtools\lib 

Project → Build Options → Linker → Libraries → Search Path 
Linker → Incl. Libraries: rts2800_ml.lib 

 

Задаем глубину стека 0х400: 
 

Project → Build Options → Linker → Basic → Stack Size (-stack): 
0x400 

 

 
//################################################################## 
// Имя файла: Lab3.c 
// 
// Описание: С помощью 8 светодиодов, подключенных к линиям  
//  порта GPIOB0 - GPIOB7, формируются "бегущие огни". 
//  Направление движения справа - налево и наоборот 
//################################################################### 
 
#include "DSP281x_Device.h" // Включение заголовочного файла 
 
void delay_loop(long); 
void Gpio_select(void); 
void InitSystem(void); 
 
void main(void) 
{ 
 unsigned int i; 
 unsigned int LED[8]= {0x0001,0x0002,0x0004,0x0008, 
                       0x0010,0x0020,0x0040,0x0080};  
  

 InitSystem();  // Инициализация регистров ЦСП 
 Gpio_select();  // Инициализация линий ввода/вывода  
  

Рис. 3.16. Структура исходного текста программы 
(продолжение и окончание см. на с. 41 и 42) 

1

2
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while(1) 
 {     
       for(i=0;i<14;i++) 
    { 
          if(i<7)  GpioDataRegs.GPBDAT.all = LED[i]; 
          else   GpioDataRegs.GPBDAT.all = LED[14-i];  
          delay_loop(?); 
      } 
     } 
}   
 
 
 
//################################################################### 
// Подпрограмма: delay_loop 
// 
// Описание: Формирование временной задержки горения светодиодов 
//################################################################### 
 
void delay_loop(long end) 
{ 
 long i; 
 for (i = 0; i < end; i++); 
 EALLOW; // Сброс сторожевого таймера 
 SysCtrlRegs.WDKEY = 0x?; 
 SysCtrlRegs.WDKEY = 0x?; 
 EDIS; 
} 
 

//##################################################################### 
// Подпрограмма: Gpio_select 
// 
// Описание: Настройка линий порта GPIO B15-8 на ввод, а линий B7-0  
//  на вывод. Настройка всех линий портов A, D, F, E, G на  
//  ввод. Запрещение работы входного ограничителя 
//##################################################################### 

 
void Gpio_select(void) 

{ 
EALLOW; 

    GpioMuxRegs.GPAMUX.all = 0x?; // Настройка линий ввода/вывода на 
    GpioMuxRegs.GPBMUX.all = 0x?; // работу в качестве портов 
    GpioMuxRegs.GPDMUX.all = 0x?; 
    GpioMuxRegs.GPFMUX.all = 0x?;    
    GpioMuxRegs.GPEMUX.all = 0x?;  
    GpioMuxRegs.GPGMUX.all = 0x?;   
    GpioMuxRegs.GPADIR.all = 0x?; // Настройка портов А, D, E, F, G  
  // на ввод 
    GpioMuxRegs.GPBDIR.all = 0x?; // Настройка линий 15-8 на ввод,  
    GpioMuxRegs.GPDDIR.all = 0x?; // а линий 7-0 на вывод 
    GpioMuxRegs.GPEDIR.all = 0x?;  
    GpioMuxRegs.GPFDIR.all = 0x?;  
    GpioMuxRegs.GPGDIR.all = 0x?;  
 
    GpioMuxRegs.GPAQUAL.all = 0x?; // Запрещение входного ограничителя 
    GpioMuxRegs.GPBQUAL.all = 0x?; 
    GpioMuxRegs.GPDQUAL.all = 0x?; 
    GpioMuxRegs.GPEQUAL.all = 0x?; 
    EDIS; 
}      
 
//##################################################################### 

Рис. 3.16. Продолжение (начало см. на с. 40, окончание – на с. 42) 
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// Подпрограмма: InitSystem 
// 
// Описание: Настройка сторожевого таймера на работу, 
//  предделитель = 1. Выработка сброса сторожевым  
//  таймером. Внутренняя частота работы ЦСП 150 МГц. 
//  Запись в предделитель высокоскоростного таймера  
//  коэффициента деления 2, а в предделитель 
//  низкоскоростного таймера - 4. Запрещение работы  
//  периферийных устройств 
//##################################################################### 
 
void InitSystem(void) 
{ 
    EALLOW; 
    SysCtrlRegs.WDCR= 0x?;  // Разрешение работы сторожевого    
      // таймера, предделитель = 64 
      // или запрещение работы  сторо- 
      // жевого таймера, предделитель = 1 
  
    SysCtrlRegs.SCSR = ?;   // Конфигурирование сброса ЦСП от WDT
  
    SysCtrlRegs.PLLCR.bit.DIV = ?;// Настройка блока умножения частоты 
      SysCtrlRegs.HISPCP.all = 0x?; // Задание значений высокоскоростного   
 SysCtrlRegs.LOSPCP.all = 0x?; // и низкоскоростного предделителей  
       

 
    SysCtrlRegs.PCLKCR.bit.EVAENCLK=?; // Запрещение работы 
    SysCtrlRegs.PCLKCR.bit.EVBENCLK=?; // периферийных устройств 
    SysCtrlRegs.PCLKCR.bit.SCIAENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SCIBENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.MCBSPENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.SPIENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ECANENCLK=?; 
    SysCtrlRegs.PCLKCR.bit.ADCENCLK=?; 
    EDIS; 
} 

 

Рис. 3.16. Окончание (начало см. на с. 40 и 41) 

3. Редактирование программы. 

3.1. В программе Lab3.c объявляем подпрограмму обработки 

прерываний от  CPU-таймера 0: 
 

interrupt void cpu_timer0_isr(void); 
 

Место вставки – область 1 на рис. 3.16. 

Далее в основной программе добавляем вызов подпрограммы: 
 

InitPieCtrl(); 
 

Место вставки – область 2 на рис. 3.16. 

Данная подпрограмма описана в файле DSP281x_PieCtrl.c,  

добавленном в проект. Она позволяет очистить флаги и запретить все 
прерывания, что удобно при написании программ. Просмотреть  

6
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и проанализировать содержимое данного файла можно, открыв его  
в другом окне редактора CCS. Аналогичным образом рекомендуется 
далее ознакомиться и с программами, хранящимися в прочих про-
граммных модулях, подключенных к проекту (файлы *.c). 

3.2. Непосредственно после вызова подпрограммы «Init-

PieCtrl();» добавляем еще один вызов подпрограммы: 
 

InitPieVectTable(); 
 

Данная подпрограмма инициализирует область векторов PIE  

в начальное состояние. Она использует предварительно заданную таб-

лицу прерываний «PieVectTableInit()», которая определена  
в файле DSP281x_PieVect.c, и копирует эту таблицу в глобальную пе-
ременную «PieVectTable», которая связана с областью памяти процес-
сора PIE area. Также для использования подпрограммы  

InitPieVectTable в проект добавлен файл  DSP281x_DefaultIsr.c, 

который добавляет в проект подпрограммы обработки прерываний. 

3.3. Необходимо переопределить имя подпрограммы обработки 

прерываний от CPU-таймера 0 на нашу подпрограмму. Для этого  
в основную программу сразу после вызова подпрограммы  

«InitPieVectTable();» добавляем вызов следующих подпро-
грамм: 

 

EALLOW; 
PieVectTable.TINT0 = &cpu_timer0_isr; 
EDIS; 
 

Здесь EALLOW и EDIS – подпрограммы, используемые соответ-
ственно для разрешения и запрета доступа к системным регистрам 

процессора, а «cpu_timer0_isr» – имя подпрограммы обработки 

прерываний, описанной в программе ранее. 
3.4. Инициализируем CPU-таймер 0. В основную программу 

следует добавить вызов подпрограммы (место вставки – сразу после 
команд, указанных в п. 3.3): 

 

InitCpuTimers(); 
 

Для возможности работы этой подпрограммы в проект добавлен 

файл DSP281x_CpuTimers.c. После этого таймер будет инициализи-

рован и остановлен. 

3.5. Необходимо настроить CPU Timer0 для генерации времен-

ных интервалов в 50 мс при тактовой частоте 150 МГц. Для этого сра-
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зу после вызова  подпрограммы «InitCpuTimers();» добавляем 

вызов подпрограммы: 
 

ConfigCpuTimer(&CpuTimer0, 150, 50000); 
 

Выполнение данной подпрограммы реализует файл 
DSP281x_CpuTimers.c. 

3.6. Настраиваем прерывания от CPU-таймера 0. Необходимо 
настроить три уровня прерывания. 

Первый уровень – модуль PIE, группа PIEIER1 (так как преры-

вания от CPU-таймера 0 относятся именно к данной группе, рис. 3.8): 
 

PieCtrlRegs.PIEIER1.bit.INTx7 = 1; 
 

Второй уровень – разрешение прерываний линии 1 ядра ЦПУ.  

Для этого необходимо настроить регистр IER (рис. 3.2 и 3.3). 
 

IER = 1; 
 

Третий уровень – разрешить глобальные прерывания. Следует 
разрешить глобальные прерывания, добавив в программу команды:  

 

EINT;  
ERTM; 

 

Вызов данных подпрограммы нужно произвести сразу вслед  

за конфигурацией таймера, произведенной в п. 3.6. 

3.7. Затем необходимо добавить команду запуска CPU Timer0: 
 

CpuTimer0Regs.TCR.bit.TSS = 0; 
 

3.8. Сразу после основной программы  (область 3 на рис. 3.16) не-
обходимо добавить подпрограмму обработки прерываний от CPU-тай- 

мера 0 «cpu_timer0_isr». Подпрограмму и обращение к ней мы уже 
внесли в программу. Теперь необходимо написать саму подпрограмму. 
Подпрограмма  будет иметь общий вид: 

 

interrupt void cpu_timer0_isr(void) 
{ 
… 
(текст подпрограммы) 
… 
} 

Подпрограмма должна выполнять следующие действия:  
– инкрементировать глобальную переменную «CpuTimer0. 

InterruptCount», описываемую (начальное значение = 0) в под-
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ключаемом файле DSP281x_CpuTimers.c. Данная переменная будет 
показывать истечение интервала времени 50 мс с момента запуска 
таймера;  

– сбросить в «0» бит 1 регистра PIEACK, что необходимо для раз-
решения последующих прерываний. Это действие выполняет команда: 

 

PieCtrlRegs.PIEACK.all = PIEACK_GROUP1; 
 

3.9. После настройки таймера и прерываний корректируем ос-
новную программу. Для этого удаляем (либо добавляем в начале 
строки признак комментария «//») вызов подпрограммы «de-

lay_loop(?);» (область 4 на рис. 3.16). Также удаляем объявление 
этой подпрограммы (область 5 на рис. 3.16), и заключаем в скобки 

комментария саму подпрограмму «void delay_loop(long 

end)». Скобки комментария открываются парой символов «/*» и за-
крываются парой символов «*/». 

Затем необходимо программно реализовать цикл ожидания для 
формирования задержки длительностью 150 мс, с учетом того, что пере-
менная «CpuTimer0.InterruptCount» однократно инкрементиру-
ется в подпрограмме «interrupt void cpu_timer0_isr(void)» 

каждые 50 мс. Место вставки цикла ожидания – область 4 на рис. 3.16. 

После цикла ожидания необходимо сбросить переменную 

«CpuTimer0.InterruptCount» в 0. 

3.10. Разрешаем работу Watchdog timer (WDT) (область 6  

на рис. 3.16). 

3.11. Добавляем обслуживание WDT. Для этого необходимо по-
следовательно записать в регистр WDKEY коды «0x55» и «0xAA», 

аналогично тому, как это выполнялось в программе к лабораторной 

работе № 2 (область 7 на рис. 3.16). Отличием является то, что дан-

ную процедуру вместе с макросами EALLOW и EDIS нужно перенести 

внутрь подпрограммы обработки прерывания от CPU-таймера 0.  

Поскольку прерывание от таймера «interrupt void 

cpu_timer0_isr(void)» происходит циклично с периодом 50 мс, 
сброс ЦСП от WDT не происходит. 

4. Компиляция, компоновка и загрузка выходного файла  
в отладочный модуль ЦСП. 

4.1. Компилируем программу: Project → Compile File. При нали-

чии ошибок исправляем их. 
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4.2. Компонуем проект: Project → Build. При наличии ошибок, 
исправляем их. 

4.3. Загружаем выходной файл: File → Load Program → Debug\ 

lab3.out (в случае, если данная функция сконфигурирована для вы-

полнения автоматически, выполнять данный пункт не нужно). 

Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, тексты исследуемых программ, результаты 

их выполнения, выводы. 

Контрольные вопросы 

1. Маскируемые и немаскируемые прерывания.  
2. Сброс ЦСП. 

3. Обработка прерываний ядра ЦСП семейства C28x. 

4. Назначение и структура модуля расширения прерываний 

(PIE) ЦСП семейства C28x. 

5. Расположение векторов прерываний ЦСП семейства C28x  

в режимах ENPIE=0 и ENPIE=1. 

6. Процедура обработки прерываний при ENPIE=1. 

7. Назначение и структура CPU-таймеров ЦСП семейства C28x. 

 

8. Регистры CPU-таймеров ЦСП семейства C28x. 

9. Укажите, какие изменения необходимо внести в исходный 

текст, чтобы программа «бегущие огни» выполнялась с движением 

«горящих» светодиодов: 
– в 1,7 раз быстрее;  
– в 2,45 раз медленнее. 
10. Поясните, какие изменения необходимо внести в исходный 

текст, чтобы программа «бегущие огни» выполнялась: 
– с замедлением движения «горящих» светодиодов в 2 раза  

на каждом шаге движения; 
– с ускорением движения «горящих» светодиодов в 3 раза на каж-

дом шаге движения. 
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Лабораторная работа № 4 

Формирование сигналов  
широтно-импульсной модуляции на основе 
сигнального процессора семейства C28х 

Цель работы 

Изучить принципы формирования сигналов широтно-импульсной 

модуляции на основе ЦСП TMS320F2812, организацию и програм- 

мирование встроенной периферии, предназначенной для реализации 

сигналов специальной формы и ШИМ-модулированных сигналов. 

Основные теоретические сведения 

1. Структура Менеджера Событий 

Менеджер Событий (EV) включает в себя таймеры общего  
назначения (GP), устройства сравнения/ШИМ, устройства захвата, 
схему квадратурного анализа (QEP). 

В сигнальном процессоре TMS320F2812 имеется два Менеджера 
Событий (EVA и EVB), которые выполняют аналогичные функции. 
EVA и EVB имеют идентичные регистры, расположенные по разным 
адресам.  

 

Рис. 4.1. Менеджер Событий 
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Каждый Менеджер Событий управляется своей собственной ло-
гикой. Она может запрашивать прерывания. Менеджер Событий по-
зволяет запускать встроенный либо внешний аналого-цифровой пре-
образователь. Для запуска внешнего АЦП на выводах EVASOC или 

EVBSOC (которые мультиплексируются с сигналами T2CTRIP   

и )T4CTRIP  вырабатывается строб начала преобразования (SOC). 

На рис. 4.1 представлена функциональная схема модуля Менеджера 
Событий (EVA). 

Рассмотрим блоки EVM подробнее. 

2. Таймеры общего назначения  

В каждом модуле EVM имеется по два GP (General Purpose) 

таймера общего назначения. В отличие от таймеров CPU, которые 
имеют разрядность 32 бита, таймеры Менеджера Событий являются 
независимыми 16-разрядными устройствами, c расширенной систе-
мой ввода/вывода. Они могут работать независимо друг от друга или 

быть синхронизированными. 

Таймер общего назначения модуля EVM дан на рис. 4.2. 

 

Рис. 4.2. Таймер общего назначения модуля EVM 

Центральным блоком GP таймера является блок сравнения. 
Здесь происходит сравнение значения 16-битного счетчика (TxCNT)  

с двумя другими регистрами: регистром сравнения (TxCMPR) и реги-

стром периода (TxPR). Если значения счетчика и регистра сравнения 
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равны, то выходной формирователь устанавливает в «1» выходной 

сигнал (TxPWM). При достижении счетчиком значения регистра пе-
риода TxPWM сбрасывается.  

Особенностью DSP TMS320F2812 является наличие буферов  
регистров TxCMPR и TxPR которые позволяют обновлять значения 
по заранее заданным событиям:  

а) достижение GP таймером-счетчиком нуля; 
б) достижение GP таймером-счетчиком значения, равного зна-

чению в регистре периода; 
в) немедленная загрузка после записи в буфер. 
Наличие буферов позволяет записывать новые значения в реги-

стры в любой момент времени, не дожидаясь окончания цикла. За-
грузка значения из буфера в регистр периода происходит только при 

достижении GP таймером-счетчиком нуля. 
Источником тактирования счетчика может являться: внешний 

сигнал (TCLKIN), тактовые импульсы от схемы квадратурного анали-

за (QEP) или тактовый сигнал от высокоскоростного предделителя 
(HSPCLK).  

В регистрах EVAIFRA, EVAIFRB, EVBIFRA, EVBIFRB имеются 
биты, отражающие флаги прерывания GP таймеров. Каждый из 4 GP 

таймеров может вырабатывать  прерывание на следующие события при 

достижении: 

а) GP таймером-счетчиком нуля 0000h (TxUFINT); 

б)  максимального значения FFFFh (TxOFINT); 

в)  заданного значения сравнения (TxCINT); 

г)  значения, равного значению в регистре периода (TxPINT). 

Каждый GP таймер может работать  в одном из 4 режимов. 
1. СТОП/Хранение. В этом режиме GP таймер останавливается  

и удерживает текущее значение, при этом таймер-счетчик, выходы 

сравнения и значение предделителя остаются без изменения. Если же 
остановить таймер, просто запретив его работу, то счетчик будет 
сброшен и значение предделителя установится в х/1. 

2. Непрерывный режим счета вверх. В этом режиме значение 
счетчика увеличивается до тех пор, пока не достигнет значения, рав-
ного значению в регистре периода (рис. 4.3). После этого счетчик 
сбрасывается в ноль и начинает считать сначала. При этом вырабаты-

вается флаг прерывания, который остается установленным в течение 
одного такта. Если флаг не был маскирован, то вырабатывается за-
прос прерывания от периферийного устройства. 
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Рис. 4.3. Режим непрерывного счета вверх GP таймера  

Продолжительность периода равна (TxPR)+1, за исключением 

первого периода, который может быть произвольным, так как началь-
ное значение в счетчике может быть любым от 0000h до FFFFh. 

Если исходное значение  больше, чем значение в регистре пе-
риода, то таймер досчитает до FFFFh, сбросится в ноль и продолжит 
работать так, как если бы исходное значение было равно нулю. При 

достижении счетчиком значения, равного значению в регистре перио-
да, устанавливается флаг прерывания по периоду, происходит сброс  
в ноль и устанавливается флаг прерывания по нулю. 

Если исходное значение в счетчике находится между нулем  

и значением в регистре периода, то таймер сначала досчитает до зна-
чения в регистре периода, а затем будет работать так, как был запро-
граммирован. 

3. Управляемый режим счета «вверх/вниз» (рис. 4.4). В этом 

режиме направление счета зависит от состояния входа TDIRA/B: 

вверх, если сигнал на TDIRA/B высокого уровня; вниз – если низкого. 

 

Рис. 4.4. Режим управляемого счета «вверх/вниз» GP таймера 
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4. Непрерывный режим счета «вверх/вниз» (рис. 4.5). В отличие 
от предыдущего режима, направление счета изменяется при достиже-
нии нуля или значения в регистре периода. Продолжительность пе-
риода в этом режиме равна 2·(TxPR). 

 

Рис. 4.5. Непрерывный режим счета «вверх/вниз» 

Устройство захвата (Capture Unit) предназначено для опреде-
ления временных параметров внешних сигналов. Значение выбранно-
го GP таймера захватывается и запоминается в 2-уровневом стеке 
FIFO, когда на соответствующих выводах фиксируется заданный пе-
репад уровней. Устройство захвата состоит из 3 цепей CAPx (x=1, 2 
или 3 – для EVA; x=4, 5 или 6 – для EVB). 

Устройство захвата обладает следующими особенностями: 
1) имеется один 16-разрядный регистр управления захватом 

(CAPCONx); 
2) есть один 16-разрядный регистр статуса FIFO (CAPFIFOx); 
3) качестве тактирования можно использовать любой GP таймер; 
4) все входы синхронизируются таймерами CPU; 
5) пользователь сам устанавливает, по какому уровню осущест-

влять захват; 
6) имеется 3 маскируемых флага прерывания. 
Входы CAP 1/2 и CAP 4/5 также могут быть использованы как 

входы схемы квадратурного анализа. 
Устройство сравнения. В каждом EVM предусмотрено по 3 уст-

ройства сравнения (Compare Unit). Эти устройства используют GP тай-
мер 1 в качестве синхронизатора, и могут вырабатывать до 6 выходных 
сигналов сравнения (ШИМ-сигналов). Все 6 выходов работают незави-
симо друг от друга. Регистры сравнения дублируются, позволяя фикси-
ровать изменения ширины импульсов. Они позволяют снизить до ми-
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нимума программную загрузку ядра при операциях измерений длитель-
ности, периодических выборок и генерации сигналов ШИМ.  

Схема квадратурного анализа используется для подключения 
энкодера – оптического преобразователя направления и скорости 
вращения. Выходными сигналами энкодера являются два сигнала ти-
па меандр, по частоте и фазовым сдвигам которых можно определить 
направление и скорость вращения. Схема QEP по этим сигналам фор-
мирует два сигнала: логический сигнал направления вращения (DIR) 
и частотный сигнал скорости вращения (CLK)  

3. Формат регистров модуля Менеджера Событий 

Формат регистра счетчика GP таймера дан на рис. 4.6. 

Регистр счетчика GP таймера (TхCNT)  
 15                                                                                                                 0 

TхCNT 

R/W – x 
 

Биты Название Описание 
15:0 T1CNT Мгновенное значение таймера-счетчика 1 

Рис. 4.6. Формат регистра счетчика GP таймера 

Формат регистра сравнения GP таймера приведен на рис. 4.7. 

Регистр сравнения GP таймера (TхCMPR) 

15  0 

 T1CMPR  

R/W – x 
 

Биты Название Описание 
15:0 T1CMPR Хранимое значение сравнения таймера-счетчика 1 

Рис. 4.7. Формат регистра сравнения GP таймера  

Формат регистра периода GP таймера показан на рис. 4.8. 

Регистр периода GP таймера (TхPR) 

15  0 

 T1PR  

R/W – x 
 

Биты Название Описание 
15:0 T1PR Хранимое значение периода таймера-счетчика 1 

Рис. 4.8. Формат регистра периода GP таймера  
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Регистры управления таймером (TхCON) представлены на рис. 4.9. 

 

 

Рис. 4.9. Регистры управления таймером (TхCON) 

 

 

 

 



 54

Регистр А управления GP таймером (GPTCONA) приведен  

на рис. 4.10. 

 

 

Рис. 4.10. Регистр А управления GP таймером (GPTCONA) 
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Формат регистра А маски прерываний (EVAIMRA) дан на рис. 4.11. 

 

Рис. 4.11. Формат регистра А маски прерываний (EVAIMRA) 

Формат регистра B маски прерываний (EVAIMRB) представлен 

на рис. 4.12. 

 

Рис. 4.12. Формат регистра B маски прерываний (EVAIMRB) 
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Формат регистра C маски прерываний (EVAIMRC) показан на 
рис. 4.13. 

 

Рис. 4.13. Формат регистра C маски прерываний (EVAIMRC) 

Формат регистров флагов прерываний приведен на рис. 4.14. 

 

Рис. 4.14. Формат регистров флагов прерываний 

4. Прерывания Менеджера Событий 

Если от какого-либо периферийного устройства пришло преры-

вание, то в регистрах EVxIFRA, EVxIFRB или EVxIFRC (x=A или B) 

устанавливается соответствующий флаг.  



 57

Прерывания Менеджера Событий могут быть индивидуально 
разрешены/запрещены с помощью маскирования прерываний в реги-

страх EVxIMRA, EVxIMRB или EVxIMRC. Бит, установленный в 1, 

разрешает (не маскирует) прерывания, сброшенный в 0 – запрещает 
(маскирует). Если установлены биты флага и маскирования прерыва-
ния, то в модуль PIE (Peripheral Interrupt Expansion) отправляется за-
прос на прерывание. Логика PIE записывает все запросы прерывания 
и вырабатывает прерывание CPU. 

При получении от INT 1, 2, 3, 4 или 5 запроса прерывания, уста-
навливается соответствующий бит в регистре флага прерывания CPU 

(IFR). Если соответствующий бит регистра маскирования прерываний 

(IER) установлен и сброшен бит INTM, то CPU признает прерывание. 
Далее CPU завершает выполнение текущей инструкции и переходит 
на адрес вектора прерываний соответственно INT 1.y, 2.y, 3.y, 4.y, 5.y 

в таблице вектора PIE. В это время сбрасывается бит IFR и устанав-
ливается бит INTM, запрещая очередное прерывание. 

Вывод и прерывание PDP (power drive protect) предназначены 

для защиты внешнего силового преобразователя от перегрузок, в том 

числе от коротких замыканий. Функция PDP позволяет защитить 
внешние силовые устройства при системных сбоях. 

5. Примеры использования менеджера событий 

Менеджер событий предназначен для формирования управляю-

щих сигналов и для определения временных характеристик внешних 
информационных сигналов. Наличие специализированного аппарат-
ного модуля позволяет разгрузить ЦПУ для других задач. Одно  
из применений TMS320F2812 – системы электропривода. Для форми-

рования ШИМ – сигналов специальной формы (например, синусои-

дального) используют один из двух методов. 
Первый метод предполагает вычисление функции синуса, кото-

рая входит в библиотеку «math.lib». Для этого в проект включается 
заголовочный файл «math.h», который позволяет обратиться к биб-
лиотеке математических функций. Но функция синуса в библиотеке 
«math.lib» – это функция с плавающей запятой и для ее реализации на 
процессоре F2812, работающего с фиксированной запятой, потребу-
ется много времени. 

Второй метод основан на работе с таблицей, в которую предва-
рительно занесены рассчитанные значения функции. Этот метод еще 
называют «доступ к поисковой таблице» («Lookup Table Access»). 
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Электронные устройства контроля используют такие таблицы не 
только для вычисления тригонометрических функций, но и для опре-
деления параметров управления. Доступ ячейкам таблицы осуществ-
ляется быстро, всего за несколько тактов можно определить требуе-
мое значение функции. Увеличить точность вычисления функций 

можно, применив аппроксимацию. Таблица может быть как одномер-
ной (выходная величина зависит от одного параметра), так и много-
мерной (выходная величина – функция двух и более переменных). 
Чем больше число ячеек таблицы, тем точнее аппроксимация исход-
ной функции. В ПЗУ процессора TMS320F2812 уже «зашита» таблица 
синуса. Таблица использует дробно-целочисленный формат с фикси-

рованной запятой IQ, или Q. Представлена она в формате Q30. Это 
означает, что 30 младших бит представляют дробную часть числа, 
один – целую и старший – знак числа.   

Порядок выполнения работы 

Часть I. Формирование сигналов звуковой частоты   

при помощи прямоугольных импульсов 

В работе необходимо сгенерировать звуковую гамму (звуковой 

ряд) используя динамик, соединенный с выходом T1PWM. В первой 

части лабораторной работы звучание организуется при помощи пря-
моугольных импульсов, генерируемых таймером Менеджера Собы-

тий. Каждая нота будет воспроизводиться 500 мс. Загрузка новой но-
ты будет производиться по прерыванию таймера ЦПУ 0. Период 
таймера ЦПУ – 50 мс. В подпрограмме обслуживания прерываний  

от ЦПУ таймера 0 следует производить сброс Watchdog  и загружать 
новую ноту. Обратите внимание на период между прерываниями тай-

мера, периодом Watchdog и периодом перезагрузки новой ноты.  

Соответствие частот музыкальным нотам приведено в табл. 4.1. 

Таблица 4.1 

Соответствие частот музыкальным нотам 

Нота С1 
D E F G A H C

2 

Частота, Гц 264 297 330 352 396 440 495 528 

 

1. Создание нового проекта. 
В Code Composer Studio создаем новый проект Lab4.pjt. Откры-

ваем файл Lab4.c и сохраняем его E:\C281x\Labs\Lab4\lab4.c. 
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Добавляем в проект файлы: 
 

C:\CCStudio_v3.3\C2000\cgtools\lib\rts2800_ml.lib 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_CpuTimers.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_DefaultIsr.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieCtrl.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieVect.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_headers\source\DSP281x_GlobalVariableDefs.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 

C:\tidcs\c28\dsp281x\v100\DSP281x_headers\cmd\DSP281x_Headers_nonBIOS.cmd 
 

2. Настройка параметров проекта, компоновка проекта и за-
грузка выходного файла. 

Включаем в проект заголовочные файлы: Project →  Build 

Options, в закладке Compiler выбираем Preprocessor и в поле Include 

Search Path (-i) вводим: 
 

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include 
 

Задаем глубину стека: Project → Build Options → Linker → Stack 

Size: 0x400. 

Компонуем проект: Project → Build.  

Загружаем выходной файл: File → Load Program → Debug\ 

lab4.out. 

3. Преобразование файла Lab4.c. 

Удаляем те части программы, которые не будут использоваться 
в данной лабораторной работе: массив LED[8]. 

Переходим к подпрограмме «Gpio_select()». Настраиваем 

линию 6 порта GPIOA на вывод функции T1PWM (GPАMUX). 

В подпрограмме «InitSystem» разрешаем работу Менеджера 
Событий А. 

Внутри главной подпрограммы записываем:  
 

CpuTimer0Regs.TCR.bit.TSS = 0. 
 

Настраиваем таймер 1 Менеджера Событий на выработку моду-
лированного сигнала PWM: 

Бит «TCMPOE» устанавливаем в 1, задаем «активный низкий» 

уровень (GPTCONA); 

В регистре T1CON устанавливаем: режим счета вверх (TMODE), 

делитель 128 (TPS), запрещаем работу таймера (TENABLE), выбира-
ем внутреннюю синхронизацию (TCLKS), разрешаем сравнение 
(TECMPR); 
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Определяем значения регистра периода (T1PR) для разных час-
тот и заносим их в массив int frequency [8] = 

{?,?,?,?,?,?,?,?}. Исходя из формулы 

 
PRTTPSHISPCP

FreqPWMT
1

MГц150
__1


   (4.1) 

для первой ноты в регистр периода необходимо занести:  

T1PR = 150 MГц/(2*128*264 Гц) = 2219, для второй ноты T1PR =  

= 150 MГц/(2*128*297 Гц) = 1973 и т. д. 

Так как сторожевой таймер будет сбрасываться быстрее (каж-

дые 200 мс), чем прозвучит следующая нота (через 500 мс), то задаем 

условия: 
 

if ((CpuTimer0.InterruptCount%4)==0) SysCtrlRegs.WDKEY = 
= 0xAA 

 

 

Разбиваем период воспроизведения нот на 10 периодов по 50 мс, 
для этого записываем условие:  

 

if ((CpuTimer0.InterruptCount – time_stamp ) > 10). 
 

После чего переменной «time_stamp» присваиваем текущее 
значение CpuTimer0.InterruptCount, загружаем код следую-

щей ноты в T1PR, а в регистр T1CMPR заносим значение, равное 
T1PR/2. Разрешаем работу таймера. 

4. Тестирование программы.  

Сбрасываем ЦСП: Debug → Reset CPU, Debug → Restart. 

Переходим к главной подпрограмме: Debug → Go main. 

Запускаем программу: Debug → Run.  

Часть II. Формирование сигналов звуковой частоты  

при помощи синусоидальных импульсов 

Во второй части работы необходимо вывести синусоидальный 

ШИМ-сигнал. Отметим, что музыкальная нота – это гармоническое 
синусоидальное колебание определенной частоты, поэтому, изучив 
принцип получения синусоидальных колебаний, можно получить 
чистоту звучания нот, близкую к реальности. В табл. 4.1 представлено 
соответствие частот и нот музыкального звукоряда. 

Для расчета частоты синусоидальных колебаний используется 
формула 
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 ,sin
PWM

PWM

N

f
f     (4.2) 

где PWMf  – частоты модулированных импульсов; PWMN  – число мо-
дулированных импульсов за период. 

1. Создание нового проекта. 
1.1. Создаем новый проект Lab4А.pjt.  

1.2. Добавляем в проект файлы (п. 1.2 части I), кроме файла 
DSP281x_CpuTimers.c, и вместо lab4.c загружаем lab4А.c. 

2. Настройка параметров проекта, компоновка проекта и за-
грузка выходного файла (аналогично п. 2.1–2.4 части I данной лабо-
раторной работы). В  закладке Compiler выбираем Preprocessor и в поле 
Include Search Path (-i) вводим: 

 

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include; 

C:\tidcs\C28\IQmath\cIQmath\include 
 

3. Преобразование файла Lab4А.c. 

Удаляем те строки программы, которые касаются работы таймера 0 

ядра процессора F2812: ConfigCpuTimer(&CpuTimer0, 150, 

50000), InitCpuTimers(), CpuTimer0Regs.TCR.bit.TSS = 0, 

переменные i и time_stamp, массив frequency [8]. 

Переименовываем подпрограмму «cpu_timer0_isr()»  

в «T1_Compare_isr» и в ней добавляем строку: 
PieCtrlRegs.PIEACK.all = PIEACK_GROUP2, устанавливаем 

бит T1CINT регистра EVAIFRA в 1. 

Добавляем инструкцию, разрешающую в модуле расширения 
прерываний PIE прерывание от GP таймера 1: 

PieCtrlRegs.PIEIER2.bit.INTx5=1 и устанавливаем разреше-
ние прерывания ядра процессора INT2: IER = 2. 

Настраиваем таймер 1 Менеджера Событий (аналогично  
пп. 3.5.1–3.5.2 части I): записываем коэффициент деления равный 1, 

устанавливаем бит T1CINT регистра EVAIMRA в 1. 

В регистр периода (T1PR) заносим значение, рассчитанное по 
формуле 

 ,
1 1 HISCPTPSPRT

f
f

T

CPU
PWM 

  (4.3) 

где 50PWMf  кГц, 150CPUf  МГц, HISCP = 2, TPS = 1. 
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Принцип формирования синусоидального сигнала широтно-
импульсной модуляцией приведен на рис. 4.15. 

T
t 

 

Рис. 4.15. Принцип формирования синусоидального сигнала  
широтно-импульсной модуляцией  

4. Тестирование программы.  

Сбрасываем ЦСП: Debug → Reset CPU, Debug → Restart. 

Переходим к главной подпрограмме: Debug → Go main. 

Запускаем программу: Debug → Run.  

Устанавливаем точку останова на строчке: 
PieCtrlRegs.PIEACK.all = PIEACK_GROUP2. 

5. Включение библиотеки «Q-Math» в проект. 
Добавляем в начальную часть текста программы строки: 
 

 #include "IQmathLib.h",  
_iq30 sine_table[512], 

#pragma DATA_SECTION(sine_table,"IQmathTables");  
 

и добавляем файл Lab4A.cmd. 

6. Расчет необходимого значения регистра сравнения. 

Учитывая, что разность значений регистра периода и регистра 
сравнения определяет ширину выходного модулированного импульса 
(рис. 4.16), а значения функции синуса изменяются от –1 до +1, рас-
считываем значение регистра сравнения по формуле: 

 

 T1CMPR = T1PR – _IQ30mpy(sine_table[index] +  

 + _IQ30(0.9999),T1PR/2),  (4.4) 
 

где функция IQ30mpy(a, b) – умножение чисел a и b в формате IQ30;  

_IQ30(0.9999) – оттранслированное значение единицы. 
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Изменение ширины импульса при ШИМ по синусоидальному 
закону представлено на рис. 4.16. 

T1PR 

 

 

 

T1PR/2 

 

 

 

0 

 

 

 

T1PWM_

T1CMP 

T1CMPR 

T1CNT 

 

Рис. 4.16. Изменение ширины импульса при ШИМ  

по синусоидальному закону 

Чтобы избежать переполнения, применим функцию насыщения 
_IQsat (x, max, min). Тогда окончательно записываем в под-

программу T1_Compare_isr формулу для расчета необходимого 
значения регистра сравнения: 

 
EvaRegs.T1CMPR = EvaRegs.T1PR – IQsat(_IQ30mpy(sine_table[index] + 

_IQ30(0.9999),EvaRegs.T1PR/2),EvaRegs.T1PR,0). 

7. Расчет частоты синусоидальных колебаний. 

Для этого используем формулу (4.2), задаемся 50PWMf  кГц, 

,128PWMN  т. е. из таблицы значений синуса выбираем каждое чет-
вертое число, добавляем строку: 

  

index += 4. 
 

Тогда 6,390sin f  Гц. 

Компонуем проект: Project → Rebuild All. 

Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, рисунки, поясняющий принцип формирова-
ния ШИМ-сигналов, тексты исследуемых программ, результаты их 
выполнения, выводы. 
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Контрольные вопросы 

1. Назначение и структура Менеджера Событий DSP 

TMS320F2812. 

2. Структура таймеров Менеджера Событий, их отличие от тай-

меров ЦПУ по структуре и назначению.  

3. Режимы работы таймеров Менеджера Событий. 

4. Регистры Менеждера Событий. 

5. ШИМ-сигнал: определение, формирование с помощью Ме-
неджера Событий. 

6. Прерывания Менеджера Событий. 
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Лабораторная работа № 5 

Ввод и масштабирование аналоговых  
сигналов в процессорах семейства C28х 

Цель работы 

Изучить структуру встроенного АЦП цифрового сигнального 
процессора TMS320F2812, режимы его работы. Научиться разрабаты-

вать простейшие программы с использованием АЦП. 

Основные теоретические сведения 

1. Структура модуля АЦП 

Модуль АЦП содержит ядро АЦП, два устройства выборки – 

хранения, аналоговый мультиплексор, мультиплексор УВХ, мультип-

лексор результата и автоматический секвенсер (устройство управления 
работой АЦП и мультиплексоров). 12-битный АЦП имеет 16 мульти-

плексированных входов. АЦП может работать либо в каскадном, либо 
в двухканальном режимах. 

Структура АЦП в каскадном режиме представлена на рис. 5.1. 

Как видно из рисунка, в этом режиме работой модуля управляет один 

автоматический секвенсер. Перед запуском необходимо задать число 
преобразований  («MAX_CONV1») и номер канала, который будет 
преобразован на каждом шаге («CHSELxx»). Результат преобразова-
ния на каждом шаге сохраняется в соответствующий регистр («RE-

SULT0» to «RESULT15»).  

Можно задать два режима захвата сигналов – одновременный  

и последовательный. В первом случае два УВХ работают в параллель, 
т. е. выборка и захват происходят одновременно. При этом за один 

шаг осуществляется преобразование двух каналов различных групп  

с одинаковым кодом (например, ADCINA3 и ADCINB3). В последо-
вательном режиме сигнал с любого входа может быть преобразован 

на любом шаге. Запуск преобразования может осуществляется про-
граммно, от внешнего источника или от менеджеров событий А или 

В. Запуск от Менеджера Событий осуществляется аппаратно, без ис-
пользования прерываний, что позволяет очень точно задавать интер-
вал преобразования. Прерывания от АЦП для обработки результатов 
могут быть сконфигурированы либо после каждого преобразования, 
либо по окончании преобразования последовательности.  
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Рис. 5.1. Блок-схема модуля АЦП в каскадном режиме 

 

Рис. 5.2. Блок-схема модуля АЦП в двухканальном режиме 

В двухканальном режиме (рис. 5.2) автоматический секвенсер 
разделяется на две независимые части («SEQ1» и «SEQ2») со свои- 

ми настройками и сигналами запуска. Входные каналы задается  
в регистрах CHSEL00…CHSEL07 для последовательности SEQ1  
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и CHSEL08…CHSEL15 для последовательности SEQ2, результаты  

преобразования сохраняется в регистрах RESULT0...RESULT7 и  

RESULT8...RESULT15 соответственно. Для любой из двух последо-
вательностей может быть задан любой из 16 входных каналов. Дан-

ный режим позволяет получить фактически два независимых АЦП,  

со своими регистрами управления и сигналами запуска. Арбитр по-
следовательности используется в случае одновременного появления 
сигналов запуска от двух последовательностей. В таком случае при-

оритет имеет SEQ1, преобразование SEQ2 будет задержано до окон-

чания SEQ1.  

2. Время преобразования и система тактирования АЦП 

Рассмотрим настройку тактирования АЦП на примере. Тактиро-
вание АЦП осуществляется от высокоскоростного прескалера пери-

ферии HSPCLK (рис. 5.3).  

 

Рис. 5.3. Пример конфигурации модуля тактирования АЦП 

Максимальная частота на выходе  HSPCLK составляет 150 МГц. 

Максимальная частота тактирования АЦП FCLK согласно докумен-

тации составляет 25 МГц. ADCCLKPS служит для формирования 
требуемой частоты FCLK из HSPCLK. Бит CPS позволяет при необ-

ходимости понизить частоту в два раза. Полученная ADCCLK пода-
ется на ядро АЦП и на устройство выборки-хранения. Битами 

ACQ_PC можно задать необходимое время захвата сигнала. За это 
время сигнал на УВХ должен установиться с заданной точностью. 
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Время захвата зависит от сопротивления источника сигнала, характе-
ристик сигнала, требуемой точности и рассчитывается для каждого 
случая отдельно. В лабораторных работах сигнал подается с потен-

циометра, высокая точность не требуется, поэтому время выборки 

может быть задано любое.  
Минимальное время преобразования для первого канала в по-

следовательности составляет 200 мкс, для последующих – 80 мкс.  

3. Формат регистров модуля АЦП 

Формат регистров модуля АЦП представлен ниже: 
 
ADCCLKPS 

[3:0] 

Делитель  
частоты  

ядра 

ADCLK 

(частота тактирования АЦП) 

0000 0 HSPCLK/(ADCTRL1[7] + 1)  

0001 1 HSPCLK/[2*(ADCTRL1[7] + 1)]  

0010 2 HSPCLK/[4*(ADCTRL1[7] + 1)]  

0011 3 HSPCLK/[6*(ADCTRL1[7] + 1)]  

0100 4 HSPCLK/[8*(ADCTRL1[7] + 1)]  

0101 5 HSPCLK/[10*(ADCTRL1[7] + 1)]  

0110 6 HSPCLK/[12*(ADCTRL1[7] + 1)]  

0111 7 HSPCLK/[14*(ADCTRL1[7] + 1)]  

1000 8 HSPCLK/[16*(ADCTRL1[7] + 1)]  

1001 9 HSPCLK/[18*(ADCTRL1[7] + 1)]  

1010 10 HSPCLK/[20*(ADCTRL1[7] + 1)]  

1011 11 HSPCLK/[22*(ADCTRL1[7] + 1)]  

1100 12 HSPCLK/[24*(ADCTRL1[7] + 1)]  

1101 13 HSPCLK/[26*(ADCTRL1[7] + 1)]  

1110 14 HSPCLK/[28*(ADCTRL1[7] + 1)]  

1111 15 HSPCLK/[30*(ADCTRL1[7] + 1)]  

 

Делитель частоты ядра. Периферийная частота процессора, 
HSPCLK, делится на 2*ADCCLKPS[3:0], за исключением, когда 
ADCCLKPS[3:0] = 0000, в этом случае HSPCLK не делится. Получен-

ная частота дополнительно делится на ADCTRL1[7]+1.  

Регистры 1–3 управления АЦП представлены на рис. 5.4–5.6. 
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Рис. 5.4. Регистр 1 управления АЦП  (ADCTRL1) 
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Рис. 5.5. Регистр 2 управления АЦП (ADCTRL2) 
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Рис. 5.6. Регистр 3 управления АЦП (ADCTRL3) 

Формат регистра регистра числа каналов для преобразования  
ADCMAXCONV приведен на рис. 5.7. 

 

Рис. 5.7. Формат регистра регистра числа каналов  
для преобразования ADCMAXCONV 
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Регистр статуса автопоследовательности (ADCASEQASR) пока-
зан на рис. 5.8. 

 

Рис. 5.8. Регистр статуса автопоследовательности (ADCASEQASR) 

Каждый набор из 4 бит CONVnn выбирает один из 16 аналого-
вых входов АЦП для последовательного автоматического преобразо-
вания: 

  

Значение CONVnn Выбираемый канал АЦП 

0000 ADCINA0 

0001 ADCINA1 

0010 ADCINA2 

0011 ADCINA3 

0100 ADCINA4 

0101 ADCINA5 

0110 ADCINA6 

0111 ADCINA7 

1000 ADCINB0 

1001 ADCINB1 

1010 ADCINB2 

1011 ADCINB3 

1100 ADCINB4 

1101 ADCINB5 

1110 ADCINB6 

1111 ADCINB7 
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Формат регистра ADCRESULTn представлен на рис. 5.9. 
 

Буферный регистр результата АЦП (ADCRESULTn) 

 

Рис. 5.9. Формат регистра ADCRESULTn 

В каскадном режиме начиная с регистра ADCRESULT8 по ре-
гистр ADCRESULT15 содержат результаты преобразования с девято-
го по шестнадцатый. Значения всех регистров ADCRESULTn выров-
нены по левому краю.  

Порядок выполнения работы  

1. Создание проекта. 
1.1. В Code Composer Studio создаем новый проект Lab5.pjt. Ко-

пируем из папки c:\tidcs файл lab5.c в папку с созданным проектом. 

Добавляем lab5.c в проект. 
1.2. Добавляем в проект следующие файлы: 
 

C:\tidcs\c28\dsp281x\v100\DSP281x_headers\source\DSP281x_GlobalVariableDefs.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\cmd\F2812_EzDSP_RAM_lnk.cmd 

C:\tidcs\c28\dsp281x\v100\DSP281x_headers\cmd\F2812_Headers_nonBIOS.cmd 

C:\ti\c2000\cgtools\lib\rts2800_ml.lib 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieCtrl.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_PieVect.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_DefaultIsr.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_Adc.c 

C:\tidcs\c28\dsp281x\v100\DSP281x_common\source\DSP281x_usDelay.asm 
 

1.3. Включаем в проект заголовочные файлы: Project → Build 

Options, в закладке Compiler выбираем Preprocessor и в поле Include 

Search Path (-i) вводим: 
 

C:\tidcs\C28\dsp281x\v100\DSP281x_headers\include;..\include. 
 

1.4. Задаем глубину стека: Project → Build Options → Linker → 

Stack Size: 0x400. 
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2. Инициализация системы (подпрограмма «InitSystem()»). 

2.1. Разрешаем работу сторожевого таймера (лабораторная рабо-
та № 2), устанавливаем коэффициентом деления 64 (регистр WDCR), 
сбрасываем сторожевой таймер (регистр SCSR). 

2.2. Настраиваем ЦСП на частоту 150 МГц (регистр PLLCR),  
в предделитель высокоскоростного таймера заносим 2. 

2.3. Разрешаем тактирование модуля АЦП и Менеджера Собы-
тий (регистр PCLKCR). 

3. Инициализация портов (подпрограмма «Gpio_select()»). 

3.1. Настраиваем все выводы на работу в качестве портов  
(регистр GPxMUX) (лабораторная работа № 2). 

3.2. Настраиваем порты A, D, E, F, G на ввод (регистр GPxDIR). 
3.3. Настраиваем линии порта GPIOB15 – GPIOB8 на ввод,  

а GPIOB7 – GPIOB0 на вывод. 
3.4. Сбрасываем биты регистров GPxQUAL в ноль. 
4. Инициализация модуля Менеджера Событий. 

4.1. Запрещаем выходы сравнения и выбираем полярность вы-
ходов сравнения принудительный низкий уровень (регистр 
GPTCONA) (лабораторная работа № 3). 

4.2. В регистре T1CON выбираем: непрерывный режим счета 
вверх, синхронизация от внутреннего источника, запрещаем режим 
сравнения, разрешаем работу GP таймера 1, задаем коэффициент де-
ления 128. 

4.3. Разрешаем запуск АЦП от Менеджера Событий А (регистр 
GPTCONA). 

4.4. Рассчитываем значение периода (T1PR), зная, что PWMf  =  

= 10 Гц:  

 .
1 1 HISCPTPSPRT

f
f

T

CPU
PWM 

  

5. Инициализация модуля АЦП. 

5.1. Задаем двухпоследовательный режим, запрещаем непрерыв-
ный режим, коэффициент деления 1 (регистр ADCTRL1). 

5.2. Записываем количество преобразований 2 (регистр AD-
CMAXCONV). 

5.3. Выбираем каналы ADCIN_A0 и ADCIN_B0 (регистр 
ADCCHSELSEQ1). 

5.4 Разрешаем преобразования от Менеджера Событий А, раз-
решаем прерывания АЦП в конце каждой последовательности  
(регистр ADCTRL2) 
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5.5. Задаем делитель частоты высокоскоростного таймера, рав-
ный 4. 

6. Настройка прерываний. 

6.1. Указываем адрес вектора прерываний (регистр ADCINT). 

6.2. Разрешаем прерывание 6 группы 1 (регистр PIEIER1). 

6.3. Вызываем подпрограммы инициализации: модуля прерыва-
ния периферийных устройств «InitPieCtrl()»,  вектора преры-

вания периферийных устройств «InitPieVectTable()», модуля 
АЦП «InitAdc()». 

7. Получение результатов преобразования АЦП (подпро-
грамма «adc_isr( )»). 

7.1. Считываем результаты преобразования из регистров  
ADCRESULT0 и ADCRESULT1 и сохраняем их соответственно в пе-
ременные Voltage_A0 и Voltage_B0. Так как данные в регистрах 
ADCRESULTn выровнены к левому краю, необходимо произвести 

сдвиг данных на четыре разряда вправо. 
7.2. Подготавливаем АЦП к следующему преобразованию: сбра-

сываем последовательность SEQ1 (регистр ADCTRL2), сбрасываем 

бит прерывания SEQ1 (регистр ADCST), подтверждаем прерывания 
(регистр PIEACK). 

8. Вывод показаний АЦП на светодиодные индикаторы. 

8.1. В основной подпрограмме main() написать программу вывода 
показаний данных из АЦП на линейку светодиодных индикаторов. Для 
этого необходимо использовать подпрограмму «show_ADC(result)», 

которая отображает четыре младших бита параметра result на светодиод-
ных индикаторах в виде светящейся линейки. Вывод показаний с каждо-
го канала осуществлять поочередно через 1 с. В программе также следу-
ет сбрасывать сторожевой таймер процессора.  

8.2. Компонуем проект: Project → Build.  

8.3. Загружаем выходной файл: File → Load Program → Debug\ 

lab6.out. 

8.4. Запускаем программу на выполнение Debug → Run. 

8.5. Контролируем правильное выполнение программы, изменяя 
потенциометрами напряжение, подаваемое на входы АЦП и наблюдая 
за линейкой светодиодных индикаторов. 

9. Задание для самостоятельной работы. 

Написать программу «бегущий огонь», аналогичную разрабо-
танной в лабораторной работе № 2. Скорость движения «бегущего 
огня» задавать потенциометром канала ADCIN_A0.  
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Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, рисунки, поясняющий структуру и режимы 

работы АЦП, тексты исследуемых программ,  результаты их выпол-
нения, выводы. 

 
Контрольные вопросы 

1. Встроенный АЦП DSP TMS320F2812: структура, параметры, 

режимы работы. 

2. Каскадный режим работы АЦП: особенности, источники за-
пуска преобразования. 

3. Двухканальный режим работы АЦП: особенности, источники 

запуска преобразования. 
4. Система тактирования АЦП.  

5. Регистры АЦП. 
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Лабораторная работа № 6 

Изучение отладочного модуля  
для ПЛИС Spartan-3E Starter Kit.  
Реализация логических функций 

Цель работы 

Ознакомиться со структурой отладочного модуля Spartan-3E 

Starter Kit, научиться создавать и отлаживать на его основе простей-

шие программы, реализующие функции комбинационных логических 
элементов. 

Основные теоретические сведения 

Аппаратная часть стенда состоит из отладочной платы Spartan-

3E Starter Kit, а программная – из САПР WebPACK ISE. 

Внешний вид платы изображен на рис. 6.1. Эта плата имеет мно-
го встроенных, уже готовых к использованию компонентов.  
На плате установлена ПЛИС семейства Spartan-3E xc3s500e. Широкие 
возможности платы обеспечиваются наличием большого количества 
интерфейсов ввода/вывода на плате и интегрированного USB-JTAG 

загрузчика-отладчика. Отладочная плата позволяет разрабатывать  
и отлаживать сложные проекты с наименьшей затратой времени. 

Отладочная плата Spartan-3E Starter Kit имеет следующие ком-

поненты: 

– ПЛИС XC3S500E Spartan-3E FPGA; 

– память Platform Flash PROM объемом 4 Мбит; 
– ПЛИС XC2C64A CoolRunner CPLD; 

– память DDR SDRAM объемом 64 Мбайт; 
– память NOR Flash объемом 64 Мбайт; 
– память SPI serial Flash объемом 16 Мбит; 
– двухстрочный жидкокристаллический индикатор (LCD);  

– порт PS/2; 

– порт VGA; 

– интерфейс Ethernet; 

– два порта RS-232; 

– порт USB; 

– кварцевый резонатор частотой 50 МГц; 

– память EEPROM; 

– дополнительный разъем FX2 фирмы Hirose; 
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– три дополнительных шестипиновых разъема фирмы Digilent; 

– четырехканальный ЦАП; 

– двухканальный АЦП с программируемым предусилителем; 

– вращающаяся нажимающаяся кнопка; 
– восемь светодиодов; 
– четыре кнопки; 

– четыре переключателя; 
– разъем для подключения внешнего генератора; 
– восьмипиновый сокет для дополнительного генератора. 

 

Рис. 6.1. Отладочная плата Spartan-3E Starter Kit 

Программным обеспечением для проектирования систем на базе 
ПЛИС является WebPACK ISE. В результате его запуска будет от-
крыт «Навигатор проекта» («Project Navigator») основная программа 
САПР WebPACK ISE. «Навигатор проекта» позволяет упорядочить 
файлы с исходным описанием проектируемого устройства, тестовыми 

модулями, модулями временных и топологических ограничений,  

а также предоставляет возможность простого доступа ко всем процес-
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сам, необходимым при проектировании цифрового устройства на базе 
ПЛИС с архитектурами FPGA и CPLD. На рис. 6.2 показан внешний 

вид основного окна «Навигатора проекта» и его компоненты. 

 

Рис. 6.2. Внешний вид основного окна «Навигатора проекта»:  

1 – инструментальная панель («Toolbar»); 2 – окно описания  
проекта («Source window»); 3 – окно процессов («Process window»);  

4 – рабочий стол («Workspace»); 5 – окно  
отчетов («Transcript window») 

В процессе разработки цифрового устройства на базе ПЛИС  

в общем случае можно выделить следующие этапы: 

– создание нового проекта, включающее выбор семейства и типа 
ПЛИС, а также средства синтеза; 

– подготовка описания устройства в схемотехнической, тексто-
вой или алгоритмической форме; 

– синтез устройства; 
– функциональное моделирование и тестирование; 
– размещение и трассировка проекта в кристалле; 
– временное моделирование; 
– программирование ПЛИС (загрузка проекта в кристалл). 
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Каждому из этих этапов соответствует определенный набор про-
цессов, к которым можно получить доступ из «Навигатора проектов». 

Порядок выполнения работы  

В ходе лабораторной работы необходимо разработать програм-

му на языке Verilog, загрузить ее в ПЛИС и проверить правильность 
работы. Программа должна вычислять заданное булево выражение 
для четырех переменных A, B, C, D. При проверке правильности ра-
боты следует задавать значения переменных с помощью переключа-
телей, а результат выводить на светодиод (рис. 6.3). 

 

Рис. 6.3. Переключатели и светодиоды 

1. Запуск САПР WebPACK ISE. 

Для запуска САПР WebPACK ISE требуется выбирать в главном 

меню операционной системы пункта «ПУСК» → «Программы» → 

«ISE Design Suite 14.7» → «Project Navigator». 

2. Создание нового проекта. 
Для создания нового проекта необходимо проделать ряд шагов:  
2.1. Выбрать в меню пункт «File» → «New Project...», после чего 

будет запущен мастер нового проекта «New Project Wizard» (рис. 6.4). 

2.2. Ввести или выбрать местоположение создаваемого проекта 
в поле «Project Location». 

2.3. Убедиться, что в качестве типа основного файла описания 
устройства («Top-Level Source Туре») выбран «HDL». 

Нажать кнопку «Next >» для перехода к странице выбора кри-

сталла. 



 81

 

Рис. 6.4. Мастер нового проекта «New Project Wizard» 

2.4. Заполнить свойства проектируемого устройства, как показа-
но на рис. 6.5: 

– категория устройства («Product Category»): All; 

– семейство («Family»): Spartan-3Е; 

– устройство («Device»): XC3S500E; 

– исполнение («Package»): FG320; 

– градация по быстродействию(«Speed»): -4; 

– инструмент синтеза («Synthesis Tool»): XST (VHDL/Verilog); 

– симулятор («Simulator»): ISim  (VHDL/Verilog). 

2.5. Убедиться, что установлена опция «Enable Enhanced Design 

Summary». В остальных полях необходимо оставить значения «по 
умолчанию». 

2.6. Нажать кнопку «Next >» для перехода к странице создания 
заготовки основного файла с описанием устройства. После создания 
этого файла процесс создания проекта будет закончен. 
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Рис. 6.5. Окно свойств проектируемого устройства 

3. Создание описания устройства. 
Проект может включать от одного до нескольких файлов с описа-

нием проектируемого цифрового устройства. Описания можно созда-
вать в виде электрических принципиальных схем, в виде HDL-описания 
на языке VHDL или Verilog или диаграмм состояний и переходов меж-

ду ними. Кроме того, допускаются смешанные способы описания, пред-
ставляющие собой сочетание перечисленных форм. В данном случае 
остановимся на создании HDL-описания. 

Для создания HDL-описания устройства на языке VHDL необ-

ходимо выполнить следующие шаги: 

3.1. В окне мастера нового проекта нажать кнопку «New Source» 

( ). 

3.2. Выбрать «VHDL Module» в качестве типа исходного файла 
(рис. 6.6).  

3.3. Ввести имя файла в поле «File name». 

3.4. Убедиться, что установлена опция «Add to project». 

3.5. Нажать кнопку «Next >». 

3.6. В открывшемся окне установить свойства портов ввода-
вывода проектируемого устройства, как показано на рис. 6.7. 
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3.7. Нажать кнопку «Next >». В новом окне проверить свойства 
создаваемого файла с описанием устройства, после чего нажать кноп-

ку «Finish». 

 

Рис. 6.6. Выбор типа исходного файла 

 

Рис. 6.7. Настройка портов ввода/вывода 

3.8. В следующих двух окнах нажать кнопку «Next >». Появится 
окно с резюме о новом проекте (рис. 6.8). Если все свойства соответ-
ствуют требованиям, предъявляемым к проектируемому устройству, 
нажать кнопку «Finish». 



 84

 

Рис. 6.8. Проверка свойств нового проекта 

Следующим шагом является создание архитектуры проектируе-
мого устройства.  

Создадим устройство, которое вычисляет булево выражение: 
DC)BA(  . 

Для этого необходимо выполнить следующие шаги: 

1. Поместить курсор после ключевого слова begin в разделе 
architecture. 

2. Ввести строку, которая описывает заданное булево выра-
жение на языке VHDL: 

 

process(A,B,C,D) 
begin 

Y <= (A and (not B)) or (C xor D); 
end process; 

 

Для этого воспользуемся таблицей логических операций (табл. 6.1). 

Таблица 6.1 

Таблица логических операций 

Условное обозначение Выполняемая функция Запись на языке Verilog 

YX   Логическое И X & Y 

YX  Логическое ИЛИ X || Y 

YX  Исключающее ИЛИ X ^ Y 

X  Инверсия ~X 
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3. Сохранить файл, выбрав в меню пункт «File» → «Save» 

или нажав на кнопку  на инструментальной панели. 

После выполнения всех действий окончательное описание уст-
ройства будет выглядеть, как показано ниже: 

 
library IEEE; 
use IEEE.STD_LOGIC_1164.ALL; 
use IEEE.STD_LOGIC_ARITH.ALL; 
use IEEE.STD_LOGIC_UNSIGNED.ALL; 
---- Uncomment the following library declaration if in-
stantiating 
---- any Xilinx primitives in this code. 
--library UNISIM; 
--use UNISIM.VComponents.all; 
entity lab1 is 
    Port ( A : in  STD_LOGIC; 
           B : in  STD_LOGIC; 
           C : in  STD_LOGIC; 
           D : in  STD_LOGIC; 
           Y : out  STD_LOGIC); 
end lab1; 
architecture Behavioral of lab1 is 
begin 
process(A,B,C,D) 
begin 
Y <= (A and (not B)) or (C xor D);   
end process;  
end Behavioral; 

 

После окончания редактирования HDL-описания устройства  
необходимо проверить файл на наличие синтаксических ошибок.  
Для этого необходимо сделать ряд шагов: 

1. Удостовериться, что в выпадающем меню «Sources for:» в 

окне описания проекта выбран режим «Synthesis/Implementation». 

2. Выбрать в этом же окне файл с описанием устройства,  
в окне процессов будут отображены процессы, доступные для это-
го устройства и режима 

3. Нажать символ «+» и раскрыть группу процессов 

«Synthesize-XST». 

4. Выполнить двойной щелчок мышью по пункту «Check 

Syntax». 

Сообщения обо всех найденных ошибках отображаются в разде-
ле «Console» окна отчетов. Свидетельством отсутствия ошибок будет 
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символ  перед названием выполненного процесса. Если в результа-
те работы процесса были обнаружены ошибки, то перед его именем 

появится символ  (рис. 6.9). 

 

Рис. 6.9. Окно процессов 

4.1. Назначение выводов c помощью утилиты PlanAhead 14.7.  

Далее необходимо поставить в однозначное соответствие линии 

портов проектируемого устройства выводам микросхемы ПЛИС. Для 
этого необходимо выполним следующие шаги: 

4.1.1. Выберем в главном меню операционной системы пункт 
«Пуск» → «Программы» → «PlanAhead (32 bit)». 

4.1.2. Для начала работы выберем пункт меню «Open Project»  

(рис. 6.10). 

 

Рис. 6.10. Окно редактора PlanAhead 14.7 
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4.1.3. C помощью проводника выбрать файл проекта «Lab1.xise» 

и нажать кнопку «OK».  

4.1.4. В окне «Import ISE Project As» указать имя проекта, ввести 

или выбрать местоположение создаваемого проекта в поле «Project  

Location». Убедиться, что установлена опция «Create project subdirec-

tory». Нажать клавишу «ОК» и дождаться завершения импорта проекта. 
4.1.5. В окне «Flow Navigator» из списка «Implementation»  

(рис. 6.11) выбрать пункт меню «Run Implementation» . По оконча-
нию выполнения процесса в окне «Implementation Completed» вы-

брать пункт меню «Open Implemented Design» и нажать кнопку «ОК». 

 

Рис. 6.11. Пункты меню «Implementation» 

4.1.6. Проверить наличие схемы расположения выводов ПЛИС,  

а при ее отсутствии в окне программы из пункта меню «Layout» вы-

брать «I/O Planing» (рис. 6.12). 

 

Рис. 6.12. Всплывающее меню «Layout» 

4.1.7. В окне списка объектов «I/O Ports» отрыть папку «Scalar 

Ports» (рис. 6.13), ввести местоположение линий портов в ПЛИС, как 
это показано ниже: 
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– вход A сопоставить с выводом N17; 

– вход B сопоставить с выводом H18; 

– вход C сопоставить с выводом L14; 

– вход D сопоставить с выводом L13; 

– выход Y сопоставить с выводом F12. 

Схема расположения выводов должна получиться такой, как по-
казано на рис. 6.14. 

 

Рис. 6.13. Список объектов проекта 

 

Рис. 6.14. Схема расположения выводов ПЛИС 

4.1.8. Выбрать пункт меню File → Save 

4.1.9. Закрыть PlanAhead 14.7. 
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4.2. Ручное назначение выводов. 
Для установки в однозначное соответствие линии портов проек-

тируемого устройства выводам микросхемы ПЛИС необходимо вы-
полнить следующие действия: 

4.2.1. Нажать правой кнопкой мыши по окну ресурсов проекта,  
в всплывающем меню выбрать пункт «New Source». 

4.2.2. В окне создания ресурсов проекта (рис. 6.15) выбрать 
пункт «Implementation Constrains File», указать имя и ввести/указать 
место расположения файла, нажать клавишу «ОК». 

 

Рис. 6.15. Окно создания ресурсов проекта 

4.2.3. Убедиться в наличии файла «.ucf» в окне ресурсов проекта. 
4.2.4. Двойным нажатием на «.ucf» открыть окно редактора. 
4.2.5. Описать установку в однозначное соответствие линии 

портов проектируемого устройства, как показано на рис. 6.16. 

 

Рис. 6.16. Конфигурация линии портов 
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4.2.6. Сохранить внесенные изменения нажав на кнопку сохра-
нения ( ). 

5. Размещение устройства в кристалле. 
Процесс размещения устройства на кристалле включает сле-

дующие шаги: 

5.1. Выбрать в окне описания проекта файл lab1. 

5.2. Открыть окно резюме проекта, дважды щелкнув по процес-
су «View Design Summary» в окне процессов. 

5.3. Запустить процесс реализации проекта, дважды щелкнув  
по процессу «Implement Design» в окне процессов. 

Если процесс реализации проекта прошел без ошибок и преду-
преждений, то это будет отмечено зеленым символом перед именем 

процесса (рис. 6.17). Если же произошел сбой на одном из этапов ра-
боты, то этот этап можно идентифицировать по красному (признак 
ошибки) или желтому (признак предупреждения) символу перед име-
нем процесса «Implement Design», а также перед именем сбойного 
подпроцесса. 

 

Рис. 6.17. Результат безошибочной  

реализации проекта 

6. Загрузка конфигурации в Spartan 3. 

Для загрузки конфигурации в ПЛИС необходимо проделать сле-
дующие шаги: 

6.1. Выбрать в окне описания проекта файл lab1. 
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6.2. В окне процессов дважды щелкнуть по пункту меню «Gen-

erate Programming File», чтобы выполнить группу процессов. Дож-

даться завершения процедуры, убедиться в правильности работы про-
граммы (рис. 6.18). 

 

Рис. 6.18. Результат выполнения процедуры  

«Generate Programming File» 

6.3. В окне процессов щелкнуть по символу «+», чтобы рас-
крыть группу процессов «Configure Target Device» 

6.4. Дважды щелкнуть по процессу «Configure Target Device», 

или выбрать пункт всплывающего меню «Run» (по нажатию правой 

кнопки мыши). Будет запущена программа iMPACT и откроется окно 
выбора режима конфигурирования. 

6.5. В открывшемся окне выбрать режим конфигурирования  
с использованием периферийного сканирования «Configure devices 

using Boundary-Scan (JTAG)». 

6.6. Убедиться, что в выпадающем списке выбран пункт «Auto-

matically connect to a cable and identify Boundary-Scan chain». 

6.7. Нажать кнопку «Finish». 

Если появится сообщение о том, что найдено несколько уст-
ройств, нажать «ОК» для продолжения работы. После этого будет 
сформирован канал периферийного сканирования в соответствии со 
стандартом JTAG и произойдет автоматическое определение устрой-

ства, после чего появится основное окно программы iMPACT. 

6.8. В открывшемся диалоговом окне по выбору пункта  
«File»-> «New Project» выбрать файл битовой последовательности 

lab1.bit для загрузки в устройство xc3s500e, после чего нажать кнопку 
«Ореn». 
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Если появится предупреждение (Warning), то необходимо на-
жать «ОК». 

6.9. Снова откроется окно выбора файла битовой последова-
тельности. Поскольку в цепочке JTAG в нашем случае только один 

ПЛИС, следует нажать «Bypass», чтобы пропустить загрузку  
в другие устройства. 

6.10. Правой кнопкой мыши щелкнуть по устройству xc3s500e  

и выбрать в выпадающем меню пункт «Program...». Откроется диало-
говое окно определения настроек программирования устройства 
(Programming Properties) (рис. 6.19). 

6.11. Нажать «ОК» для начала программирования. Об успешном 

окончании программирования будет свидетельствовать появившееся 
в главном окне iMPACT сообщение «Program Succeeded». 

Если появится предупреждение (Warning), то нажать «ОК».  

6.12. Закрыть программу iMPACT, не сохраняя проект. 

 

Рис. 6.19. Диалоговое окно определения настроек  
программирования устройства 

7. Проверка правильности работы устройства. 
Изменяя положения переключателей N17, H18, L14 и L13, тре-

буется провести тестирование разработанного устройства, наблюдая 
за светодиодом F12. Полученные результаты занести в табл. 6.2. 
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Таблица 6.2 

Пример таблицы истинности 

A B C D Y 

0 0 0 0 1 

0 0 0 1 0 

0 0 1 0 1 

0 0 1 1 0 

0 1 0 0 1 

0 1 0 1 0 

0 1 1 0 1 

0 1 1 1 1 

1 0 0 0 1 

1 0 0 1 0 

1 0 1 0 1 

1 0 1 1 1 

1 1 0 0 1 

1 1 0 1 0 

1 1 1 0 1 

1 1 1 1 0 

Задание для самостоятельной работы 

В ходе выполнения задания для самостоятельной работы требуется: 
1) составить таблицу истинности для булева выражения, соот-

ветствующего номеру варианта согласно табл. 6.3; 

2) разработать описание устройства, вычисляющего заданное 
булево выражение; 

3) поставить в  соответствие линии портов устройства выводам 

микросхемы; 

4) разместить  разработанное устройство в кристалле; 
5) загрузить полученную конфигурацию  в ПЛИС; 

6) проверить правильность работы программы. 

Таблица 6.3 

Исходные данные 

Номер варианта Булево выражение Номер  
варианта Булево выражение 

1 DC)BA(   16 D)CBA(   

2 DBCA   17 DCBA   
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Окончание табл. 6.3 

Номер варианта Булево выражение Номер  
варианта Булево выражение 

3 CDAB   18 CBAD   

4 DC)D(A   19 
ABCD   

5 DCBA   20 CAB)(D   

6 DCBA   21 C)(DB)(A   

7 )B(C)DA(   22 DC)BA(   

8 BACD   23 DCBA   

9 D)BC(A   24 D)(C)BA(   

10 A)(C)D(B   25 )DC()BA(   

11 CDBA   26 ADCB   

12 
ABCD   

27 )DB()CA(   

13 )BA(C)(D   28 DCBA   

14 )DC()BA(   29 B)DC(A   

15 
DCBA   

30 C)DB(A   

Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, таблицу истинности булева выражения,  
текст разработанной  конфигурации, выводы. 

Контрольные вопросы 

1. Поясните, что такое ПЛИС и FPGA. 

2. Раскройте понятие HDL. 

3. Укажите, каким образом производится описание комбинаци-

онной логики на языке описания цифровых устройств VHDL. 

4. Поясните, почему в промышленности текстовое описание 
цифровых схем вытеснило схемотехническое. 

5. Поясните, какая часть цифровой схемы описывается в блоке 
«architecture Behavioral». 

6. Укажите, какая часть цифровой схемы описывается в блоке 
«entity». 
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Лабораторная работа № 7 

Реализация типовых функций элементов 
цифровой электроники на отладочном 

модуле Spartan-3E Starter Kit 

Цель работы 

Научиться описывать последовательностные устройства различ-
ными методами на основе отладочного модуля Spartan-3E Starter Kit,  

а также создавать тестовые модули для проверки правильности рабо-
ты программ. 

Основные теоретические сведения 

Рассмотрим различные стили описания одного и того же пове-
дения на примере дешифратора, который имеет два входных полюса и 

четыре выходных (рис. 7.1).  

 

Рис. 7.1. Дешифратор 

На рис. 7.1 слева и справа указаны имена входных и выходных 
полюсов, употребляемых в VHDL-описании. Функции дешифратора 
имеют следующий вид: 

 

;x1x0y0   

;1xx0y1   

;x10xy2   

.x1x0y3   

. 
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Интерфейс дешифратора: 
 

entity Decoder is  
port (X: in Bit_vector (0 to 1); 
     Y: out Bit_vector (0 to 3)); 
end Decoder; 

 

Представим различные стили описания функционирования 
дешифратора: структурное описание, описание в виде потока данных, 
процедурное описание. Заметим, что при спецификации цифровых 
систем допустим смешанный стиль, что весьма удобно при проекти-

ровании. 

Структурное описание архитектурного тела в виде схемы в ба-
зисе инверторов (Inverter) и двухвходовых элементов И (AND_Gate) 

имеет вид: 
 

architecture structure of Decoder is 
signal S: bit_vector (0 to 1); 
component AND_Gate  
   port (A, B: in Bit; D: out Bit); 
end component; 
component Inverter 
   port (A: in Bit; B: out Bit); 
end component; 
begin  
   Inv1: Inverter port map (A=>x(0), B=>s(0)); 
   Inv2: Inverter port map (A=>x(1), B=>s(1)); 
   A1:AND_Gate port map (A=>s(0), B=>s(1), D=>y(0)); 
   A2:AND_Gate port map (A=>s(0), B=>x(l), D=>y(l)); 
   A3:AND_Gate port map (A=>x(0), B=>s(l), D=>y(2)); 
   A4:AND_Gate port map (A=>x(0), B=>x(l), D=>y(3)); 
end structure; 

 

Описание поведения дешифратора в виде потока данных (data 

flow): 
 

architecture Data_flow of Decoder is 
begin 
   y(0) <= not x(0) and not x(l); 
   y(l) <= not x(0) and x(l); 
   y(2) <= x(0) and not x(l); 
   у(3) <= х(0) and х(1); 
end Data_flow; 
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Процедурное описание дешифратора выглядит следующим об-

разом: 
 

architecture Procedural of Decoder is 
signal s: bit_vector (0 to 3); 
begin 
   process (x) 
   case x is 
      when “00”=>s<=”1000”; 
      when “01”=>s<=”0100”; 
      when “10”=>s<=”0010”; 
      when “11”=>s<=”0001”; 
   end case; 
   end process; 
y<=s; 
end Procedural; 

 

Смешанное описание, использующее элементы структурного 
описания и элементы описания «поток данных», приведено ниже: 

 

architecture Mixed of Decoder is 
component Inverter 
   port (A: in Bit; B: out Bit); 
end component; 
signal S: bit_vector (0 to 1); 
begin 
   Invl: Inverter port map (A=>x(0), B=>s(0)); 
   Inv2: Inverter port map (A=>x(l), B=>s(l)); 
   process (s, x) 
   begin 
      y(0) <= s(0) and s(l); 
      y(l) <= s(0) and x(l); 
      y(2) <= x(0) and s(l); 
      y(3) <= x(0) and x(l)); 
   end process; 
end Mixed; 

 

В данном примере структурное описание и описание типа «поток 
данных» весьма схожи, так как происходит замена логических элемен-

тов (компонентов) логическими выражениями. Однако для более слож-

ных схем такая замена может быть совершенно неочевидной. 

 



 98

Порядок выполнения работы 

В ходе лабораторной работы необходимо разработать программу 
на языке VHDL, которая описывает заданное последовательностное 
устройство; создать набор тестовых воздействий для проверки  пра-
вильности работы проектируемого устройства; получить временные 
диаграммы выходных сигналов; загрузить разработанную программу  
в ПЛИС, а также проверить правильность ее работы. При проверке 
правильности работы следует задавать значения переменных с помо-
щью переключателей, а результат выводить на светодиоды. 

1. Создание нового проекта и описания устройства. 
В качестве примера рассмотрим создание описания микросхемы 

К561ИЕ19 в виде потока данных.  
Микросхема К561ИЕ19 (рис. 7.2) – пятиразрядный синхронный 

счетчик по схеме Джонсона. От каждого триггера счетчика сделан 

инверсный выход Q0–Q4 . Счетчик имеет пять входов предваритель-
ной записи (установки) S0–S4, тактовый вход С, вход последователь-
ных данных D, а также вход сброса R. Входами S0–S4 можно вос-
пользоваться, если подать сигнал разрешения установки (высокий 

уровень) на вход SE.  

 

Рис. 7.2. Условно-графическое обозначение 
 микросхемы К561ИЕ19 

Создадим новый проект и присвоим ему имя «lab2». 

Создадим HDL-описание устройства на языке VHDL, для этого 
необходимо выполнить следующие шаги: 

1.1. Выберем «VHDL Module» в качестве типа исходного файла. 
1.2. В поле «File name» введем «lab2».  
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1.3. Установим свойства портов ввода/вывода проектируемого 
устройства, как показано на рис. 7.3. 

 

Рис. 7.3. Настройка портов ввода/вывода 

Вход D используется для преобразования рассматриваемого 
счетчика в делитель частоты на целое число, поэтому его в данной 

лабораторной работе не будем рассматривать. 
В результате получим файл описания устройства с определен-

ным разделом entity и незаполненным разделом architecture. 

1.4. Опишем дополнительный сигнал Q_temp, для этого перед 

словом begin введем следующую строку: 
 

signal Q_temp : STD_LOGIC_vector(5 downto 0); 
 

1.5. Введем процесс counter, который описывает работу микро-
схемы К561ИЕ19: 

 

counter: process(C,R,SE) 
begin  
   if (SE = '1')then 
       Q_temp(4 downto 0)<=S(4 downto 0); 
   elsif ( R = '1') then 
       Q_temp <= (others => '0');  
   elsif ( C'event and C ='1') then    
       Q_temp(4 downto 1)<=Q_temp(3 downto 0) ; 
       Q_temp(0) <= not(Q_temp(5) XOR Q_temp(4));  
   end if; 
end process counter; 
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1.6. Присвоим выходному сигналу Q значения сигнала Q_temp, 

для этого после текста процесса counter введем следующую строку:  
 

Q(4 downto 0) <= Q_temp(4 downto 0); 
 

После выполнения всех действий окончательное описание уст-
ройства будет выглядеть, как показано ниже: 

 

library IEEE; 
use IEEE.STD_LOGIC_1164.ALL; 
use IEEE.STD_LOGIC_ARITH.ALL; 
use IEEE.STD_LOGIC_UNSIGNED.ALL; 
---- Uncomment the following library declaration if in-
stantiating 
---- any Xilinx primitives in this code. 
--library UNISIM; 
--use UNISIM.VComponents.all; 
entity lab2 is 
    Port(C : in  STD_LOGIC; 
         R : in  STD_LOGIC; 
         SE : in  STD_LOGIC; 
         S : in  STD_LOGIC_VECTOR (4 downto 0); 
         Q : out  STD_LOGIC_VECTOR (4 downto 0)); 
end lab2; 
 

architecture Behavioral of lab2 is 
signal Q_temp: STD_LOGIC_vector(5 downto 0); 
begin 
  counter: process(C,R,SE) 
  begin  
  if (SE = '1')then 
  Q_temp(4 downto 0)<=S(4 downto 0); 
  elsif ( R = '1') then 
      Q_temp <= (others => '0');  
  elsif ( C'event and C ='1') then    
      Q_temp(4 downto 1) <= Q_temp(3 downto 0) ; 
      Q_temp(0) <= not(Q_temp(5) XOR Q_temp(4));  
   end if; 
end process counter; 
Q(4 downto 0) <= Q_temp(4 downto 0); 
end Behavioral; 

 

1.7. Сохраним файл. 
1.8. Проверим его на наличие синтаксических ошибок. 
2. Создание набора тестовых воздействий. 

Этап функционального моделирования (Simulate Behavioral 

VHDL Model) позволяет выполнить предварительную верификацию 
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проекта. На этой стадии отсутствует информация о значениях задер-
жек распространения сигналов, поэтому при функциональном моде-
лировании можно обнаружить только логические и синтаксические 
ошибки в описании разрабатываемого устройства. Для функциональ-
ного моделирования проекта применяется библиотека UniSim Library, 

элементы которой имеют единичные задержки. 

При функциональном моделировании создается набор тестовых 
воздействий (Test Bench), по реакции на которые оценивается пра-
вильность работы проектируемого устройства. Для создания набора 
тестовых воздействий необходимо проделать следующие шаги: 

2.1. Выбрать в окне описания проекта файл lab2. 

2.2. Для создания нового набора тестовых воздействий выбрать 
пункт меню «Project» → «New Source». 

2.3. В открывшемся окне выбрать тип исходного файла «Test 

Bench WaveForm» и ввести имя для создаваемого набора test1 в поле 
«File Name» (рис. 7.4).  

2.4. Нажать кнопку «Next >». 

2.5. В открывшемся окне привязок (Associate Source) выбрать 
файл с описанием устройства, к которому будет привязан набор тес-
товых воздействий. Поскольку в нашем проекте всего один файл, то 
он уже выбран для создания связи. 

2.6. Нажать кнопку «Next >». 

2.7. В окне резюме проверить соответствие файла с исходным 

описанием устройства и привязанного к нему набора тестовых воз-
действий, после чего нажать кнопку «Finish». 

2.8. В окне инициализации системы синхронизации (Initialize 

Timing) следует настроить временные параметры тактового сигнала. 
Зададимся следующими требованиями к разрабатываемому 

счетчику: 
– счетчик должен работать корректно при частоте входного сиг-

нала 50 МГц; 

– значения сигналов на входах сброса R и разрешения парал-
лельной загрузки SE должны быть установлены не позднее чем  

за 5 нс до установления высокого уровня на тактовом входе C;  

– значение выходных сигналов на шине Q должно быть установ-
лено не позднее чем через 5 нс после установления высокого уровня на 
тактовом входе C. 
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Рис. 7.4. Выбор типа исходного файла 

 

Рис. 7.5. Настройка системы синхронизации 

Для реализации этих требований необходимо заполнить поля 
настройки системы синхронизации следующим образом (рис. 7.5): 

– длительность высокого уровня тактового сигнала (Clock Time 

High): 10 нс; 
– длительность низкого уровня тактового сигнала (Clock Time 

Low): 10 нс; 
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– задержка до установления входного сигнала (Input Setup 

Time): 5 нс; 
– задержка до установления выходного сигнала (Output Valid 

Delay): 5 нс; 
– cдвиг (Offset): 0 нс;  
– глобальный сигнал синхронизации (Global Signal): GSR (FPGA); 

– длительность моделирования (Initial Length of Test Bench): 

1500 нс. 
Значения остальных параметров оставить без изменений. 

2.9. Нажать кнопку «Finish» для окончания процесса настройки 

системы синхронизации. 

На временной диаграмме (рис. 7.6) голубым цветом отмечены зо-
ны, равные по длительности заданному времени установления значения 
входного сигнала. Смоделируем параллельную загрузку данных: 

– для создания временных диаграмм изменения сигнала на каж-

дой из линий шины требуется щелкнуть по символу «+» перед име-
нем шины (в нашем случае S);  

– загрузим состояние «00011», для этого щелкнем мышью по 
голубой зоне в районе отметки 530 нс для установки высокого уровня 
сигнала S(3); 

– щелкнем мышью по голубой зоне в районе отметки 670 нс для 
установки низкого уровня сигнала S(3). Таким образом получим им-

пульс на линии S(3); 

– проделаем аналогичные операции для линии S(4); 

– на линии разрешения параллельной загрузки SE сформируем 

импульс в том же временном диапазоне. 
Для моделирования  работы входа сброса R сформируем им-

пульс вида 0 → 1 → 0 в районе отметки 110 нс и установим высокий 

уровень в районе отметки 1090 нс. 

 

Рис. 7.6. Временная диаграмма набора тестовых воздействий 
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Временная диаграмма (Waveform) с заданными параметрами 

входных сигналов должна выглядеть, как показано на рис. 7.6. Серая 
зона в начале диаграммы соответствует параметру «Сдвиг». 

При установке глобального сигнала синхронизации к значению, 

заданному в поле «Offset», автоматически добавляется 100 нс, что и 

отражено на диаграмме. 
2.10. Сохранить временную диаграмму. 
2.11. В выпадающем меню «Sources for:» в окне описания про-

екта выбрать режим «Behavioral Simulation» (рис. 7.7). 

 

Рис. 7.7. Выбор режима функционального моделирования 

3. Создание тестового модуля. 

Создание набора ожидаемых значений выходных сигналов за-
вершает процесс создания набора тестовых воздействий. Эта операция 
преобразует набор тестовых воздействий в полноценный тестовый мо-
дуль. Целью создания такого модуля является получение возможности 

сравнения ожидаемых значений выходных сигналов со значениями, 

полученными в результате моделирования проектируемого устройства. 
По результатам такого моделирования делается заключение о пра-
вильности функционирования реализованного алгоритма. 

Для создания тестового модуля необходимо выполнить сле-
дующие шаги: 

3.1. Убедиться, что выбран режим «Behavioral Simulation» в вы-

падающем меню «Sources for:» в окне описания проекта. 
3.2. В окне описания проекта выбрать файл с тестовым модулем 

test1. 

3.3. В окне процессов развернуть группу «Xilinx ISE Simulator» 

и выполнить двойной щелчок по процессу «Generate Expected 

Simulation Results». Запустится процесс моделирования работы про-
ектируемого устройства. 
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3.4. В ответ на запрос диалогового окна «Expected Results» отве-
тить «Yes», и будет выведена временная диаграмма с рассчитанными 

значениями выходных сигналов (рис. 7.8).  

3.5. Для шины существует возможность просмотра временных 
диаграмм изменения сигнала на каждой из линий шины. Для этого 
следует щелкнуть по символу «+» перед именем шины (в нашем слу-
чае Q). 

 

Рис. 7.8. Тестовый модуль 

3.6. Начиная с версии ISE 11.1, Xilinx больше не поддерживает 
Test Bench Waveform Editor. Когда проект, в котором есть test bench 

waveform (TBW), обновляется до версии 11.1, то TBW будет автома-
тически преобразован в HDL test bench и добавлен в проект. Xilinx 

рекомендует для новых проектов использовать тесты (HDL test 

benches), написанные на основе HDL. 

Представим пример такого HDL описания тестового воздействия: 
 

---------------------------------------------------------------------------
----- 
-- Company:  
-- Engineer: 
-- 
-- Create Date:   23:03:47 09/25/2018 
-- Design Name:    
-- Module Name:   E:/DSPUSER/fpga /xilinx_project/LAB_2_GSTU/Test.vhd 
-- Project Name:  LAB_2_GSTU 
-- Target Device:   
-- Tool versions:   
-- Description:    
--  
-- VHDL Test Bench Created by ISE for module: lab2 
--  
-- Dependencies: 
--  
-- Revision: 
-- Revision 0.01 - File Created 
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-- Additional Comments: 
-- 
-- Notes:  
-- This testbench has been automatically generated using types std_logic 
and 
-- std_logic_vector for the ports of the unit under test.  Xilinx recom-
mends 
-- that these types always be used for the top-level I/O of a design in or-
der 
-- to guarantee that the testbench will bind correctly to the post-
implementation  
-- simulation model. 
---------------------------------------------------------------------------
----- 
LIBRARY ieee; 
USE ieee.std_logic_1164.ALL; 
  
-- Uncomment the following library declaration if using 
-- arithmetic functions with Signed or Unsigned values 
--USE ieee.numeric_std.ALL; 
  
ENTITY Test IS 
END Test; 
  
ARCHITECTURE behavior OF Test IS  
  
    -- Component Declaration for the Unit Under Test (UUT) 
  
    COMPONENT lab2 
    PORT( 
         C : IN  std_logic; 
         R : IN  std_logic; 
         SE : IN  std_logic; 
         S : IN  std_logic_vector(4 downto 0); 
         Q : OUT  std_logic_vector(4 downto 0) 
        ); 
    END COMPONENT; 
     
 
   --Inputs 
   signal C : std_logic := '0'; 
   signal R : std_logic := '0'; 
   signal SE : std_logic := '0'; 
   signal S : std_logic_vector(4 downto 0) := "00101"; --(others => '0'); 
 
  --Outputs 
   signal Q : std_logic_vector(4 downto 0) ; 
   -- No clocks detected in port list. Replace <clock> below with  
   -- appropriate port name  
  
--   constant <clock>_period : time := 10 ns; 
  
BEGIN 
  
 -- Instantiate the Unit Under Test (UUT) 
   uut: lab2 PORT MAP ( 
          C => C, 
          R => R, 
          SE => SE, 
          S => S, 
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          Q => Q 
        ); 
 
   -- Clock process definitions 
--   <clock>_process :process 
--   begin 
--  <clock> <= '0'; 
--  wait for <clock>_period/2; 
--  <clock> <= '1'; 
--  wait for <clock>_period/2; 
--   end process; 
 
   -- Stimulus process 
   stim_proc: process 
   begin   
       wait for 100 ns;  
   C <= not C; 
   end process; 
 
   stim_proc_SE: process 
   begin   
       wait for 150 ns;  
   SE <= '1'; 
   wait for 40 ns;  
   SE <= '0'; 
 wait; 
 end process; 
  
   stim_proc_R: process 
   begin   
       wait for 0 ns;  
   R <= '1'; 
   wait for 10 ns;  
   R <= '0'; 
 wait; 
 end process;  
  
END; 

 
На рис. 7.9 показан способ перехода в режим симуляции. Для соз-

дания файла тестовых воздействий Test1.vhd необходимо правой кноп-
кой мыши вызвыть выпадающее меню, выбрать «New sourse…» -> 
«VHDL test bench». Указать в качестве названия файла Test1.vhd и вве-
сти в него вышеприведенное описание тестовых воздействий. 

 

Рис. 7.9. Режим симуляции 
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4. Функциональное моделирование. 
Получить информацию о работе устройства можно при помощи 

функционального моделирования. Этот процесс похож на процесс 
создания тестового модуля, но с той лишь разницей, что значения вы-

ходных сигналов не задаются, а только рассчитываются. Процесс 
функционального моделирования включает следующие шаги: 

4.1. Убедиться, что выбран режим «Simulation» в выпадающем 

меню «Sources for:» в окне описания проекта и указан файл с тесто-
вым модулем test1. 

4.2. В окне процессов развернуть группу «Xilinx ISE Simulator» 

и выполнить двойной щелчок по процессу «Simulate Behavioral 

Model». 

Результаты моделирования выводятся в окне «Simulation» и дос-
тупны только для просмотра или печати (рис. 7.10). 

 

Рис. 7.10. Результаты функционального моделирования 

5. Проверка правильности работы устройства. 
Для проверки правильности работы устройства внесем некото-

рые изменения в текст программы: 

5.1. Из-за нехватки переключателей при разрешении параллель-
ной загрузки данных всегда будем загружать «11000», для этого уда-
лим строку, описывающую вектор входных переменных S: 

 

entity lab2 is 
    Port ( C : in  STD_LOGIC; 
        R : in  STD_LOGIC; 
        SE : in  STD_LOGIC; 
        Q : out  STD_LOGIC_VECTOR (4 downto 0)); 
end lab2; 
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и добавим сигнал S:   
 

signal S     : STD_LOGIC_vector(4 downto 
0):=B''11000''; 

 

5.3. Для того чтобы можно было видеть изменения выходного 
сигнала, выводимого на светодиоды, добавим процесс CLK, с помо-
щью которого происходит деление частоты C, равной 50 МГц,  

на 25000000 с целью получения частоты C_new, равной 2 Гц: 
 

CLK: process(c) 
  begin 
    if c'event and c='1' then- 
      --divide 50MHz by 25000000 to form 2Hz pulses 
       if int_count=25000000 then 
         int_count <= 0; 
         C_new <= '1'; 
       else 
         int_count <= int_count + 1; 
         C_new <= '0'; 
      end if; 
 end if;  
end process CLK;  
 

Затем введем два дополнительных сигнала int_count и C_new: 
 

signal int_count  : integer range 0 to 25000000 :=0; 
signal C_new      : std_logic; 

   

Кроме того, в процессе counter изменим название сигнала С  

на C_new.  

После выполнения всех действий окончательное описание уст-
ройства будет выглядеть, как показано ниже: 

 

library IEEE; 
use IEEE.STD_LOGIC_1164.ALL; 
use IEEE.STD_LOGIC_ARITH.ALL; 
use IEEE.STD_LOGIC_UNSIGNED.ALL; 
---- Uncomment the following library declaration if in-
stantiating 
---- any Xilinx primitives in this code. 
--library UNISIM; 
--use UNISIM.VComponents.all; 
entity lab2 is 
    Port ( C : in  STD_LOGIC; 
           R : in  STD_LOGIC; 
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           SE : in  STD_LOGIC; 
           Q : out  STD_LOGIC_VECTOR (4 downto 0)); 
end lab2;  
architecture Behavioral of lab2 is 
signal Q_temp     : STD_LOGIC_vector(5 downto 0); 
signal S:STD_LOGIC_vector(4 downto 0) :=B ''11000''; 
signal int_count  : integer range 0 to 25000000 :=0; 
signal C_new      : std_logic; 
begin 
CLK: process(c) 
  begin 
    if c'event and c='1' then- 
   --divide 50MHz by 25000000 to form 2Hz pulses 
       if int_count=25000000 then 
         int_count <= 0; 
         C_new <= '1'; 
       else 
         int_count <= int_count + 1; 
         C_new <= '0'; 
      end if; 
 end if;  
end process CLK;  
counter: process(C_new,R,SE) 
begin  
if (SE = '1')then 
 Q_temp(4 downto 0)<=S(4 downto 0); 
elsif ( R = '1') then 
      Q_temp <= (others => '0');  
   elsif ( C_new'event and C_new ='1') then    
         Q_temp(4 downto 1) <= Q_temp(3 downto 0) ; 
         Q_temp(0) <= not(Q_temp(5) XOR Q_temp(4));  
   end if; 
end process counter; 
Q(4 downto 0) <= Q_temp(4 downto 0); 
end Behavioral; 

 

6. Назначение выводов и загрузка конфигурации в Spartan 3. 

Далее необходимо поставить в однозначное соответствие линии 

портов проектируемого устройства выводам микросхемы ПЛИС.  

6.1. В редакторе PACE в окне списка объектов проекта («Design 

Object List») ввести в поле «Loc» местоположение линий портов  
в ПЛИС, как это показано ниже: 

– вход С сопоставить с выводом С9; 

– выход Q<0> сопоставить с выводом F12; 
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– выход Q<1> сопоставить с выводом E12; 

– выход Q<2> сопоставить с выводом E11; 

– выход Q<3> сопоставить с выводом F11; 

– выход Q<4> сопоставить с выводом C11; 

– вход R сопоставить с выводом № 17; 

– вход SE сопоставить с выводом № 18. 

6.2. Запустить процесс реализации проекта. 
6.3. Удостовериться, что все выводы микросхемы правильно по-

ставлены в соответствие портам проектируемого устройства. 
6.4. Запустить программу iMPACT. 

6.5. Загрузить в устройство xc3s500e файл битовой последо-
вательности lab2.bit. 

Результатом правильной работы устройства будет:  
а) при установленных в «0» переключателях № 17 и № 18: по-

следовательное включение и выключение светодиодов, соответст-
вующее временным диаграммам, приведенным на рис. 7.9; 

б) при установленном в «1» переключателе № 17: все светодио-
ды погашены;  

в) при установленном в «1» переключателе № 18: установка све-
тодиодов в положение «11000». 

Задание для самостоятельной работы 

В ходе выполнения задания для самостоятельной работы требу-
ется: 

1) разработать описание устройства, соответствующего номеру 
варианта, и поставить в соответствие линии портов устройства выво-
дам микросхемы в соответствии с табл. 7.1;  

2) создать набор тестовых воздействий; 

3) создать тестовый модуль; 
4) провести функциональное моделирование; 
5) разместить разработанное устройство в кристалле; 
6) загрузить полученную конфигурацию  в ПЛИС; 

7) проверить правильность работы программы. 
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Таблица 7.1 

Варианты заданий для самостоятельной работы 

№ УГО микросхемы Примечания 

1 

 

К155ТМ8 – четыре D-триггера, имеющие 
общие входы синхронного сброса /R и так-
тового запуска С, а также имеются выходы 

Q и /Q. Информацию от параллельных вхо-

дов данных D1–D4 можно загрузить, если 

на вход /R подать напряжение высокого 
уровня. 

2 

 

К555ИР8 – 8-разрядный сдвиговый регистр с 
последовательным входом и параллельными 

выходами. Регистр имеет асинхронный сброс 
(вход /R) и два входа для последовательных 
данных DSa и DSb (логика И). Поданные че-
рез эти входы данные сдвигаются на одну по-
зицию вправо согласно каждому положи-

тельному перепаду импульса, пришедшего на 
тактовый вход С  

3 

 

К155ИЕ4 – 4-разрядный двоичный счетчик-
делитель на 2, на 6 и на 12. Чтобы постро-

ить счетчик с модулем деления 12, требует-
ся соединить делители на 2 и на 6, замкнув 
выводы 12 и 1. На вход /C0 дается входная 
частота f, на выходе Q3 получается после-
довательность прямоугольных импульсов 
с частотой f/12. Тактовые запускающие пе-
репады – отрицательные 

4 

 

К155ТМ2 – два независимых D триггера. 
У каждого триггера есть входы D, /S и /R, 

а также комплементарные выходы Q и /Q. 

Входы /S и /R – асинхронные. Сигнал 
от входа D передается на выходы Q и /Q 

по положительному перепаду импульса 
на тактовом входе С 
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Продолжение табл. 7.1 

№ УГО микросхемы Примечания 

5 

 

К561ИР2 – два независимых 4-разрядных 
регистра сдвига. Данные в регистр вводятся 
через последовательный вход D. Регистр 
имеет вход тактовых импульсов С, причем 

данные принимаются от входа D первого 
триггера и сдвигаются на один такт вправо 

после каждого положительного тактового 
перепада на входе С. Сброс в нуль данных 
на выходе Q регистра получится, если на 
вход асинхронного сброса R подать напря-
жение высокого логического уровня  

6 

 

К531ИЕ14 – асинхронный счетчик пульса-
ций. Состояния счетчика меняются по отри-

цательному перепаду тактового импульса. 
Двоично-десятичную выходную последова-
тельность можно получить, если тактовые 
импульсы подать на вход /C0 и соединить 
выводы 5 и 6. Сигналом R='0' запрещается 
работа всем входам счетчика, а на всех вы-

ходах появляется напяжение низкого уров-
ня. Когда на вход разрешения  параллельной 

загрузки /PE подано напряжение низкого 
уровня, действие тактовых входов запреща-
ется. Данные, присутствующие на входах 
D0–D3, загружаются параллельно в тригге-
ры счетчика 

7 

 

К531ТВ11 – два JK-триггера. Оба триггера 
микросхемы имеют по две общие цепи 

управления: тактовый вход /C и вход сброса 
/R. Входы J и K могут работать, если на 
асинхронных входах /S и /R присутствуют 
напряжения высокого уровня   
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Окончание табл. 7.1 

№ УГО микросхемы Примечания 

8 

 

К555ИР16 – 4-разрядный сдвиговый регистр. 
Если на входе /PE присутствует напряжение 
высокого уровня, данные загружаются в ре-
гистр от параллельных входов D0–D3 син-

хронно с отрицательным перепадом на такто-
вом входе /C. Напряжение низкого уровня на 
входе /PE вызывает загрузку данных от по-
следовательного входа SI. Цифровое слово 
сдвигается вправо от Q0 к Q1 далее к Q2 и Q3 

синхронно с каждым отрицательным перепа-
дом на тактовом входе /C 

9 

 

К155ИЕ5 – 4-разрядный асинхронный счет-
чик пульсаций. Счетчик имеет две части: 

делитель на 2 (выход Q0; тактовый вход /C0) 

и делитель на восемь (выходы Q1–Q3; такто-
вый вход /C1). Входы синхронного сброса R1 

и R2 (логика И) запрещают действие импуль-
сов по обоим тактовым входам. Импульс, 
поданный на вход R, дает сброс данных 
по всем триггерам одновременно 

Содержание отчета 

Отчет должен содержать цель работы, краткие теоретические 
сведения по теме работы, условное графическое изображение иссле-
дуемой микросхемы и краткое описание ее работы,  текст разработан-

ной  программы, изображение тестового модуля, результат функцио-
нального моделирования, выводы. 

Контрольные вопросы 

1. Дайте определение понятию «последовательностная схема». 

2. Укажите, каким образом можно описать шифратор при помо-
щи оператора case. 

3. Поясните, что значит запись «Q_temp(4 downto 1) <= 
Q_temp(3 downto 0)». 

4. Укажите, каким образом можно понизить частоту встроенно-
го генера-тора с 50 МГц до 5 Гц. 

5. Поясните, каким образом описывается регистр на языке VHDL. 
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