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Лабораторная работа № 1 

ИНТЕГРИРОВАННАЯ СРЕДА РАЗРАБОТКИ  

ДЛЯ PIC-МИКРОКОНТРОЛЛЕРОВ  

1 Цель работы 

Изучить и практически исследовать методы разработки и отлад-
ки программ на языке Си для PIC-микроконтроллеров с помощью ин-
тегрированной среды. 

2 Основные теоретические сведения 

Для создания программного обеспечения микроконтроллерных 
систем широко используются средства вычислительной техники, в том 
числе персональные компьютеры, позволяющие разработчику выпол-
нить весь цикл проектирования, включая отладку целевой программы. 
В настоящее время самым мощным средством разработки программ-
ного обеспечения для микроконтроллеров являются интегрированные 
среды разработки IDE (Integrated Development Environment).  

Одним из таких программных инструментов является MPLAB 
IDE – интегрированная среда разработки для микроконтроллеров 
PICmicro компании Microchip. MPLAB IDE содержит все инструмен-
тальные средства, необходимые для того, чтобы написать программу 
на языке Ассемблер, получить ее машинные коды, выполнить на си-
муляторе ее тестирование и загрузить машинные коды в программа-
тор. IDE имеет встроенные и сменные модули, позволяющие сконфи-
гурировать среду с различными инструментальными средствами, 
программным обеспечением и аппаратными средствами. Для созда-
ния программ на языке Си в MPLAB IDE могут быть добавлены ком-
пиляторы C18 и С30 разработки компании Microchip. Могут также 
использоваться компиляторы фирм HI-TECH, IAR, CSS, Byte Craft. 
Пакет программ MPLAB IDE можно бесплатно загрузить с сайта 
www.microchip.com. С сайта www.microchip.ru можно также бесплат-
но загрузить демо-версии некоторых компиляторов. 

Сербская компания MikroElektronika разработала IDE, которая 
позволяет быстро создавать эффективные программы на языке Си. 
Среда имеет удобный интерфейс пользователя со встроенным редак-
тором текста и мощным отладчиком программ. Встроенный мастер 
проектов позволяет в считанные минуты создать заготовку рабочей 
программы для любого микроконтроллера из целого семейства. Биб-
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лиотека готовых функций обеспечивает программиста поддержкой 
для быстрого и безошибочного создания программы. Компания  Mik-
roElektronika создала среду разработки для таких популярных и из-
вестных микроконтроллеров, как семейство PIC компании Microchip, 
AVR компании Atmel и семейство MCS-51. С сайта www.mikroe.com 
компании MikroElektronika можно бесплатно скачать демонстрацион-
ную версию среды для PIC-контроллеров, которая позволяет созда-
вать программы с объемом исполняемого кода до 2 Кбайт.  

Разработка программного обеспечения при использовании сре-
ды разработки IDE состоит из следующих основных этапов: 

1 Создание проекта. 
2 Создание исходных файлов на языке Си. 
3 Построение проекта. 
4 Тестирование программы и ее отладка. 
Среда IDE организует программное обеспечение в виде проек-

тов, состоящих из одного файла проекта (файл с расширением  
*.mcppi) и одного или нескольких исходных файлов на языке Си 
(файлов с расширением *.c). Исходные файлы могут компилироваться 
только в том случае, если они включены в проект. 

Файл проекта содержит: 
– имя проекта; 
– тип микроконтроллера; 
– тактовую частоту его работы; 
– слово конфигурации микроконтроллера; 
– список исходных файлов для проекта; 
– другие (вспомогательные) файлы. 

3 Порядок выполнения работы 

3.1 Создание папки для работы в среде IDE 

3.1.1 Для выполнения лабораторных работ по дисциплине «Мик-
ропроцессоры в системах управления» Вам необходимо создать на ком-
пьютере свою рабочую папку. Сделать это можно следующим образом. 

На панели TotCom выберите диск F. Затем выберите папку 
MPinCS (сокращение от Microprocessors in Control Systems) и рас-
кройте ее. Внутри нее создайте новую папку (с помощью клавиши F7) 
с именем, соответствующим Вашей фамилии (буквы обязательно ла-
тинские), например: Ivanov. 

Примечание. При использовании в именах папок русских букв возможна 
неправильная работа исследуемых программ.   
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В дальнейшем Вы будете записывать и хранить в Вашей папке 
все файлы в процессе выполнения лабораторных работ. Полный путь 
к ней: 

F:\MPinCS\Ivanov 

3.1.2 При выполнении лабораторных работ Вы будете создавать 
много различных файлов. Чтобы было легче ориентироваться в них, 
желательно для каждой лабораторной работы иметь свою отдельную 
папку. Допустим, что для выполнения лабораторной работы № 1 мы 
будем использовать папку с именем Lab1, которую необходимо пред-
варительно создать. 

С этой целью откройте Вашу рабочую папку (с именем, соответ-
ствующим Вашей фамилии) и создайте в ней (с помощью клавиши F7) 
новую папку с именем Lab1. 

В дальнейшем Вы будете записывать и хранить в этой папке все 
файлы в процессе выполнения лабораторной работы № 1. Полный 
путь к ней: 

F:\MPinCS\Ivanov\Lab1 

3.2 Запуск среды разработки 

Интегрированная среда разработки IDE запускается из стартово-
го меню Windows подобно остальным приложениям, либо, что удоб-
нее, с помощью ярлычка на рабочем столе компьютера. 

После запуска программы на экране компьютера Вы увидите 
рабочий стол среды IDE. В верхней части экрана находится строка за-
головка, в которой выводится имя проекта. Под ней расположена 
строка главного меню. Главное меню содержит обширный набор ко-
манд для доступа к функциям среды. 

Если по умолчанию установлена опция  Show Page On Startup, 
которая открывает Start Page (стартовую страницу), то на рабочем 
столе среды разработки будут открыты следующие окна. 

В центре экрана располагается окно Get Started с различными сер-
висными функциями для помощи начинающим пользователям. В левой 
части экрана расположены команды для создания нового проекта (New 

Project…), открытия существующего проекта (Open Project…) и от-
крытия папки примеров (Open Examples Folder…). В нижней части эк-
рана находится окно сообщений. Стартовую страницу можно открыть 
также с помощью команды меню View > Start Page.  
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Рассмотрим методику разработки программного обеспечения  
в интегрированной cреде на примерах простейших программ для мик-
роконтроллера PIC16F84A. 

3.3 Первая программа вывода данных в порт МК 

3.3.1 Создание нового проекта. Процесс создания нового проек-
та в среде IDE очень прост. Подведите курсор мыши к строке коман-
ды для создания нового проекта New Project … и щелкните левой 
кнопкой. 

На экране появится окно мастера создания нового проекта – 
New Project Wizard. Начальное окно содержит список действий, кото-
рые должны быть выполнены для создания нового проекта. Этот про-
цесс разбит на несколько шагов (Steps), которые Вы должны последо-
вательно проделать. 

Для продолжения щелкните по кнопке [Next]. 

Шаг 1 Установка настроек проекта 

На этом шаге необходимо определить общую информацию для 
проекта: выбрать микроконтроллер, его тактовую частоту и, конечно, 
дать проекту название. Это очень важный этап, так как компилятор 
создает внутренние настройки на основе этой информации. По умол-
чанию мастер проекта предлагает определенные настройки, но в на-
шем случае их требуется изменить. С этой целью проделайте сле-
дующее. 

1 Очистите строку Project Name и введите новое имя проекта. 
При выборе имени проекта желательно, чтобы оно имело какую-то 
смысловую нагрузку. В нашей первой программе будет выполняться 
вывод данных в порт МК, поэтому можно дать имя этому проекту как 
out (вывод). Напоминаем, что среда использует только латинские бук-
вы. Использование кириллицы недопустимо! 

Итак, введите имя проекта – out (расширение  .mcppi  набирать 
не нужно!). В строке Project Name должно быть: 

Project Name:   out 

2 Для выбора папки хранения проекта щелкните по кнопке 
[Browse] – обзор. Откроется окно обзора папок. Последовательно вы-
берите и раскройте нужные папки в соответствие с установленном  
в п. 3.1.2 пути f:\MPinCS\Ivanov\Lab1. Последней должна быть папка 
с именем Lab1. Щелкните по ее имени для раскрытия. В заключение 
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щелкните по кнопке [OK] для подтверждения своего выбора и уста-
новке нового пути. В строке Project Folder должно появиться имя пап-
ки Lab1 и полный путь к ней: 

Project Folder:  f:\MPinCS\Ivanov\Lab1\ 

3 Введите новое имя для микроконтроллера – PIC16F84A.  
С этой целью щелкните по стрелке в правой части строки Device 
Name. В раскрывшемся списке PIC-микроконтроллеров выберите 
PIC16F84A и щелкните по этой строке. В строке Device Name должно 
появиться: 

Device Name:  PIC16F84A 

4 И, наконец, необходимо установить в строке Device Clock так-
товую частоту работы микроконтроллера. По умолчанию она равна 8 
МГц. Для нашего первого проекта можно оставить это значение. 

5 В заключение шага 1 щелкните по кнопке [Next] для продол-
жения. 

Шаг 2 Добавление файлов 
Этот шаг позволяет Вам включить дополнительные файлы, ко-

торые будут необходимы для Вашего проекта, например, некоторые 
заголовочные файлы. В нашем случае нет необходимости подключать 
какие-либо дополнительные файлы. Поэтому просто щелкните по 
кнопке [Next] для продолжения. 

Шаг 3 Подключение библиотек 
Этот шаг позволяет Вам определить, желаете ли Вы включить 

все библиотеки в Ваш проект или нет. Следует знать, что, даже если 
все библиотеки включены, они не требуют какой-либо дополнитель-
ной памяти, если они не используются в Вашей программе. Главное 
достоинство опции подключения всех библиотек в том, что Вы полу-
чаете возможность использования в Вашей программе свыше 1000 го-
товых функций. Поэтому следует оставить эту конфигурацию по 
умолчанию. Однако убедитесь, что флажок на кнопке [Include All (De-
fault)] установлен. 

Щелкните по кнопке [Next] для продолжения. 

Шаг 4 Окончание построения проекта 

После того как все необходимые настройки для проекта выпол-
нены, заключительный шаг позволяет Вам сделать еще кое-что. 
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Имеется возможность разрешить автоматическое открытие окна 
редактирования проекта после завершения работы мастера проекта.  
С помощью этого окна можно изменять биты конфигурации микро-
контроллера. Это окно также может быть открыто в любой момент 
разработки программы с помощью команды меню Edit > Project.  

Следует отметить, что в результате предыдущих шагов масте-
ром проекта были установлены для микроконтроллера PIC16F84A 
следующие биты конфигурации: 

– HS – высокочастотный генератор (тактовая частота от 4 до  
20 МГц); 

– WDT off – сторожевой таймер WDT отключен; 
– Code Protection off – отключена защита кода от чтения, т. е. 

можно читать и записывать код в микроконтроллер. 
Для выполнения лабораторных работ можно оставить эту кон-

фигурацию МК по умолчанию. Поэтому для окончания построения 
проекта просто щелкните по кнопке [Finish]. 

Результатом работы мастера проектов будет новый проект 
out.mcppi, имя которого вместе с указанием полного пути к нему поя-
вится в строке заголовка в верхней части рабочего стола среды.  

В центре рабочего стола откроется окно редактора кода с пус-
тым исходным файлом для текста программы на языке Си: 

void  main( ) { 

 
} 

 
Исходный файл по умолчанию имеет то же имя, что и проект,  

т. е. out.c. Следует отметить, что среда не требует, чтобы исходный 
файл имел такое же название, как проект, поэтому его можно пере-
именовать. 

3.3.2 Создание исходного файла. Наберите в окне редактора кода 
текст программы вывода данных в порт В микроконтроллера. Текст 
комментария для экономии времени можно не набирать. 

Примечание. При наборе текста программы обязательно делайте отступы 
(3–4 пробела), как это выполнено в примере. Отступы облегчают чтение про-
граммы. 

 
/********************************************************** 
out.c – программа вывода данных в порт B  
**********************************************************/ 
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void  main( ) 
{ 
     TRISB = 0;                   // настроить все линии порта В на вывод    
     PORTB = 0x00;           // вывод данных (все нули) в порт В 
     PORTB = 0xFF;           // вывод данных (все единицы) в порт В         
} 
 

После набора сохраните файл out.c, выполнив команду меню 
File > Save. 

3.3.4 Построение проекта. Построение проекта в mikroC PRO – 
это процесс компиляции исходных файлов, их компоновки и создание 
hex-файла, предназначенного для загрузки в программную память 
микроконтроллера. Для построения проекта надо выполнить команду 
меню Build > Build. После процесса компиляции и компоновки в окне 
Messages (в нижней части экрана) выдается сообщение об итогах по-
строения. Сообщение содержит информацию о количестве затрачен-
ных ресурсов памяти, наличии ошибок (Errors) и предупреждений 
(Warnings). 

Возникающие ошибки (обычно синтаксические) не позволяют 
компилятору сгенерировать машинные коды программы на основе 
исходного текста, поэтому такие ошибки обязательно должны быть 
исправлены. При наличии ошибок выводится сообщение “Finished 
(with errors)”. 

Предупреждения выдаются компилятором в том случае, когда 
он может сгенерировать машинные коды, но в процессе их формиро-
вания возникли обстоятельства, требующие внимания разработчика. 
К таким обстоятельствам относятся, например, использование пере-
менной, которой не присвоено начальное значение, потеря точности 
при преобразовании типов переменных и т. п. Как правило, преду-
преждения выдаются в потенциально опасных ситуациях и позволяют 
избежать трудно выявляемых логических ошибок в процессе работы 
программы, вследствие этого игнорировать их не следует. 

Если в результате построения проекта возникли сообщения об 
ошибках или предупреждения, то их перечень с указанием номера 
строки и типа ошибки отобразится (красным цветом) в окне Messages. 
Место ошибки в исходном тексте можно легко найти, дважды щелк-
нув мышью на строке соответствующего сообщения. 

Если ошибок нет, то в окне Messages появится сообщение (голу-
бого цвета) с текстом “Finished successfully”. 
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После успешной компиляции среда генерирует выходные фай-
лы, которые помещаются в папку с файлом проекта: 

– ассемблерный файл (с расширением *.asm). Содержит коман-
ды Ассемблера, сгенерированные компилятором; 

– файл листинга (с расширением *.lst). Это общая картина рас-
пределения памяти микроконтроллера: адреса команд, регистры, про-
граммы и метки; 

– HEX-файл (с расширением *.hex). Это основной выходной 
файл, который используется для загрузки кодов программы в память 
микроконтроллера. 

Выходные файлы по умолчанию имеют то же имя, что и файл 
проекта. Ассемблерный файл и листинг могут быть просмотрены  
с использованием команд меню View. 

Задание. Выполните построение проекта out.mcppi с помощью 
команды меню Build > Build. В случае успешной компиляции выве-
дите на экран ассемблерный файл  out.asm, используя команду меню 
View > Assembly. В этом файле в правой части находятся строки ис-
ходной программы на языке Си. В средней части размещены команды 
Ассемблера, сформированные компилятором. Обратите внимание, 
что при окончании функции main( ) – (правая фигурная скобка }) 
компилятор сгенерировал команду GOTO $. Эта команда формирует 
бесконечный цикл повторения самой себя, выход из которого возмо-
жен только путем сброса микроконтроллера. Таким образом, после 
окончания главной функции main( ) дальнейшее выполнение про-
граммы микроконтроллером фактически прекращается (программа 
зацикливается). 

Для закрытия окна ассемблерного файла надо щелкнуть мышью 
по значку “x“ в правой части строки out.asm. 

3.3.5 Тестирование программы с помощью симулятора-отлад-

чика. Среда IDE имеет средства отладки, позволяющие проверить ра-
ботоспособность программы и исправить при необходимости ошибки 
в исходном тексте. Отладку можно выполнять как с помощью внут-
реннего симулятора работы микроконтроллера, так и с помощью ап-
паратного отладчика, подключив к нему целевую микроконтроллер-
ную систему. По умолчанию отладчик IDE настроен для работы  
в режиме симулятора. 

Для запуска отладчика надо выполнить команду из меню  
Run > Start Debugger. В результате IDE перейдет в режим отладки  
(в нем текущая строка исходного кода обозначается зеленой стрелкой 



11 

и по умолчанию выделена синим цветом), и откроется окно наблюде-
ния Watch Values, позволяющее отслеживать в ходе выполнения про-
граммы содержимое различных переменных и регистров. Значения 
обновляются в процессе симуляции работы программы в отладчике. 
Последние измененные элементы в окне наблюдения выделяются 
красным цветом.  

Примечание. Если после запуска отладчика на экране будет отсутствовать 
окно наблюдения Watch Values, то его можно открыть с помощью команды ме-
ню View > Debug Window > Watch Window или нажатием комбинации клавиш  
shift + F5. Формат отображения данных в окне наблюдения будет по умолчанию 
десятичный. 

Для внесения в список окна наблюдения Watch Values той или 
иной переменной программы, значение которой необходимо отсле-
живать, ее следует выбрать в раскрывающемся списке строки Select 
variable from list и нажать кнопку [Add].  

После того как переменная добавлена в список окна Watch Val-
ues, можно настроить параметры отображения ее в столбце Value. Для 
этого можно воспользоваться одним из способов: 

– дважды щелкнуть мышью на соответствующей строке списка 
Watch Values в столбце Name или Address; 

– щелкнуть в столбце Value и затем нажать расположенную 
справа кнопку […]. 

В любом случае на экране появится диалоговое окно Edit Value, 
позволяющее отредактировать значение переменной прямо в ходе 
выполнения программы или же изменить формат ее отображения. 

Для выбора формата отображения необходимо установить фла-
жок в соответствующем окошке: 

– Dec – десятичный; 
– Hex – шестнадцатеричный; 
– Bin – двоичный; 
– Float – с плавающей точкой; 
– Char – символьный. 
– Установка флажка Signed означает активизацию отображения 

знака. 
Для того чтобы подтвердить изменения, внесенные в значение 

или формат отображения переменной, в диалоговом окне Edit Value 
следует нажать кнопку [OK]. Нажатие кнопки [Cancel] отменяет все 
внесенные изменения. 
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Для удаления текущего элемента в списке Watch Values служит 
кнопка [Remove], а для полной очистки этого списка – кнопка [Re-
move All]. 

В режиме отладки открывается также окно хронометража Watch 
Clock. В нем отображается текущий счетчик Current Count командных 
(машинных) циклов и времени в микросекундах (us) от момента за-
пуска отладчика. Секундомер (Stopwatch) измеряет время исполнения 
в количестве командных циклов и микросекундах от момента запуска 
отладчика и может быть обнулен в любой момент времени. Разность 
(Delta) представляет фактическое время выполнения участка про-
граммы от предыдущей точки останова до текущей, отображаемое  
в количестве командных циклов и микросекундах (при пошаговом 
исполнении отображается время выполнения одной строки кода про-
граммы на языке Си). 

Также в окне Watch Clock отображается текущая тактовая час-
тота микроконтроллера (Clock). Тактовую частоту в окне хрономет-
ража можно изменять, что приведет к пересчету времени в микросе-
кундах. Однако это изменение не влияет на текущие установки 
проекта, где также задана тактовая частота микроконтроллера, а влия-
ет только на расчет времени симуляции. 

Управлять процессом отладки можно тремя способами: 
1) с помощью пунктов меню Run; 
2) при помощи «горячих клавиш» клавиатуры; 
3) с использованием кнопок (значков) в окне Watch Values. 
Практика показывает, что наиболее удобно для отладки исполь-

зовать именно кнопки окна Watch Values.  
Примечание. Чтобы узнать функцию кнопки (значка), надо поместить кур-

сор мыши на эту кнопку. На экране появится описание этой функции. 

Название и функция основных кнопок управления отладкой  
(а также соответствующих клавиш клавиатуры) следующие: 

– Start Debugger (F9) – запуск отладчика. 
– Run/Pause Debugger (F6) – запуск/останов программы в непре-

рывном (автоматическом) режиме. 
– Stop Debugger (Ctrl + F2) – прекращение работы отладчика. 
– Step Into (F7) – шаг на одну строку программы. 
– Step Over (F8) – шаг через одну строку программы. 
– Step Out (Ctrl + F8) – шаг из функции. 
– Run To Cursor (F4) – выполнять до курсора. 
– Toggle Breakpoint (F5) – поставить/удалить точку останова. 
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– Команда Step Into позволяет «шагать» по каждой строке исход-
ного текста. При помощи ее можно войти в вызываемую функцию. 

– Команда Step Over позволяет «перешагнуть» через вызывае-
мую функцию, не входя внутрь, а выполнив ее как единое целое. 

Для завершения работы с отладчиком в любой момент времени 
следует выбрать из меню команду Run > Stop Debugger. Произойдет 
возврат в режим редактирования. 

Задание. Выполните тестирование и отладку в IDE первой про-
граммы вывода в порт out.c. С этой целью перейдите в режим отладки 
с помощью команды меню Run > Start Debugger.  

Чтобы проверить работу программы out.c, нужно следить за со-
стоянием выводов порта B, которые отображаются переменной 
PORTB. Для занесения в окно наблюдения переменной подведите 
курсор мыши к строке Select variable from list (выбрать переменную 
из списка) и щелкните по стрелке в правой части. В раскрывшемся 
списке выберите строку PORTB и щелкните по ней. Для добавления 
выбранной переменной PORTB в список окна наблюдения щелкните 
по кнопке [Add]. Строка с переменной PORTB (желтого цвета) поя-
вится в окне наблюдения.  

Выполните программу out.c в пошаговом режиме Step Over, ис-
пользуя соответствующую кнопку управления отладкой или клавишу 
F8. При каждом шаге синяя полоса будет перемещаться по тексту про-
граммы. Наблюдайте за значением переменной PORTB на каждом шаге. 

Выполнение программы out.c прекращается при достижении 
правой фигурной скобки функции main( ). Программа зацикливается  
с помощью команды GOTO $, которую сгенерировал компилятор 
(смотреть файл out.asm). 

Для возможности нового выполнения программы нужно произ-
вести сброс микроконтроллера. Это можно сделать путем повторного 
запуска отладчика командой Run > Start Debugger или щелчком по 
соответствующей кнопке управления отладкой в окне Watch Values. 

Значения переменных в окне наблюдения по умолчанию ото-
бражаются в десятичном формате. В программе out.c значения 
PORTB записаны в шестнадцатеричном формате. Для изменения 
формата отображения щелкните два раза по строке PORTB. В рас-
крывшемся окне редактирования Edit Value PORTB поставьте флажок 
в окошке HEX. Затем щелкните по кнопке [OK] для подтверждения 
выбора и закрытия окна редактирования. 
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Выполните вновь программу  out.c  в пошаговом режиме Step 
Over. Убедитесь, что формат отображения PORTB стал шестнадцате-
ричным.  

Для завершения работы с отладчиком нужно выполнить коман-
ду меню Run > Stop Debugger, при этом происходит возврат в режим 
редактирования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.4 Вторая программа вывода в порт 

Во второй программе происходит бесконечный цикл вывода  
в порт B микроконтроллера, т. е. состояния выходов порта цикличе-
ски переключаются.    

Текст исходной программы: 
 

/********************************************************** 
 out2.c – вторая программа вывода данных в порт B 
**********************************************************/ 
void main( ) 
{ 
       TRISB = 0;                     // настроить линии порта В на вывод 
        while(1)                         // бесконечный цикл повторения 
       { 
             PORTB  = 0x00;            // вывод нулей в порт В 
             PORTB = 0xFF;            // вывод единиц в порт В 
        } 
} 
 

Задание. Выполните разработку программы в следующей по-
следовательности: 

1 С помощью команды New Project… запустите New Project 
Wizard. Создайте новый проект с именем out2 в папке Lab1, микро-
контроллер PIC16F84A, тактовая частота 8 МГц.  

2 Наберите текст исходной программы out2.c и сохраните его  
в папке. 

3 Выполните построение проекта. 
4 При отсутствии ошибок построения проекта переключите  

mikroC PRO в режим отладки программы с помощью симулятора. 
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Для тестирования программы занесите в окно наблюдения 
Watch Values имя порта РORTB из исходной программы. Установите 
HEX-формат отображения PORTB.  

Выполните программу в пошаговом режиме Step Over. После 
нескольких шагов убедитесь, что состояния выходов порта В цикли-
чески переключаются. 

Можно узнать время, затраченное на выполнение каждого опе-
ратора в строке программы по секундомеру, который находится в ок-
не хронометража Watch Clock. В строке Delta показывается количест-
во командных циклов и время в микросекундах (us), затраченных на 
выполнение одной строки исходной программы. 

Продолжайте выполнять программу в пошаговом режиме Step 
Over и наблюдайте за показаниями в окне Watch Clock. При каждом 
шаге показания секундомера Stopwatch будут увеличиваться. По зна-
чениям в строке Delta следует, что оператор вывода в порт (строка 
программы) выполняется за время – 1 мкс.  

Выполните сброс МК с помощью команды Run > Start Debugger 

или щелчком по соответствующей кнопке управления в окне Watch 
Values. 

Теперь запустите программу в автоматическом режиме с помо-
щью кнопки управления Run/Pause Debugger или нажатием на клави-
шу F6. При работе программы в автоматическом режиме значения пе-
ременной PORTB не обновляются, а в окне хронометража идет отсчет 
времени от момента запуска. 

Остановите выполнение программы повторным щелчком по 
кнопке управления Run/Pause Debugger или нажатием на клавишу F6. 
Зеленая стрелка слева от текста программы покажет номер строки, на 
которой произошел останов выполнения. Значение переменной 
PORTB (красного цвета) обновится. В окне Watch Clock будет ото-
бражаться общее время выполнения программы в автоматическом  
режиме от момента запуска.  

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом произойдет возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.5 Программа вывода в порт с временной задержкой 

Из результатов исследования программы out2.c следует, что вы-
вод в порт (одна строка программы) выполняется за 1 мкс. Очевидно, 



16 

что, если бы к порту были присоединены светодиоды, то их переклю-
чение было бы незаметно. Следовательно, необходимо ввести вре-
менную задержку между переключениями состояний выводов порта. 

Рассмотрим программу, в которой между переключениями вы-
ходов порта В имеется временная задержка: 

 
/********************************************************** 
 out3.c – программа вывода данных в порт В с временной задержкой   
**********************************************************/ 
void main( ) 
{ 
      TRISB = 0; 
      while(1) 
      {  
            PORTB = 0x00; 
            Delay_ms(500);       // временная задержка на 500 мс 
            PORTB = 0xFF; 
            Delay_ms(500);       // временная задержка на 500 мс 
       } 
} 
 

В программе out3.c для реализации временной задержки исполь-
зуется встроенная функция компилятора: 

Delay_ms (time_in_ms), 

где параметр  time_in_ms – требуемое время задержки в миллисекун-
дах. Это целое число в пределах от 1 до 4294697295. 

Задание. Для исследования программы создайте новый проект  
с именем out3 и поместите его в папку Lab1, микроконтроллер 
PIC16F84A, тактовая частота 8 МГц. Наберите текст программы  
в файле out3.c и сохраните его в папке. Выполните построение проек-
та, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения 
Watch Values имя порта РORTB из исходной программы. 

Выполните программу в пошаговом режиме Step Over. По пока-
заниям в строке Delta окна хронометража убедитесь, что время за-
держки равно заданному в программе и реализовано компилятором  
с высокой точностью.  
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Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом произойдет возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.6 Исследование программы счета с выводом в порт 

Рассмотрим программу, которая в бесконечном цикле увеличи-
вает число и выводит его в порт В микроконтроллера: 

 
/********************************************************** 
count.c – программа счета с выводом результата в порт B 
**********************************************************/ 
char  counter;         // объявление однобайтной переменной-счетчика 
void  main( ) 
{ 
       TRISB = 0; 
       counter = 0; 
        while(1)           // бесконечный цикл  счета и вывода в порт   
       { 
            PORTB = counter; 
            counter = counter + 1; 
        } 
} 

 

Задание. Для исследования программы создайте новый проект  
с именем count и поместите его в папку Lab1, микроконтроллер 
PIC16F84A, тактовая частота 8 МГц. Наберите текст программы  
в файле count.c и сохраните его. Выполните построение проекта, а за-
тем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения име-
на переменных counter и порта РORTB из исходной программы. 

Выполните программу в пошаговом режиме Step Over, наблюдая 
за изменением значений переменных counter и порта РORTB. Убеди-
тесь в правильности работы программы, сделав примерно 10 шагов.  

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом произойдет возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  
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3.7 Исследование программы суммирования чисел 

Рассмотрим программу, которая вычисляет суммы чисел: 

 

/********************************************************** 

 sum.c – программа вычисления суммы целых чисел от 1 до 10 и вы-

вода результата в порт В 

**********************************************************/ 

char  sum,   i;                   // объявление однобайтных переменных 

void  main( ) 

{ 

      TRISB = 0; 

      sum = 0; 

      for (i = 1; i <= 10; i++)            // цикл суммирования чисел 

      { 

             sum = sum + i; 

       } 

       PORTB = sum;        // вывод результата суммирования в порт В 

} 

 

3.7.1 Задание. Для исследования программы создайте новый 

проект с именем sum и поместите его в папку Lab1, микроконтроллер 

PIC16F84A, тактовая частота 8 МГц. Наберите текст программы  

в файле sum.c  и сохраните его. Выполните построение проекта, а за-
тем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения име-
на переменных i, sum, PORTB  из исходной программы. 

3.7.2 Выполните программу sum.c  до конца в пошаговом режи-

ме Step Over. Наблюдайте за изменением значений переменных  i, 

sum, PORTB. Убедитесь, что цикл  for  выполняется 10 раз. 
3.7.3 Теперь исследуйте работу программы в автоматическом 

режиме с использованием точек останова. 
Симулятор среды IDE имеет возможность останавливать выпол-

нение программы в любом месте. Это делается с помощью точек оста-
нова (breakpoints). Установить точку останова можно двумя способами. 

1 Надо подвести курсор мыши к нужной строке программы  

и щелкнуть левой кнопкой. Появится мигающая линия, означающая, 

что данная строка выбрана. Затем подведите курсор к кнопке управ-

ления отладкой Toggle Breakpoint  в окне Watch Values и щелкните 
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левой кнопкой (можно вместо этого нажать клавишу F5). Выбранная 

строка программы окрасится красным цветом, что означает – на уста-
новку точки останова. 

Для отмены точки останова нужно опять подвести курсор  
к нужной строке программы и щелкнуть левой кнопкой. Затем надо 
подвести курсор к кнопке управления Toggle Breakpoint и щелкнуть 
левой кнопкой (можно вместо этого нажать клавишу F5). 

2 Для установки точки останова нужно щелкнуть левой кнопкой 
мыши по маркеру (синему кружку) в левой части строки программы. 
Выбранная строка окрасится красным цветом, а маркер поменяет свой 
цвет на красный. 

Для отмены точки останова надо щелкнуть левой кнопкой мыши 
по маркеру красного цвета выделенной строки текста программы. 

Задание. Установите, а затем удалите точки останова в произ-
вольных местах программы с использованием обоих способов. 

Предположим, что в программе sum.c  нас интересует результат 
суммирования, выполненный оператором цикла  for. Кроме того, 
нужно узнать время, затраченное на выполнение программы от мо-
мента запуска до конца цикла  for. С этой целью установите точку ос-
танова на строке текста программы: 

PORTB = sum; 

Выполните сброс микроконтроллера командой Run > Start  

Debugger (клавиша F9). Затем запустите программу на выполнение  
в автоматическом режиме при помощи кнопки управления Run/Pause 
Debugger  или клавиши F6. 

Выполнение программы остановится на строке  PORTB = sum, 
которая примет синий цвет. Результатом суммирования в цикле  for  
будет значение  sum = 55. Время выполнения программы до точки ос-
танова будет 50 мкс. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом произойдет возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.8 Задания для самостоятельной работы 

Задание 1 Модернизируйте программу  count.c  таким образом, 

чтобы вывод в порт после каждого увеличения переменной counter 

выполнялся с временной задержкой  длительностью 1 с.  
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Для разработки программы создайте новый проект с именем count2 

и поместите его в папку Lab1. Выберите МК PIC16F84A, частота 8 МГц. 

Запишите текст программы в файл  count2.c и сохраните его. Выполните 
построение проекта, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения име-
на переменных  counter и порта РORTB из исходной программы. 

Выполните программу в пошаговом режиме Step Over. Наблю-
дайте за изменением содержимого переменных counter  и PORTB, 
сделав несколько шагов. Убедитесь, что вывод в порт В происходит 
через 1 с. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом произойдет возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  
Задание 2 Модернизируйте программу count.c таким образом, 

чтобы цикл вывода в порт В выполнялся только 5 раз. После этого 
выполнение программы прекращается. Для организации цикла вывода 
используйте оператор for (как в программе sum.c). 

Для разработки программы создайте новый проект с именем 
count3 в папке Lab1. Выберите МК PIC16F84A, тактовая частота 8 МГц. 
Запишите текст программы в файл count3.c  и сохраните его. Выполните 
построение проекта, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения име-
на переменных  counter и порта РORTB из исходной программы. 

Выполните программу в пошаговом режиме Step Over. Наблю-
дайте за изменением содержимого переменных counter  и PORTB. 
При каких значениях counter и PORTB прекращается цикл вывода? 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом происходит возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

4 Содержание отчета 

Укажите наименование и цель работы. Представьте тексты про-
грамм к заданиям для самостоятельной работы (комментарии в про-
граммах обязательны!). 
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5 Контрольные вопросы 

1 Что такое IDE? 
2 Какие функции выполняет IDE для PIC? 
3 Поясните процесс разработки программного обеспечения в сре-

де для PIC-микроконтроллеров. 
4 Что такое проект в IDE? 
5 На каком этапе осуществляется выбор микроконтроллера? 
6 Какие окна используются в симуляторе для наблюдения за хо-

дом выполнения программы? 
7 Как можно осуществить пошаговое выполнение программы? 
8 Что такое точка останова? 

Лабораторная работа № 2 

ИССЛЕДОВАНИЕ ОСНОВНЫХ ОПЕРАЦИЙ  

ЯЗЫКА ПРОГРАММИРОВАНИЯ СИ 

1 Цель работы 

Изучить операции языка программирования Си: арифметиче-
ские; присваивания; логические; отношения и поразрядные. Практи-
чески исследовать выполнение этих операций в программах для мик-
роконтроллеров семейства PIC16. 

2 Основные теоретические сведения 

Программа на языке Си состоит из выражений. Выражение – это 
последовательность операндов, операций и символов-разделителей. 
Основные операции в Си: арифметические, присваивания, отношения, 
логические, поразрядные. Для обозначения этих операций использу-
ются специальные символы (значки). 

3 Порядок выполнения работы 

3.1 Создание папки для работы 

Предположим, что при выполнении лабораторной работы № 2 
мы будем использовать папку с именем Lab2, которую необходимо 
предварительно создать. 
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С этой целью откройте Вашу рабочую папку и создайте в ней  
(с помощью клавиши F7) новую папку с именем Lab2. 

В дальнейшем Вы будете записывать и хранить в этой папке все 
файлы  при выполнении данной лабораторной работы (работы № 2). 
Полный путь к этой папке будет такой: 

F:\MPinCS\Ivanov\Lab2 

3.2 Исследование арифметических операций 

3.2.1 Язык Си для PIC-микроконтроллеров включает стандарт-
ный набор арифметических операций, обозначаемых значками:  сло-
жение “ + ”, вычитание “ – “, умножение “ * ”, деление “ / “, которые 
не требуют особого пояснения. Специфичными являются операции 
определения остатка от деления, а также инкремента и декремента. 

Операцию определения остатка от деления, обозначаемую знач-
ком “ % “, поясняет следующий пример: 

 
int  a = 5,  b = 2,  d; 
d = a % b;                // d = 1 – остаток от деления  5 / 2 
d = b % a;                // d = 2 
 
Следует отметить, что операция определения остатка от деления 

применима только к целым числам. 
Операции инкремента (обозначается как “ ++ “) и декремента 

(обозначается как “ -- “) могут применяться только к переменным. 
Существуют две формы их записи: префиксная, когда операнд распо-
лагается справа от знака операции (например, ++i,  --j), и постфикс-
ная, когда операнд располагается слева от знака операции (i++,  j--).  

В префиксной форме (для инкремента) сначала выполняется уве-
личение операнда на 1, и увеличенное значение используется в выра-
жении. В постфиксной форме (для инкремента) сначала используется  
в выражении  значение операнда и только после этого его значение 
увеличивается на 1. Например: 

 
int  a = 0,  b = 1,  d; 
d = a++;          // d = 0,  а = 1 
d = ++a;          // d = 2,  a = 2 
d = ++b;          // d = 2,  b = 2 
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Рассмотрим программу  arifm.c, в которой будут использоваться 
некоторые арифметические операции:     

 
/********************************************************** 
arifm.c – первая программа для исследования арифметических опера-
ций  

 
***********************************************************/ 
int   i,  k = 6,  n,  m;                           // объявления переменных 
void  main( ) 
{ 
     i = 10 * (k++);                      // i =      , k =  
     k--;                                        // k =  
     i = 10 * (++k);                      // i =     , k =  
     k--;                                        // k =  
     n = i / k;                                // n =  
     m = i % k;                             // m =   
} 

 
Задание. Для исследования программы создайте новый проект  

с именем arifm в папке Lab2. Выберите МК PIC16F84A, тактовая часто-
та 8 МГц. Наберите текст программы в файле  arifm.c  и сохраните его. 
Выполните построение проекта и затем перейдите в режим отладки. 

Для тестирования программы и занесите в окно наблюдения 
Watch Values имена  переменных i, j, k, n, m  из исходной программы. 

Примечание. 1. Если после запуска отладчика на экране будет отсутство-
вать окно наблюдения Watch Values, то его можно открыть с помощью команды 
меню View > Debug Window > Watch Window  или нажатием комбинации кла-
виш  Shift + F5.  2. Формат отображения данных в окне наблюдения будет по 
умолчанию десятичный. 

Исследуйте работу программы  arifm.c  в пошаговом режиме 
Step Over. После каждого шага наблюдайте за содержимым перемен-
ных в окне Watch Values и записывайте эти значения в текст коммен-
тария программы. Эти значения необходимо будет привести в отчете 
по данной работе. Объясните полученные результаты выполнения 
операторов программы. 

Для завершения работы с отладчиком нужно выполнить коман-
ду меню Run > Stop Debugger, при этом происходит возврат в режим 
редактирования. Сохраните файл arifm.c  с комментариями, получен-
ными в результате исследования программы, с помощью команды 
меню File > Save.   
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В заключение закройте проект с помощью команды Project > 

Close Project.  

3.2.2 Операция присваивания в языке Си обозначается как “=”. 
Обычно она используется в виде 

переменная = выражение; 
При выполнении операции присваивания переменная получает 

значение выражения. Выражение может быть одиночной константой 
или сложной комбинацией переменных, операторов и констант. На-
пример: 

 
               x = 10; 
               x = x + y; 
               x = x + y + 50; 
 

При программировании часто используются операторы вида 
 

               x = x + 4; 
               x = x – y;         
и т. п. 

В этих операторах переменная, которой присваивается результат 
выражения, является также первым операндом. Для выполнения по-
добных операций язык mikroC предлагает составные операторы при-
сваивания, которые объединяют простые арифметические операции  
с присваиванием. В таблице 2.1 приведены арифметические состав-
ные операторы присваивания. 

 
Таблица 2.1 – Арифметические составные операторы присваивания 

Оператор присваивания Длинная форма Пример 

x += y; x = x + y; x += 12; 

x -= y; x = x – y; x -= 34 + y; 

x *= y; x = x * y; x *= 10; 

x /= y; x = x / y; x /= 5; 

x %= y; x = x % y; x %=2; 

Примечание. В составном операторе присваивания между знаком арифмети-
ческой операции (+, -, *, /, %) и знаком присваивания “=” пробел не допускается! 
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В качестве примера рассмотрим программу  arifm2.c, в которой 

используются арифметические составные операторы присваивания 

для целых чисел и чисел с плавающей точкой: 

 

/*********************************************************** 

arifm2.c – вторая программа для исследования арифметических опе-
раций 

***********************************************************/ 

int   i = 55,  j = 66; 

float   x = 2.5,  y = 4.6; 

void  main( ) 

{ 

     i += j;                   // i =   

     j -= 6;                   // j =  

     i *= 4;                  // i =  

     j /= 3;                   // j =  

     i %= 2;                // i =  

     x += y;                // x =  

     y -= 4.0;              // y =  

     x *= 4.0;             // x =  

     y /= 3.0;              // y =  

} 

 

Задание. Для исследования программы создайте новый проект  
с именем arifm2 в папке Lab2,  МК PIC16F84A, частота 8 МГц. Набе-
рите текст программы в файле  arifm2.c  и сохраните его. Выполните 
построение проекта, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения 

Watch Values имена  переменных  i, j, x, y  из исходной программы.  

Исследуйте работу программы  arifm2.c в пошаговом режиме 
Step Over. После каждого шага наблюдайте за содержимым перемен-

ных в окне Watch Values и записывайте эти значения в текст коммен-

тария программы. Эти значения необходимо будет привести в отчете 
по данной работе. Объясните полученные результаты выполнения 

операторов программы. 

Для завершения работы с отладчиком нужно выполнить коман-

ду меню Run > Stop Debugger, при этом происходит возврат в режим 

редактирования. Сохраните файл arifm2.c  с комментариями, полу-
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ченными в результате исследования программы, используя команду 

File > Save.  

В заключение закройте проект с помощью команды Project > 

Close Project.  

3.3 Исследование операций отношения и логических 

3.3.1 Операции отношения применяются для вычисления соот-
ношений между операндами. Логические операции, используя прави-
ла логики, также возвращают соотношения между операндами.  

В формальной логике ключевым понятием являются ЛОЖЬ  
и ИСТИНА. В языке Си лжи соответствует 0, а истине – любое значе-
ние, отличное от 0. Выражения, использующие операции отношения 
или логические, возвращают 0 для лжи и 1 для истины. В таблице 2.2 
приведены обозначения логических и операций отношения, приме-
няемых в языке mikroC. 

 
Таблица 2.2 – Логические операции и операции отношения  

Знак операции Выполняемое действие Пример 

&& Логическое И if (k > 1 && k < 10) 

|| Логическое ИЛИ if (c == 0 || c == 9) 

! Логическое  НЕ if (!(c > 1 && c < 9)) 

< Меньше if (j < 0) 

<= Меньше или равно if (j <= 0) 

> Больше if (j > 10) 

>= Больше или равно if (x >= 8.2) 

== Равно if (c == b) 

!= Не равно if (c != b) 

 
В качестве примера рассмотрим программу  logic.c, в которой 

используются операции отношения и логические для целых чисел: 
 

/*********************************************************** 
logic.c – первая  программа для исследования операций отношения  
и логических  
***********************************************************/ 
char  var1 = 10,  var2 = 20; 
char  res1, res2, res3, res4, res5, res6, res7, res8; 
void  main( ) 
{ 
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     res1 = var1 > var2;               // res1 =  
     res2 = var1 < var2;               // res2 =  
     res3 = var1 == var2;             // res3 =  
     res4 = var1 != var2;              // res4 =  
     res5 = var1 && var2;           // res5 = 
     res6 = var1 || var2;                // res6 =  
     res7 = ! var1;                        // res7 =  
     res8 = ! var2;                        // res8 =       
} 

 

Задание. Для исследования программы создайте новый проект с 
именем logic в папке Lab2, МК PIC16F84A, частота 8 МГц. Наберите 
текст программы в файле logic.c  и сохраните его. Выполните по-
строение проекта, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения 
Watch Values имена переменных var1, var2, res1, res2, res3, res4, res5, 
res6, res7, res8  из исходной программы. 

Исследуйте работу программы  logic.c  в пошаговом режиме 
Step Over. После каждого шага наблюдайте за содержимым перемен-
ных в окне Watch Values  и записывайте эти значения в текст коммен-
тария программы. Эти значения необходимо будет привести в отчете 
по данной работе. Объясните полученные результаты выполнения 
операторов программы. 

Для завершения работы с отладчиком нужно выполнить коман-
ду меню Run > Stop Debugger, при этом происходит возврат в режим 
редактирования. Сохраните файл logic.c  с комментариями, получен-
ными в результате исследования программы.  

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.4 Исследование поразрядных операций 

3.4.1 В языке Си широко используются поразрядные (побито-
вые) операции, с помощью которых можно выполнять тестирование, 
установку, сброс, инвертирование и сдвиг отдельных битов операн-
дов. Поразрядные операции могут выполняться только с целыми ти-
пами данных, т. е. char, int, long. В таблице 2.3 приведены поразряд-
ные операции языка mikroC. 
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Таблица 2.3 – Поразрядные операции в языке Си 

Знак операции Выполняемое действие Пример 

& Поразрядное  И i & 0x25 

| Поразрядное  ИЛИ j | 64 

^ Поразрядное исключающее  ИЛИ k ^ 0x0F 

~ Поразрядное  НЕ (инверсия) ~ m 

<< Поразрядный сдвиг влево i << 2 

>> Поразрядный сдвиг вправо j >> 3 

 
Рассмотрим программу  bit_op.c, в которой используются раз-

личные поразрядные операции: 
 

/********************************************************** 
 bit_op.c – первая программа для исследования поразрядных операций  
**********************************************************/ 
char  i = 0x0F,  j = 0x1A,  k1,  k2,  k3,  k4,  k5,  k6,  k7; 
void  main( ) 
{ 
     k1 = i & j;                    // k1 =    
     k2 = i | j;                      // k2 =  
     k3 = i ^ j;                     // k3 =  
     k4 = ~ i;                       // k4 = 
     k5 = ~ j;                       // k5 =  
     k6 = i << 2;                 // k6 =  
     k7 = j >> 3;                 // k7 =  
} 

 

Задание. Для исследования программы создайте новый проект с 
именем bit_op в папке Lab2, МК PIC16F84A, частота 8 МГц. Наберите 
текст программы в файле  bit_op.c  и сохраните его. Выполните по-
строение проекта, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения 
Watch Values имена переменных k1, k2, k3, k4, k5, k6, k7  из исходной 
программы. Установите двоичный формат отображения значений пе-
ременных. 

Исследуйте работу программы  bit_op.c  в пошаговом режиме 
Step Over. После каждого шага наблюдайте за содержимым перемен-
ных в окне Watch Values и записывайте эти значения в текст коммен-
тария программы. Эти значения необходимо будет привести в отчете 
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по данной работе. Объясните полученные результаты выполнения 
операторов программы. 

Для завершения работы с отладчиком нужно выполнить коман-
ду меню Run > Stop Debugger, при этом произойдет возврат в режим 
редактирования. Сохраните файл bit_op.c  с комментариями, полу-
ченными в результате исследования программы.  

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.4.2 Для сокращения текста программ в Си широко используют-
ся поразрядные составные операторы присваивания, которые являются 
комбинацией поразрядных операций и присваивания. В таблице 2.4 
приведены составные поразрядные операции присваивания. 

 
Таблица 2.4 –  Составные поразрядные операторы присваивания 

Оператор Длинная форма Пример 

x &= y; x = x & y; i &= 0x0F; 

x |= y; x = x | y; j |= 64; 

x ^= y; x = x ^ y; k ^= 0x80; 

x <<= n; x = x << n; j <<= 2; 

x >>= n; x = x >> n; k >>= 3; 

Примечание. В составных операторах присваивания между знаком поразряд-
ной операции (&, |, ^, >>, <<) и знаком присваивания “=“ пробел не допускается! 

 
Рассмотрим программу bit_op2.c, в которой используются раз-

личные составные поразрядные операторы присваивания: 
 

/********************************************************** 
 bit_op2.c – вторая программа для исследования поразрядных 
 составных операций присваивания 
**********************************************************/ 
char   i, j, k; 
void  main( ) 
{ 
     i = 0xFF;                      // i =  
     i &= 0x0F;                   // i =  
     i |= 0x31;                     // i =  
     i ^= 0x94;                    // i =  
      
     j = 0xFF;                      // j =  
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         /* установить код  0110 в старшей тетраде переменной  j  */ 
     j &= 0x0F;                    // j =  
     j |= 0x60;                      // j =  
          /* инвертировать 7-й разряд в переменной  j  */ 
     j ^= 0x80;                     // j =  
           /*  инвертировать 3-й разряд в переменной  j  */ 
     j ^=0x04;                      // j =  
 
     k = 0xF5;                      // k =  
           /*  сдвиги беззнаковой переменной  k  */ 
     k >>= 1;                        // k =  
     k >>= 2;                        // k =  
     k <<= 1;                        // k =  
     k <<= 2;                        // k =  
 
} 

   

Задание. Для исследования программы создайте новый проект с 
именем bit_op2 папке Lab2, МК PIC16F84A, частота 8 МГц. Наберите 
текст программы в файле  bit_op2.c  и сохраните его. Выполните по-
строение проекта, а затем перейдите в режим отладки. 

Для тестирования программы занесите в окно наблюдения 
Watch Values имена переменных  i, j, k  из исходной программы. Ус-
тановите двоичный формат отображения значений переменных. 

Исследуйте работу программы  bit_op2.c  в пошаговом режиме 
Step Over. После каждого шага наблюдайте за содержимым перемен-
ных в окне Watch Values  и записывайте эти значения в текст коммен-
тария программы. Эти значения необходимо будет привести в отчете 
по данной работе. Объясните полученные результаты выполнения 
операторов программы. 

Для завершения работы с отладчиком нужно выполнить коман-
ду меню Run > Stop Debugger, при этом происходит возврат в режим 
редактирования. Сохраните файл bit_op2.c  с комментариями, полу-
ченными в результате исследования программы. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

4 Содержание отчета 

Укажите наименование и цель работы. Представьте таблицы 2.1– 2.4 
и тексты всех исследуемых программ с результатами выполнения.  
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5 Контрольные вопросы 

1 Какие арифметические операции имеются в языке Си? 
2 Как выполняются операции прединкремента и постинкремен-

та? Приведите примеры. 
3 Как выполняется операция определения остатка от деления? 

Приведите пример. 
4 Как обозначаются и выполняются составные арифметические 

операции присваивания? 
5 Как кодируются логические понятия ЛОЖЬ и ИСТИНА в Си? 
6 Какие логические операции имеются в языке Си? 
7 Какие операции отношения имеются в языке Си? 
8 Какие имеются в языке Си поразрядные операции? 
9 Как обозначаются и выполняются составные поразрядные опе-

рации присваивания? 

Лабораторная работа № 3 

ИССЛЕДОВАНИЕ ОПЕРАТОРОВ ВЫБОРА 

ДЛЯ УПРАВЛЕНИЯ ПРОГРАММОЙ В ЯЗЫКЕ СИ  

1 Цель работы 

Изучить операторы выбора для управления программой в язы- 
ке Си. Практически исследовать выполнение этих операторов в про-
граммах для микроконтроллеров семейства PIC16. 

2 Основные теоретические сведения 

Операторы управления программой – это средства, с помощью 
которых можно изменять порядок выполнения программы. Они по-
зволяют выполнять ветвление, циклическое повторение одного или 
нескольких операторов, передачу управления в нужное место кода 
программы. 

Язык Си предоставляет три категории операторов управления 
программой: 

1) операторы выбора – это  if  и  switch; 
2) операторы цикла – это  while,  do … while  и  for; 
3) операторы перехода – это  break,  continue  и  goto. 
В данной лабораторной работе Вы будете изучать и исследовать 

операторы выбора. 
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3 Порядок выполнения работы 

3.1 Создание папки для работы 

При выполнении лабораторной работы № 3 мы будем использо-
вать папку с именем Lab3, которую необходимо предварительно  
создать. 

С этой целью откройте Вашу рабочую папку и создайте в ней  
(с помощью клавиши F7) новую папку с именем Lab3. 

В дальнейшем Вы будете записывать и хранить в этой папке все 
файлы  при выполнении лабораторной работы № 3. Полный путь  
к этой папке будет такой: 

f:\MPinCS\Ivanov\Lab3 

В данной лабораторной работе будут широко использоваться 
операции ввода и вывода данных через порты микроконтроллера. По-
этому сначала рассмотрим, как в языке Си программируются опера-
ции работы с портами.  

3.2 Исследование операций ввода/вывода в Си 

Микроконтроллеры семейства PIC16 имеют несколько портов 
ввода/вывода, позволяющих получать информацию от внешних уст-
ройств (ввод данных) или отправлять данные внешним устройствам 
(вывод данных). Количество портов и их разрядность (по-другому, 
число линий порта) определяется конкретным типом микроконтрол-
лера. Так, простой микроконтроллер PIC16F84A имеет два порта, ко-
торые обозначаются буквами А и В. Причем порт А имеет 5 линий  
(5-разрядный), а порт В имеет 8 линий (8-разрядный). Более сложный 
микроконтроллер PIC16F877 имеет 5 портов, которые обозначаются 
буквами A, B, C, D, E. Порт А имеет 6 линий, порты B, C и D –  
по 8 линий каждый, а порт E имеет только 3 линии.  

Для управления вводом/выводом через каждый порт служит со-
ответствующая пара регистров: 

– регистр данных – PORTx; 
– регистр управления направлением передачи – TRISx. 
Количество таких пар регистров соответствует количеству пор-

тов. С их помощью через любой порт может быть одновременно вы-
дано или принято от одного до восьми бит данных.  

Порты в микроконтроллерах PIC – двунаправленные. Это озна-
чает, что любой вывод порта может использоваться и как вход, и как 
выход. Направление передачи задает соответствующий управляющий 
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регистр TRISx. Запись в некоторый разряд регистра TRISx логической 
единицы делает соответствующий вывод порта входом, а логического 
нуля – выходом. Например, для того чтобы нулевой и первый разряды 
порта В были входами, а все остальные – выходами, в регистр TRISB 
необходимо записать значение 00000011.   

Настроив порты на вывод, мы можем их использовать для выво-
да данных в порт. Например, мы можем вывести какие-либо данные в 
порт С микроконтроллера PIC16F877 следующим образом: 

 
char  port_data;             // объявление однобайтной переменной 
TRISC = 0;                   // настроить все линии порта С на вывод 
port_data = 0x0F;      // присвоить переменной port_data значение 0x0F 
PORTC = port_data;     // вывести значение  переменной port_data 
                                      // в порт С 
PORTC = 0xF0;           // вывести значение 0xF0  в порт C 

 
Если настроить порты на ввод, то их можно использовать для 

чтения данных с их входов (для ввода данных из портов). Так, для 
чтения данных из порта В (ввода данных) микроконтроллера 
PIC16F877 нужно выполнить следующий код программы: 

 
char port_data;              // объявление однобайтной переменной для  
                                      // хранения введенных данных 
TRISB = 0xFF;             // настроить все линии порта В  на ввод 
port_data = PORTB;     // чтение данных с линий порта В (ввод из 
                                      //  порта В)  

 
Рассмотрим в качестве примера программу, в которой выполня-

ется ввод данных из порта В, а затем их вывод в порт С микрокон-
троллера PIC16F877: 

 
/********************************************************** 
in_out.c – программа для исследования ввода и вывода данных 
Микроконтроллер PIC16F877 
**********************************************************/ 
char  in_port;           // переменная для хранения данных, введенных 
                                // из порта В 
void  main( ) 
{ 
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     TRISB =0xFF;                  // настроить все линии порта В на ввод 
     TRISC = 0;                       // настроить все линии порта С на вывод 
     while(1)                            // бесконечный цикл ввода и вывода 
     {       
          in_port = PORTB;         // ввод из порта В 
          PORTC = in_port;         // вывод в порт С 
      } 
} 
 

Задание. Выполните разработку программы в следующей по-
следовательности: 

1 Запустите программу IDE. 
2 С помощью команды New Project… запустите New Project 

Wizard. Создайте новый проект с именем  in_out  в папке  f:\....\Lab3. 
Выберите микроконтроллер PIC16F877, тактовая частота 8 МГц. 

3 Наберите текст исходной программы  in_out.c  и сохраните его 
в папке (с помощью команды меню File > Save).  

4 Выполните построение проекта (с помощью команды меню 
Build > Build). 

5 При отсутствии ошибок построения проекта переключите mik-
roC PRO  в режим отладки (с помощью команды меню Run > Start 

Debugger). 
Проведите исследование работы программы in_out.c  в следую-

щей последовательности. 
Для тестирования программы занесите в окно наблюдения 

Watch Values последовательно имена портов PORTB и PORTC, а за-
тем имя переменной in_port. 

Примечания. 1. Если после запуска отладчика на экране будет отсутство-
вать окно наблюдения Watch Values, то его можно открыть с помощью команды 
меню View > Debug Window > Watch Window  или нажатием комбинации кла-
виш  Shift + F5.  2. Формат отображения данных в окне наблюдения будет по 
умолчанию десятичный. 

Выполните программу in_out.c в пошаговом режиме Step Over 
путем нажатия на клавишу F8, или щелкая мышью по соответствую-
щему значку управления отладкой.  

Когда синяя полоса окажется на строке с номером 7 (in_port = 
PORTB;), поставьте курсор мыши на колонку Value в строке PORTB  
и дважды щелкните левой кнопкой. Мигающая линия курсора появит-
ся справа от числа. С помощью клавиши Back Space удалите это число 
и наберите новое число, например, 10. Затем нажмите клавишу Enter.  
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В строке PORTB появится новое значение Value (красного цвета), рав-
ное 10. Так как линии порта В настроены на ввод, то набранное новое 
значение 10 будет являться кодом данных (в десятичном формате) на 
входах порта В. 

Выполните следующий шаг программы – строку 8 (in_port = 
PORTB;). Убедитесь, что значение переменной  in_port  стало равным 10, 
т. е. произошел ввод данных со входов порта В. 

Выполните следующий шаг программы – строку 9 (PORTC = 
in_port;). Убедитесь, что содержимое регистра данных порта PORTC 
стало равным 10, т. е. произошел вывод в порт С. 

Когда после очередного шага синяя полоса вновь окажется на 
строке c номером 7 (in_port = PORTB;), измените данные на входах 
порта В. Введите, например, число 100. Продолжайте выполнять про-
грамму в пошаговом режиме, наблюдая за содержимым переменных  
в окне Watch Values. Объясните полученные результаты работы про-
граммы. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом произойдет возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.3 Исследование операторов выбора 

Язык Си поддерживает два типа операторов выбора: if (если)  
и switch (переключатель). Эти операторы позволяют проверять вы-
полнение определенных условий и выбирать возможное продолжение 
вычислительного процесса. Возможны следующие конструкции этих 
операторов: 

1) оператор  if  единственного выбора; 
2) оператор  if … else  двойного выбора; 
3) оператор  if … else if … else  множественного выбора; 
4) оператор  switch  множественного выбора. 
3.3.1 Исследование оператора if единственного выбора. Опера-

тор if единственного выбора для одного выполняемого оператора 
имеет вид 

 
if (условие) 
     оператор; 

для блока выполняемых операторов: 

if (условие) 
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{ 
     оператор1; 
     ………….. 
     операторN; 
}  
 
Программа вычисляет условие, заключенное в круглых скобках. 

Если оно истинно, то выполняется оператор (или блок операторов, за-
ключенный в фигурных скобках). Если условие ложно, то оператор 
(или блок) не выполняется.   

В качестве примера рассмотрим программу  if1.c, в которой ис-
пользуется оператор  if  единственного выбора: 

 
/********************************************************** 
 if1.c –  программа для исследования оператора  if  единственного вы-
бора.  Микроконтроллер PIC16F877 
**********************************************************/ 
char  in_port;     // переменная для хранения вводимых данных 
                             // из порта В 
void  main( ) 
{ 
     TRISB = 0xFF;                            // настроить порт В  на ввод 
     TRISC = 0;                                  // настроить порт С на вывод 
     PORTC = 0x00;                          // вывести нули в порт С 
     in_port = PORTB;                      // ввод из порта В 
     if (in_port  >=  0x0F) 
          PORTC = in_port;                 // вывод в порт C 
} 
 

В программе вводится число из порта В и записывается в пере-
менную in_port. Если это значение больше или равно значению  
0x0F = 00001111, то программа выводит его в порт С. В противном 
случае программа никаких действий не производит. 

Задание. Выполните разработку программы в следующей по-
следовательности: 

1 С помощью команды New Project… запустите New Project 
Wizard. Создайте новый проект с именем  if1  в папке  f:\....\Lab3. Вы-
берите микроконтроллер PIC16F877, тактовая частота 8 МГц. 
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2 Наберите текст исходной программы  if1.c  и сохраните его  
в папке (с помощью команды меню File > Save).  

3 Выполните построение проекта (с помощью команды меню 
Build > Build). 

4 При отсутствии ошибок построения проекта переключите  
mikroC PRO в режим отладки (с помощью команды меню Run > Start 

Debugger). 
Проведите исследование работы программы if1.c  в следующей 

последовательности. 
Для тестирования программы занесите в окно наблюдения 

Watch Values последовательно имена портов PORTB и PORTC, а за-
тем имя переменной in_port.  

Для исследования работы программы измените формат отобра-
жения всех переменных в окне наблюдения на шестнадцатеричный. 

Выполните программу if1.c  в пошаговом режиме Step Over пу-
тем нажатия на клавишу F8, или щелкая мышью по соответствующе-
му значку управления отладкой.  

Когда синяя полоса окажется на строке с номером 6 (in_port = 
PORTB;), поставьте курсор мыши на колонку Value в строке PORTB и 
дважды щелкните левой кнопкой. Наберите новое число, например, 
0x7F, а затем нажмите клавишу Enter. Продолжайте выполнять про-
грамму в пошаговом режиме, наблюдая за перемещением синей поло-
сы по ветвям программы. 

Когда синяя полоса окажется на фигурной скобке (конец функ-
ции main), дальнейшее выполнение программы прекратится. Произве-
дите сброс микроконтроллера с помощью команды меню Run > Start 

Debugger, или щелкнув по соответствующему значку управления от-
ладкой. Введите новое значение на входах порта В, например, 0x03. 
Выполните программу до конца в пошаговом режиме, наблюдая за пе-
ремещением синей полосы по ветвям программы. 

Объясните полученные результаты выполнения операторов про-
граммы при различных значениях данных на входах порта В. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger, при этом происходит возврат в режим редакти-
рования. 

В заключение закройте проект с помощью команды Project > Close 

Project.  
3.3.2 Исследование оператора  if … else  двойного выбора. Опе-

ратор  if … else  (если … то) двойного выбора обеспечивает две аль-
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тернативы продолжения выполнения программы. Выбор осуществля-
ется, исходя из проверяемого условия. 

Общий вид оператора  if … else  двойного выбора для одного 
выполняемого оператора: 

 
if (условие) 
     оператор1; 
else 
     оператор2; 
 
Вместо одиночных операторов 1 и 2 могут быть блоки операто-

ров, заключенные в фигурные скобки. 
В случае истинности условия выполняется оператор1, в против-

ном случае – оператор2. 
Рассмотрим в качестве примера программу  if2.c, где использо-

ван оператор  if … else  двойного выбора: 
 

/********************************************************** 
 if2.c –  программа для исследования оператора   if … else    двойного 
выбора. Микроконтроллер PIC16F877 
**********************************************************/ 
char  in_port;      // переменная для хранения вводимых данных 
                                // из порта В 
void  main( ) 
{ 
     TRISB = 0xFF;               // настроить все линии порта B на ввод 
     TRISC = 0;                     // настроить все линии порта С на вывод 
     TRISD = 0;                    // настроить все линии порта D на вывод 
     PORTC = 0x00;                            // вывод нулей в порт С 
     PORTD = 0x00;                            // вывод нулей в порт D 
     in_port = PORTB;                                         // ввод из порта B 
     if (in_port > 0  &&  in_port < 0x0F) 
          PORTC = in_port;                                    // вывод в порт C 
     else 
          PORTD = in_port;                                    // вывод в порт D 
} 
 

В программе  if2.c  вводится число из порта B и записывается  
в переменную  in_port. Если это значение находится в диапазоне от 0 
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до 0x0F = 00001111, то программа выводит его в порт C. В противном 
случае это число выводится в порт D. 

Задание. Выполните разработку программы в следующей по-
следовательности: 

1 С помощью команды New Project… запустите New Project 
Wizard. Создайте новый проект с именем  if2  в папке  f:\....\Lab3. Вы-
берите микроконтроллер PIC16F877, тактовая частота 8 МГц. 

2 Наберите текст исходной программы  if2.c  и сохраните его в 
папке (с помощью команды меню File > Save).  

3 Выполните построение проекта (с помощью команды меню 
Build > Build). 

4 При отсутствии ошибок построения проекта переключите mik-
roC PRO в режим отладки (с помощью команды меню Run > Start 

Debugger). 

Проведите исследование работы программы if2.c  в следующей 
последовательности. 

Для тестирования программы занесите в окно наблюдения 
Watch Values последовательно имена портов PORTB, PORTC и 
PORTD, а затем имя переменной in_port.  

Для исследования работы программы измените формат отобра-
жения всех переменных в окне наблюдения на шестнадцатеричный. 

Выполните программу if2.c в пошаговом режиме Step Over пу-
тем нажатия на клавишу F8, или щелкая мышью по соответствующе-
му значку управления отладкой.  

Когда синяя полоса окажется на строке с номером 8 (in_port = 
PORTB;), поставьте курсор мыши на колонку Value в строке PORTB и 
дважды щелкните левой кнопкой. Наберите новое число, например, 
0x7F, а затем нажмите клавишу Enter. Продолжайте выполнять про-
грамму в пошаговом режиме, наблюдая за перемещением синей поло-
сы по ветвям программы. 

Когда синяя полоса окажется на фигурной скобке (конец функ-
ции main), дальнейшее выполнение программы прекратится. Произве-
дите сброс микроконтроллера с помощью команды меню Run > Start 

Debugger, или щелкнув по соответствующему значку управления от-
ладкой. Введите новое значение на входах порта В, например, 0x03. 
Выполните программу до конца в пошаговом режиме, наблюдая за пе-
ремещением синей полосы по ветвям программы. 

Объясните полученные результаты выполнения операторов про-
граммы при различных значениях данных на входах порта В. 
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Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger. 

В заключение закройте проект с помощью команды Project > Close 

Project.  
3.2.3 Исследование оператора  if … else if … else  множествен-

ного выбора. Язык mikroC позволяет использовать вложенные опера-
торы  if … else  для реализации множественного выбора. 

Общий вид оператора  if … else if … else  множественного вы-
бора: 

 
if (условие1) 
     оператор1; 
else  if (условие2) 
     оператор2; 
 …………………… 
else   if (условиеN) 
     операторN; 
else 
     оператор(N+1); 

 
Последняя  else-часть в операторе  if … else  может и отсутствовать. 
Оператор  if … else if … else  множественного выбора выполня-

ет серию последовательных проверок до тех пор, пока не будет уста-
новлено следующее: 

1 Одно из условий в  if-части или в частях  else  if  является ис-
тиной. В этом случае выполняются соответствующие ему операторы. 

2 Ни одно из вложенных условий не является истиной. Програм-
ма выполнит операторы в последней  else-части, если она имеется. 

Рассмотрим программу  if3.c, в которой используется оператор  
if … else if … else  множественного выбора: 

 
/**********************************************************   
 if3.c – программа исследования оператора  if … else if … else                   
множественного выбора. Микроконтроллер PIC16F877 
**********************************************************/ 
char  in_port;    // переменная для хранения вводимых данных  
                                                         // из порта В 
void  main( ) 
{ 
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      TRISB = 0xFF;                                  // настроить порт B на ввод 
      TRISC = 0;                                        // настроить порт С на вывод 
      PORTC =0x00;                                 // вывод нулей в порт С  
      in_port = PORTB;                             // ввод данных из порта B 
      if (in_port > 0  &&  in_port < 0x0F) 
           PORTC = 0x01;                         // вывод в порт С значения 0x01 
      else  if (in_port >= 0x0F  &&  in_port < 0x3F) 
           PORTC = 0x02;                         // вывод в порт С значения 0x02 
      else  if (in_port >= 0x3F  &&  in_port < 0x7F) 
           PORTC = 0x03;                         // вывод в порт С значения 0x03 
      else 
           PORTC = 0x04;                         // вывод в порт С значения 0x04 
} 
 

Программа вводит данные с входов порта В и записывает их в 
переменную  in_port. Затем используется оператор  if … else if … else  
множественного выбора для определения нахождения значения  
in_port  в определенном диапазоне: 

 
0 <  in_port  <  0x0F            – диапазон 1 
0x0F <=  in_port  <  0x3F   – диапазон 2 
0x3F <=  in_port  <  0x7F   – диапазон 3 
0x7F <=  in_port  <=  0xFF – диапазон 4 
 
Полученное значение номера диапазона выводится в порт С. 
Задание. Выполните разработку программы в следующей по-

следовательности: 
1 С помощью команды New Project… запустите New Project 

Wizard. Создайте новый проект с именем  if3  в папке  f:\....\Lab3. Вы-
берите микроконтроллер PIC16F877, тактовая частота 8 МГц. 

2 Наберите текст исходной программы  if3.c  и сохраните его  
в папке (с помощью команды меню File > Save).  

3 Выполните построение проекта (с помощью команды меню 
Build > Build). 

4 При отсутствии ошибок построения проекта переключите  
mikroC PRO в режим отладки (с помощью команды меню Run > Start  
Debugger). 

Проведите исследование работы программы if3.c  в следующей 
последовательности. 
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Для тестирования программы занесите в окно наблюдения 
Watch Values последовательно имена портов PORTB и PORTC, а за-
тем имя переменной in_port.  

Для исследования работы программы измените формат отобра-
жения всех переменных в окне наблюдения на шестнадцатеричный. 

Выполните программу if3.c  в пошаговом режиме Step Over пу-
тем нажатия на клавишу F8, или щелкая мышью по соответствующе-
му значку управления отладкой.  

Когда синяя полоса окажется на строке с номером 6 (in_port = 
PORTB;), поставьте курсор мыши на колонку Value в строке PORTB 
и дважды щелкните левой кнопкой. Наберите новое число, например, 
0x07 (соответствующее диапазону 1), а затем нажмите клавишу Enter. 
Продолжайте выполнять программу в пошаговом режиме, наблюдая 
за перемещением синей полосы по ветвям программы. Убедитесь  
в правильности выполнения программы по значению, выведенному  
в порт С. 

Когда синяя полоса окажется на фигурной скобке (конец функ-
ции main), дальнейшее выполнение программы прекратится. Произве-
дите сброс микроконтроллера с помощью команды меню Run > Start 

Debugger, или щелкнув по соответствующему значку управления от-
ладкой. Введите новое значение на входах порта В, например, 0x1F 
(соответствующее диапазону 2). Выполните программу до конца в по-
шаговом режиме, наблюдая за перемещением синей полосы по ветвям 
программы. Убедитесь в правильности выполнения программы по зна-
чению, выведенному в порт С. 

Далее исследуйте работу программы при значениях 0x5F (диа-
пазон 3) и 0x8F (диапазон 4) на входах порта В.    

Объясните полученные результаты выполнения операторов про-
граммы при различных значениях данных на входах порта В. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger.  

В заключение закройте проект с помощью команды Project > Close 

Project.  
3.3.4 Исследование оператора выбора switch. Оператор switch 

(можно перевести как переключатель) используется для выбора одно-
го варианта из многих. Он проверяет, совпадает ли значение выраже-
ния с одним из значений, входящих в некоторое множество целых 
констант, и выполняет соответствующую этому значению ветвь про-
граммы. 
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Общий вид оператора switch: 
 
switch (выражение) 
{ 
      case   константа1:   
          оператор1; 
          break; 
      case   константа2: 
          оператор2; 
          break; 
      ………………… 
      case  константаN: 
          операторN; 
          break; 
       default: 
          оператор(N+1); 
} 

 
Оператор  switch  выполняется так. Сначала вычисляется выра-

жение, стоящее в скобках после ключевого слова  switch. Вычислен-
ное значение сравнивается со значением констант: константа1, кон-
станта2, …, константаN. При совпадении вычисленного значения  
с некоторой константой выполняется соответствующий ей оператор. 
Затем управление передается оператору  break (прервать), который 
производит немедленный выход из оператора  switch. Если вычислен-
ное значение не совпадает ни с одной из констант, выполняется опе-
ратор в ветви, помеченной  default (по умолчанию).    

Правила использования оператора  switch следующие. 
1 Switch требует выражения целого типа. Это значение может 

быть константой, переменной или выражением. Оператор switch не 
работает с типами данных с плавающей точкой. 

2 Значение после каждой метки case должно быть константой. 
3 Язык Си не поддерживает метки case, содержащие диапазон зна-

чений. Каждое значение должно указываться с отдельной меткой case. 
4 Необходимо использовать оператор break после каждого набо-

ра выполняемых операторов. Оператор break вызывает продолжение 
выполнения программы после завершения текущего оператора switch. 
Если не использовать оператор break, то выполнение программы про-
должится на последующих метках case. 
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5 Ветвь, помеченная словом default (по умолчанию), выполняет-
ся тогда, когда ни одна из констант ветвей  case не подходит. Ветвь 

default не является обязательной и, если она отсутствует, оператор 

switch ничего не выполнит. 
6 Набор операторов в каждой ветви  case  не нужно заключать  

в фигурные скобки. 
Примечание. В связи с тем, что в ветвях, помеченных словом  case, можно 

указывать только константу, для анализа принадлежности к диапазону значений 

следует использовать оператор  if … else if … else  множественного выбора. 
Рассмотрим программу, в которой используется оператор switch: 

 

/********************************************************** 

 switch.c – программа исследования оператора выбора  switch  

Микроконтроллер PIC16F877 

**********************************************************/ 

char  in_port;                // переменная для хранения введенного кода  
void  main( ) 

{ 

     TRISB = 0xFF;                           // настроить порт B на ввод 

     TRISC = 0;                                 // настроить порт С на вывод 

     PORTC = 0x00;                          // вывод нулей в порт С 

     in_port = PORTB;                      // ввод данных из порта B 

     switch (in_port) 

     { 

          case   0xFE: 

               PORTC = 0x01;                // вывод «вариант 1» в порт C 

               break; 

          case   0xFD: 

               PORTC = 0x02;                // вывод «вариант 2» в порт C 

               break;     

          case    0xFB:                   

               PORTC = 0x03;                // вывод «вариант 3» в порт C 

               break; 

          case    0xF7: 

               PORTC = 0x04;                // вывод «вариант 4» в порт C 

               break; 

           default: 

                PORTC = 0xFF;          // вывод «неизвестный код» в порт C 
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      } 

} 

      

В программе  switch.c  предполагается ввод определенного кода 
из порта B. С помощью оператора  switch  проверяется один из четы-

рех вариантов входного кода. Для каждого варианта кода выполняет-
ся вывод соответствующего «сообщения» в порт C. В качестве такого 

«сообщения» выбрано определенное число: 

 
Входной код из порта B Вариант кода Код для вывода в порт C 

0xFE = 11111110 Вариант 1 0x01 = 00000001 

0xFD = 11111101 Вариант 2 0x02 = 00000010 

0xFB = 11111011 Вариант 3 0x03 = 00000011 

0xF7 = 11110111 Вариант 4 0x04 = 00000100 

 
Если входной код не соответствует ни одному из указанных че-

тырех вариантов, то в порт C выводится код 0xFF = 11111111. 
Входной код представляет собой двоичное число, в котором толь-

ко один 0. Такой код получается при опросе контактов переключателей 

(клавиш), присоединенных к выводам порта B. Наличие 0 в определен-

ном разряде кода будет соответствовать замкнутому контакту.   

Задание. Выполните разработку программы в следующей по-
следовательности: 

1 С помощью команды New Project… запустите New Project 
Wizard. Создайте новый проект с именем  switch  в папке  f:\....\Lab3. 
Выберите микроконтроллер PIC16F877, тактовая частота 8 МГц. 

2 Наберите текст исходной программы  switch.c  и сохраните его 
в папке (с помощью команды меню File > Save).  

3 Выполните построение проекта (с помощью команды меню 
Build > Build). 

4 При отсутствии ошибок построения проекта переключите mik-
roC PRO в режим отладки (с помощью команды меню Run > Start 

Debugger). 
Проведите исследование работы программы switch.c  в следую-

щей последовательности. 
Для тестирования программы занесите в окно наблюдения 

Watch Values последовательно имена портов PORTB и PORTC, а за-
тем имя переменной in_port.  
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Для исследования работы программы измените формат отобра-
жения всех переменных в окне наблюдения на шестнадцатеричный. 

Выполните программу switch.c в пошаговом режиме Step Over 
путем нажатия на клавишу F8, или щелкая мышью по соответствую-
щему значку управления отладкой.  

Проверьте работу программы для всех четырех вариантов кода 
на входах порта В, указанных в таблице. В заключение установите на 
входах порта В код  0xFF. 

Объясните полученные результаты выполнения операторов про-
граммы. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger.  

В заключение закройте проект с помощью команды Project > Close 

Project.  

3.4 Задания для самостоятельной работы 

Задание 1 Напишите программу для PIC16F877, в которой  
в бесконечном цикле вводится байт данных из порта С. Если он 
меньше 100, то он передается в порт В, иначе он передается в порт D. 
Разработанную программу назовите  vvod.c. 

Для исследования программы создайте проект  с именем  vvod   
в папке f:\...\Lab3. Выберите PIC16F877, частота 8 МГц. Выполните 
построение проекта, а затем перейдите в режим отладки. 

Для тестирования разработанной программы занесите в окно 
наблюдения Watch Values имена портов PORTB, PORTC и PORTD,  
а также имя переменной для хранения введенного числа. 

Для исследования работы программы  vvod.c  выполните ее  
в пошаговом режиме Step Over. Убедитесь в правильности выполне-
ния алгоритма программы. 

Для завершения работы с отладчиком выполните команду меню 
Run > Stop Debugger.  

В заключение закройте проект с помощью команды Project > Close 

Project.  
Задание 2 Разработайте программу, которая определяет большее 

из трех введенных чисел. В программе числа вводятся последователь-
но из порта B микроконтроллера  PIC16F877: сначала – первое, затем – 

второе, а потом – третье. Для хранения каждого введенного числа надо 

предусмотреть отдельную переменную. Найденное большее число вы-

водится в порт C. Разработанную программу назовите  max.c.  



47 

Для исследования программы создайте проект с именем max  

в папке f:\...\Lab3. Выберите PIC16F877, частота 8 МГц. Выполните 
построение проекта, а затем перейдите в режим отладки. 

Для тестирования разработанной программы занесите в окно 

наблюдения Watch Values имена портов PORTB и PORTC, а также 
имена переменных для хранения введенных чисел. 

Для исследования работы программы  max.c  выполните ее в по-

шаговом режиме Step Over. Убедитесь в правильности выполнения ал-

горитма программы. 

Для завершения работы с отладчиком выполните команду меню 

Run > Stop Debugger.  

В заключение закройте проект с помощью команды Project > 

Close Project.  

4 Содержание отчета 

Укажите наименование и цель работы. Представьте тексты всех 

исследуемых программ, включая задания для самостоятельной рабо-

ты (комментарии в программах обязательны!). 

5 Контрольные вопросы 

1 Как производится настройка линий портов PIC-микроконт-
роллеров на ввод? 

2 Как производится настройка линий портов PIC-микроконт-
роллеров на вывод? 

3 Какие операторы выбора имеются в языке Си? 

4 В каких случаях оператор  switch  не может использоваться 

вместо оператора  if … else if … else? 

5 Какие функции выполняет оператор break в конструкции  

с оператором  switch? 

6 Может ли в операторе switch отсутствовать ветвь default? Как 

в этом случае выполняется программа? 
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Лабораторная работа № 4 

ИССЛЕДОВАНИЕ ОПЕРАТОРОВ ЦИКЛА  

И ПЕРЕХОДА ДЛЯ  УПРАВЛЕНИЯ 

ВЫЧИСЛИТЕЛЬНЫМ ПРОЦЕССОМ В ЯЗЫКЕ СИ 

1 Цель работы 

Изучить операторы цикла и перехода для управления вычисли-
тельным процессом в языке программирования Си. Практически ис-
следовать выполнение этих операторов в программах для микрокон-
троллеров семейства PIC16. 

2 Основные теоретические сведения 

Операторы управления вычислительным процессом позволяют 
выполнять ветвление, циклическое повторение одного или нескольких 
операторов, передачу управления в нужное место кода программы. 

Язык Си предоставляет три категории операторов управления 
программой: 

1) операторы выбора – это  if  и  switch; 
2) операторы цикла – это  while,  do … while  и  for; 
3) операторы перехода – это  break,  continue  и  goto. 
 В данной лабораторной работе Вы будете изучать и исследо-

вать операторы цикла и перехода. 

3 Порядок выполнения работы 

3.1 Создание папки для работы в IDE 

При выполнении лабораторной работы № 4 мы будем использовать 
папку с именем Lab4, которую необходимо предварительно создать. 

С этой целью откройте Вашу рабочую папку и создайте в ней  
(с помощью клавиши F7) новую папку с именем Lab4. 

В дальнейшем Вы будете записывать и хранить в этой папке все 
файлы  при выполнении лабораторной работы № 4. Полный путь  
к этой папке будет такой: 

 
f:\MPinCS\Ivanov\Lab4 
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3.2  Оператор цикла  for 

Цикл  for  является универсальным, поскольку компоненты цик-
ла могут быть произвольными выражениями. Общая форма записи 
оператора цикла  for  имеет вид 

 
for (инициализация; условие; увеличение/уменьшение переменной 

цикла) 
{ 
     тело цикла; 
} 
 

Оператор for имеет три компонента: 
1 Инициализация – это место, где обычно находится оператор 

присваивания, используемый для установки начального значения пе-
ременной цикла. 

2 Условие – это место, где находится выражение, определяющее 
условие работы цикла. 

3 Увеличение/уменьшение переменной цикла – это место, где 
определяется характер изменения переменной цикла на каждой ите-
рации, т. е. повторения цикла. 

Тело цикла – это оператор или группа операторов, которые бу-
дут выполняться в цикле. Цикл  for  работает до тех пор, пока условие 
истинно. Когда условие становится ложным, выполнение программы 
продолжается с оператора, следующего за циклом for. 

Например, в следующей программе осуществляется вывод чисел 
от 1 до 100 включительно в порт C микроконтроллера: 

 
void  main( ) 
{ 
     char  x; 
     for (x = 1; x <= 100; x++) 
          PORTC = x; 
} 
 

В программе переменная  х  изначально установлена в 1. По-
скольку х меньше 100, выполняется оператор  PORTC = x, который 
выводит х в порт C. После этого  х  увеличивается на 1 и проверяется 
условие: по-прежнему ли  х  меньше либо равен 100. Данный процесс 
продолжается до тех пор, пока  х  не станет больше 100, и в этот мо-
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мент цикл прервется. В данном примере  х  является переменной цик-
ла, которая изменяется и проверяется на каждой итерации цикла. 

Вариации цикла  for. Важной особенностью цикла  for  является 

то, что все три компонента цикла являются необязательными. 

Например, если оставить все три компонента пустыми, то полу-

чим бесконечный цикл: 

for (;  ;); 

Кроме того, тело цикла может быть пустым, т. е. не содержать 

операторов. Такие циклы могут использоваться для получения вре-
менных задержек при выполнении программы: 

for (i = 0;  i < 10000; i++); 

3.3 Оператор цикла  while 

Цикл while является разновидностью условного цикла, повто-

ряющегося до тех пор, пока условие выполнено. Таким образом, цикл  

while может не выполняться ни разу, если условие проверки изна-
чально ложно. Форма записи оператора цикла while имеет вид 

 

while (условие) 
{ 

     блок операторов; 

} 

 

Пример. Следующий цикл выводит в порт C числа от 1 до 100: 

 

int  x = 1; 

while (x < = 100) 

{ 

     PORTC = x; 

     x++; 

} 

3.4 Оператор цикла  do…while 

В цикле  do… while  условие повторения проверяется после ка-
ждого прохождения тела цикла. Следовательно, цикл  do… while  вы-

полняется, по крайней мере, один раз. 
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Форма записи цикла  do… while  имеет вид 

 

do 

{ 

       блок операторов; 

} 

while (условие); 
 

Пример. Следующий цикл выводит в порт C значения квадратов 

чисел от 2 до 10: 

 

int  x = 2; 

do 

{ 

     PORTC = x * x; 

     x++; 

} 

while (x < = 10); 

3.5  Оператор перехода  break 

Оператор  break  имеет два назначения. Первое – это окончание 
работы оператора switch. Второе – это принудительное окончание 
цикла, минуя стандартную проверку условия. Когда оператор break  

встречается в теле цикла, цикл немедленно заканчивается и выполне-
ние программы переходит на строку, следующую за циклом. 

Рассмотрим пример использования оператора  break  для дос-
рочного прекращения работы цикла  for: 

 

char  in_port,  x; 

void  main( ) 

{ 

     TRISB = 0xFF;                                 // настроить порт B на ввод 

     TRISC = 0;                                       // настроить порт С на вывод 

     PORTC = 0;  

     in_port = PORTB;                            // ввод числа из порта B 

     for (x = 1; x < 100; x++) 

     { 

            if (x == in_port) 



52 

                break;                                     // прекращение цикла вывода 
            PORTC = x;                              // вывод в порт С 
      } 
} 

В этой программе оператор цикла  for  выполняет вывод в порт С 
переменной  х, изменяющейся от 0 до 100. Однако, если значение пе-
ременной  х  будет равно переменной  in_port, введенной из порта B, 
причем это значение меньше 100,  то цикл вывода немедленно пре-
кращается.         

3.6 Оператор перехода continue 

Работа оператора  continue  чем-то похожа на работу оператора  
break. Но вместо форсированного окончания цикла оператор  continue  
переходит к следующей итерации цикла, пропуская оставшийся код 
тела цикла. 

Рассмотрим пример применения оператора continue для вывода 
в порт С чисел от 1 до 10 за исключением числа 5: 

 
void  main( ) 
{ 
     char  k;                              // объявление однобайтной переменной 
     TRISC = 0;                       // настроить порт С на вывод 
     PORTC = 0;                     // вывод нулей в порт С 
     for (k = 1; k <= 10; k++) 
     { 
           if (k == 5)                           // если k равно 5, то  
                continue;                        // пропустить вывод в порт С 
           PORTC = k;                        // вывод в порт С 
      } 
} 

3.7 Оператор перехода  goto 

Оператор  goto (идти  к ….) – это безусловный переход на метку. 
Метка – это идентификатор Си, завершающийся двоеточием. Пример 
записи оператора  goto: 

 
goto  label; 
      ……… 
     ………. 
label: ……. 
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Рассмотрим простейшую программу, где используется оператор 
перехода  goto: 

      
void main( ) 
{ 
     char  x = 1; 
     loop: 
           x++; 
           if (x <= 10) 
                goto  loop; 
} 
 

В программе реализуется цикл инкремента переменной x от 1 до 
10 с помощью оператора goto и метки loop. Очевидно, что такой цикл 
можно было бы реализовать и с использованием операторов while  
или  for. 

3.8 Задание для самостоятельной работы 

Разработайте все варианты программы, которая находит сумму 
целых чисел от 1 до 15 включительно и выводит полученное значение 
в порт С микроконтроллера PIC16F877. 

Вариант 1 Используйте в программе для организации цикла 
оператор for. Программу назовите  for.c. Создайте проект с именем for 
в папке f:\...\Lab4, выполните его построение и произведите тестиро-
вание программы. 

Примечание. Для того чтобы при отладке программы можно было занести 
переменные в окно наблюдения, их нужно объявлять в исходной программе как 
глобальные, т. е. до функции main( ). 

Вариант 2 Используйте для организации цикла суммирования 
оператор while. Программу назовите while.c. Создайте проект с име-
нем while в папке f:\...\Lab4, выполните его построение и произведите 
тестирование программы. 

Вариант 3 Используйте для организации цикла суммирования 
оператор do…while. Программу назовите  dowhile.c. Создайте проект 
с именем dowhile в папке f:\...\Lab4, выполните его построение и про-
изведите тестирование программы. 

Вариант 4 Используйте для организации цикла суммирования 
оператор for (как в варианте 1). Однако при достижении значения 
числа, равному 10, цикл суммирования должен немедленно прекра-
титься. Для этой цели примените оператор перехода  break. Програм-
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му назовите break.c. Создайте проект с именем break в папке 
f:\...\Lab4, выполните его построение и произведите тестирование 
программы. 

Вариант 5 Используйте для организации цикла суммирования 
оператор for (как в варианте 1). Однако для суммирования должны 
использоваться только четные значения чисел, т. е. 2, 4, 6 и т. п. Для 
пропуска суммирования нечетных значений чисел используйте опера-
тор перехода continue. Для проверки целого числа, например, x,  
на четность можно использовать арифметическую операцию x % 2 – 
определение остатка от деления на 2. Если результат операции будет 
равен 0, то число x – четное, если же результат будет 1, то  х – нечет-
ное. Программу назовите  continue.c. Создайте проект с именем  con-
tinue  в папке f:\...\Lab4, выполните его построение и произведите тес-
тирование программы. 

Вариант 6 Используйте для организации цикла суммирования 
чисел от 1 до 15 оператор перехода goto. Программу назовите  goto.c. 
Создайте проект с именем  goto  в папке f:\...\Lab4, выполните его по-
строение и произведите тестирование программы. 

4  Содержание отчета 

Укажите наименование и цель работы. Представьте тексты всех 
вариантов программ к заданию для самостоятельной работы (коммен-
тарии в тексте программ обязательны!). 

5 Контрольные вопросы 

1 Какие операторы цикла имеются в языке Си?  
2 Какие операторы перехода  имеются в языке Си? 
3 Чем отличаются операторы цикла while и do … while? 
4 Какими способами можно реализовать бесконечный цикл? 
5 В каких случаях удобно использовать оператор  break? 
6 Чем отличается действие оператора continue от действия опе-

ратора break? 
7 Как можно применять оператор  goto? 
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